Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
sullivas
Novice
Posts: 9
Liked: 1 time
Joined: Nov 13, 2014 7:14 pm
Contact:

Leap Day bug?

Post by sullivas » Feb 29, 2016 8:23 pm

VEB is set to run nightly at 12:30AM on my workstation (running Windows 7x64). Last night's (rather, early this morning's) backup ran fine but I noticed this little bit of information when I moused over the VEB icon.

Image

I'd suspect to see next backup as 3/1/2016 00:30, not 3/2/2016. I guess we'll find out tomorrow if it runs on schedule or if it will "leap" over 3/1. I did check a few of my physical servers running VEB and they all show the correct 3/1/2016 as next run, so it's not something across the board. Ultimately of course this isn't a big deal, just a quirk I noticed on this Leap Day.

Dima P.
Product Manager
Posts: 9601
Liked: 754 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Leap Day bug?

Post by Dima P. » Feb 29, 2016 9:25 pm

Hi sullivas,

Can you check how 'Backup no more often than' option is configured at schedule step? Thanks.

sullivas
Novice
Posts: 9
Liked: 1 time
Joined: Nov 13, 2014 7:14 pm
Contact:

Re: Leap Day bug?

Post by sullivas » Mar 01, 2016 2:27 pm

Backup ran fine last night, tool tip today shows next backup 3/2/2016 (as you'd expect for today being 3/1/2016). The "Back up no more often than every" is set to two hours, which I'm pretty sure is the default.

sullivas
Novice
Posts: 9
Liked: 1 time
Joined: Nov 13, 2014 7:14 pm
Contact:

Re: Leap Day bug?

Post by sullivas » Mar 01, 2016 2:37 pm

I just remembered something...yesterday while working on a completely unrelated problem (and also thinking it was somehow related to Leap Day, because that particular piece of software is that stupid it could have been), I set my date forward a day to March 1 for just a few minutes. When that didn't fix it I immediately put it back to the correct 2/29 date. Perhaps VEB picked up on that date forward change somehow? But if that's the case you'd also think it would've picked up changing the date back. And as you can see from the screenshot, the date was set correctly when I noticed the VEB tooltip.

Dima P.
Product Manager
Posts: 9601
Liked: 754 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Leap Day bug?

Post by Dima P. » Mar 02, 2016 2:54 pm

Thanks for the heads up. Might be, since it counts the local time and it was changed manually. How the things are going now?

sullivas
Novice
Posts: 9
Liked: 1 time
Joined: Nov 13, 2014 7:14 pm
Contact:

Re: Leap Day bug?

Post by sullivas » Mar 02, 2016 2:55 pm

Everything has continued to operate fine, the problem was merely cosmetic.

Dima P.
Product Manager
Posts: 9601
Liked: 754 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Leap Day bug?

Post by Dima P. » Mar 02, 2016 2:57 pm

Good – I’ll ask our QA team to pay attention to this date metric, so thanks for reporting!

Post Reply

Who is online

Users browsing this forum: No registered users and 13 guests