Restore complets successfully but BSOD on boot...

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby remko.de.koning » Thu Jul 23, 2015 9:32 am

kirkgj wrote:I was able to get the restore to boot successfully by selecting boot from last known good configuration after pressing F8 following the restore. That solved my immediate need.


I just encountered the same problem after a test restore of a new machine for our Laboratory. Got a little bit nervous when the machine did not want to boot. Same blue screen. Taking a backup is one thing... Getting it restored is another.

Good to see such an active forum and with good feedback on solutions.

Your comment was of great help! :D Thanks!
remko.de.koning
Enthusiast
 
Posts: 72
Liked: 13 times
Joined: Wed May 21, 2014 12:15 pm
Full Name: Remko de Koning

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Dima P. » Fri Jul 24, 2015 12:27 pm

remko.de.koning,
Thanks for the heads up! We have a working fix at the support team, so feel free to contact them in order to get and test it.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby smaygc82 » Tue Aug 11, 2015 12:42 pm

Dima P.,
Hey I'm having the same issue here trying to Bare Metal Recovery and I get the BSOD with pcw.sys after first boot. I have the latest version of Endpoint Backup installed too. I was able to work around the issue by pressing F8 and Last KNown Good Configuration. The problem here is all the drivers are missing so it was hardly a painless restore.

Can I have access to this fix that's being talked about?
smaygc82
Lurker
 
Posts: 1
Liked: never
Joined: Tue Aug 11, 2015 12:38 pm
Full Name: Sean May

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Vitaliy S. » Tue Aug 11, 2015 4:23 pm

Yes, you can get this fix by contacting our technical team. Thanks!
Vitaliy S.
Veeam Software
 
Posts: 19558
Liked: 1102 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Dima P. » Wed Aug 12, 2015 10:25 am

smaygc82,
Can I have access to this fix that's being talked about?

Just to clarify, have you installed the latest 1.1 upgrade or not? Thanks
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby hoFFy » Thu Sep 10, 2015 6:27 am

Had this one too, we were using the latest available version.
Booting with F8, last known good configuration -> problem solved.
VMCE 7 / 8 / 9, VCP-DC 5 / 5.5 / 6, MCITP:SA
Blog: machinewithoutbrain.de
hoFFy
Veeam ProPartner
 
Posts: 161
Liked: 25 times
Joined: Fri Apr 27, 2012 1:10 pm
Location: Germany / Lohne
Full Name: Sebastian Hoffmann

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Dima P. » Thu Sep 10, 2015 4:40 pm

Thanks for the heads up Sebastian!
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby lowlander » Tue Oct 20, 2015 2:33 pm

Can you send me the fix referred to in this post ?
Case # 01087722
lowlander
Service Provider
 
Posts: 267
Liked: 20 times
Joined: Sun Dec 28, 2014 11:48 am

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby lowlander » Wed Oct 21, 2015 11:13 am

pcw.sys is apparently the Performance Counters for Windows driver.

When we boot the restored machine using the recovery media and enter commandline c:\windows\system32\drivers\pcw.sys can be deleted. After a reboot system is up and running. Is this normal behaviour for restoring a backup to another type of hardware ?
lowlander
Service Provider
 
Posts: 267
Liked: 20 times
Joined: Sun Dec 28, 2014 11:48 am

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Dima P. » Wed Oct 21, 2015 12:46 pm

Based on the fix we've implemented the additional functionality to cancel the old drivers injection upon recovery.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Gostev » Wed Oct 21, 2015 10:46 pm

Dima meant to say that there is a new option available in the recovery UI for this. I believe it was added in version 1.1
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby lowlander » Thu Oct 22, 2015 6:30 am

Hi Gostev,

thanks for the clarification. Is this a built in option or something you can select / deselect ? We tried to find this option, but the only option is to select hardware drivers for storage and network in de Windows "Hardware Drivers". You can then opt to inject them in the Operating system.
lowlander
Service Provider
 
Posts: 267
Liked: 20 times
Joined: Sun Dec 28, 2014 11:48 am

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Dima P. » Thu Oct 22, 2015 9:35 pm

Hi lowlander,

I've actually answered the same question you’ve posted in another thread :mrgreen:
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

[MERGED]: Bluescreen after Restore

Veeam Logoby tomcek » Wed Dec 09, 2015 9:13 am

Hello,

I want to inform about my expereineces with VEB.

Yesterday I have made a restore after trouble with my Windows 7 installation.

My Recovery Media is a USB device created on the same machine. Booting from the USB device was easy, installation of network drivers too. My backups are located on a cifs share in our network. I have made a restore of my c: partition (no restore of the 200MB system reserved partition). The restore finished without any error.

Problem: Windows did not boot - Bluescreen with every try to reboot (see picture from dropbox link).

https://www.dropbox.com/s/2b8wa5u0mj0fy14/IMG_5345.JPG

Solution: Entering Boot-Menu with F8 and choosing the "Last Known Good Configuration" option. After that windows started without any problems. For me it seems that with the "Last Known Good Configuration" registry entries were corrected.

Did the restore something wrong?

In my restored and running Windows 7 installation I have made "sfc /scannow" ... al lot of problems were corrected (I have a log from it).


Best regards, Tom
tomcek
Novice
 
Posts: 4
Liked: never
Joined: Wed Dec 09, 2015 8:33 am

Re: Restore complets successfully but BSOD on boot...

Veeam Logoby Dima P. » Wed Dec 09, 2015 12:50 pm

Hello Tom,

I am sorry to hear that. To investigate the recovery issues we need the recovery log (usually it is placed to the repository where you selected backup files from). If it’s possible, please share these logs with me (Dropbox/OneDrive or any public hosting will work).

Additionally, if you have VEB installed on another machine you can open a support case and share this information with support representative once requested.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

PreviousNext

Return to Veeam Agent for Windows



Who is online

Users browsing this forum: jeffsterv and 8 guests