Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
remko.de.koning
Enthusiast
Posts: 90
Liked: 17 times
Joined: May 21, 2014 12:15 pm
Full Name: Remko de Koning
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by remko.de.koning » Jul 23, 2015 9:32 am

kirkgj wrote:I was able to get the restore to boot successfully by selecting boot from last known good configuration after pressing F8 following the restore. That solved my immediate need.
I just encountered the same problem after a test restore of a new machine for our Laboratory. Got a little bit nervous when the machine did not want to boot. Same blue screen. Taking a backup is one thing... Getting it restored is another.

Good to see such an active forum and with good feedback on solutions.

Your comment was of great help! :D Thanks!

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Jul 24, 2015 12:27 pm

remko.de.koning,
Thanks for the heads up! We have a working fix at the support team, so feel free to contact them in order to get and test it.

smaygc82
Lurker
Posts: 1
Liked: never
Joined: Aug 11, 2015 12:38 pm
Full Name: Sean May
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by smaygc82 » Aug 11, 2015 12:42 pm

Dima P.,
Hey I'm having the same issue here trying to Bare Metal Recovery and I get the BSOD with pcw.sys after first boot. I have the latest version of Endpoint Backup installed too. I was able to work around the issue by pressing F8 and Last KNown Good Configuration. The problem here is all the drivers are missing so it was hardly a painless restore.

Can I have access to this fix that's being talked about?

Vitaliy S.
Product Manager
Posts: 22866
Liked: 1539 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Vitaliy S. » Aug 11, 2015 4:23 pm

Yes, you can get this fix by contacting our technical team. Thanks!

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Aug 12, 2015 10:25 am

smaygc82,
Can I have access to this fix that's being talked about?
Just to clarify, have you installed the latest 1.1 upgrade or not? Thanks

hoFFy
Service Provider
Posts: 175
Liked: 27 times
Joined: Apr 27, 2012 1:10 pm
Full Name: Sebastian Hoffmann
Location: Germany / Lohne
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by hoFFy » Sep 10, 2015 6:27 am

Had this one too, we were using the latest available version.
Booting with F8, last known good configuration -> problem solved.
VMCE 7 / 8 / 9, VCP-DC 5 / 5.5 / 6, MCITP:SA
Blog: machinewithoutbrain.de

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Sep 10, 2015 4:40 pm

Thanks for the heads up Sebastian!

lowlander
Service Provider
Posts: 308
Liked: 21 times
Joined: Dec 28, 2014 11:48 am
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by lowlander » Oct 20, 2015 2:33 pm

Can you send me the fix referred to in this post ?
Case # 01087722

lowlander
Service Provider
Posts: 308
Liked: 21 times
Joined: Dec 28, 2014 11:48 am
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by lowlander » Oct 21, 2015 11:13 am

pcw.sys is apparently the Performance Counters for Windows driver.

When we boot the restored machine using the recovery media and enter commandline c:\windows\system32\drivers\pcw.sys can be deleted. After a reboot system is up and running. Is this normal behaviour for restoring a backup to another type of hardware ?

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Oct 21, 2015 12:46 pm

Based on the fix we've implemented the additional functionality to cancel the old drivers injection upon recovery.

Gostev
SVP, Product Management
Posts: 24638
Liked: 3467 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Gostev » Oct 21, 2015 10:46 pm

Dima meant to say that there is a new option available in the recovery UI for this. I believe it was added in version 1.1

lowlander
Service Provider
Posts: 308
Liked: 21 times
Joined: Dec 28, 2014 11:48 am
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by lowlander » Oct 22, 2015 6:30 am

Hi Gostev,

thanks for the clarification. Is this a built in option or something you can select / deselect ? We tried to find this option, but the only option is to select hardware drivers for storage and network in de Windows "Hardware Drivers". You can then opt to inject them in the Operating system.

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Oct 22, 2015 9:35 pm

Hi lowlander,

I've actually answered the same question you’ve posted in another thread :mrgreen:

tomcek
Novice
Posts: 4
Liked: never
Joined: Dec 09, 2015 8:33 am
Contact:

[MERGED]: Bluescreen after Restore

Post by tomcek » Dec 09, 2015 9:13 am

Hello,

I want to inform about my expereineces with VEB.

Yesterday I have made a restore after trouble with my Windows 7 installation.

My Recovery Media is a USB device created on the same machine. Booting from the USB device was easy, installation of network drivers too. My backups are located on a cifs share in our network. I have made a restore of my c: partition (no restore of the 200MB system reserved partition). The restore finished without any error.

Problem: Windows did not boot - Bluescreen with every try to reboot (see picture from dropbox link).

https://www.dropbox.com/s/2b8wa5u0mj0fy14/IMG_5345.JPG

Solution: Entering Boot-Menu with F8 and choosing the "Last Known Good Configuration" option. After that windows started without any problems. For me it seems that with the "Last Known Good Configuration" registry entries were corrected.

Did the restore something wrong?

In my restored and running Windows 7 installation I have made "sfc /scannow" ... al lot of problems were corrected (I have a log from it).


Best regards, Tom

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Dec 09, 2015 12:50 pm

Hello Tom,

I am sorry to hear that. To investigate the recovery issues we need the recovery log (usually it is placed to the repository where you selected backup files from). If it’s possible, please share these logs with me (Dropbox/OneDrive or any public hosting will work).

Additionally, if you have VEB installed on another machine you can open a support case and share this information with support representative once requested.

tomcek
Novice
Posts: 4
Liked: never
Joined: Dec 09, 2015 8:33 am
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by tomcek » Dec 10, 2015 8:06 am

Hi Dima,

I have sent you a private message with a link to the recovery log in my dropbox.

I have VEB installed yesterday on second Windows 10 machine. The Recovery Media was the same USB device but created on the windows 10 machine. Backup and Restore went fine. First reboot without any problems.

An additional test on the Windows 7 machine I can not do, because it´s my PC for daily work.

Is there anything else I can do?

Best regards, Tom

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Dec 10, 2015 2:20 pm

Thanks Tom! I got the logs and forwarded them to QA team for investigation. I'll follow up once I hear back anything.

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Dec 12, 2015 11:54 pm

Hi Tom,

We checked your logs and it seems that BSOD was caused by wrong drivers being injected after recovery. That’s might happen when recovery media was created on another machine or you are performing recovery to a dissimilar hardware.

Try to uncheck “Inject drivers” (Recovery Media > Tools > Load Drivers) option before performing a recovery

Image

oliver.siems
Lurker
Posts: 1
Liked: 1 time
Joined: Dec 14, 2015 7:58 am
Full Name: Oliver Siems
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by oliver.siems » Dec 14, 2015 8:03 am 1 person likes this post

I booted with recovery media into Commandline, I deleted c:\windows\system32\driver\pcw.sys and booted the pc into windows two times and everything was fine

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Dec 14, 2015 10:47 pm

Hello and welcome to the forums Oliver.

Thanks for sharing – might be a good idea to run sfc /scannow afterwards.

tomcek
Novice
Posts: 4
Liked: never
Joined: Dec 09, 2015 8:33 am
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by tomcek » Dec 21, 2015 8:24 am

Dima P. wrote:Hi Tom,

We checked your logs and it seems that BSOD was caused by wrong drivers being injected after recovery. That’s might happen when recovery media was created on another machine or you are performing recovery to a dissimilar hardware.

Try to uncheck “Inject drivers” (Recovery Media > Tools > Load Drivers) option before performing a recovery
Hi Dima, the recovery tool was made on the same machine :shock:

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Dec 21, 2015 12:14 pm

tomcek,

According to the QA team, this might be caused by USB device driver collected during the recovery media creation. Have you tried the recovery with drivers being not injected from the disk as I recommended above?

Jan1
Influencer
Posts: 19
Liked: 2 times
Joined: Dec 29, 2014 7:15 pm
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Jan1 » Dec 29, 2015 3:19 pm

Hello,

My case:

Laptop Dell Latitude 5530, windows 7 prof

I did backup to change hard disk to SSD. Everything was perfect until I put laptop to docking station. Then I have BSOD.

Current situation:

Laptop without docking station works fine.
Laptop with docking station - BSOD

I hadn't time to do deep investigation so I remember only 0000007E error on BSOD
Any ideas ?

Jan

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Dec 29, 2015 3:23 pm

Hi Jan,

Have you tried not to 'Inject these drivers into operating system while performing a bare metal recovery"? Can you share you recovery log?

Jan1
Influencer
Posts: 19
Liked: 2 times
Joined: Dec 29, 2014 7:15 pm
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Jan1 » Jan 04, 2016 5:42 am 2 people like this post

Hi,

I unchecked "Inject drivers" and now works fine.

Thanks!!

Jan

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Jan 04, 2016 12:33 pm

Awesome - thanks for the heads up and have a happy New Year!

jasonb225
Lurker
Posts: 1
Liked: never
Joined: Jan 07, 2016 3:07 pm
Full Name: Jason Bordelon
Contact:

[MERGED]: Blue Screen BSOD when restoring to vmware VMDK

Post by jasonb225 » Jan 07, 2016 3:35 pm

I'm attempting to restore a windows 7 64-bit workstation to ESXi 5.5 vmdk format. I'm able to export the disk to a datastore, create a new vm, and attach the exported Virtual disk file to the newly created vm. Problem is I get a blue screen when booting.
Image

Dima P.
Product Manager
Posts: 10444
Liked: 849 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Dima P. » Jan 07, 2016 7:54 pm

Hi Jason,

Kindly, check this KB article. Thanks.

Gostev
SVP, Product Management
Posts: 24638
Liked: 3467 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Gostev » Jan 08, 2016 12:22 am

Your issue is basically the reason why this functionality is called "Export" as opposed to "Restore". It is merely an export into a different format, while what you are trying to do is called P2V conversion, which requires additional steps (particularly around drivers) to be performed on a system partition.

Delo123
Expert
Posts: 361
Liked: 109 times
Joined: Dec 28, 2012 5:20 pm
Full Name: Guido Meijers
Contact:

Re: Restore complets successfully but BSOD on boot...

Post by Delo123 » Jan 08, 2016 9:27 pm 1 person likes this post

There are some great Tools available to inject Drivers after Mainboard swap (what you practically are doing).
You should have replaced custom ide/scsi drivers with default Microsoft to be able to boot the vm. To do it now you would Need of of those adaptive restore tools!

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 11 guests