Restore using B&R stuck in "Please wait"

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Restore using B&R stuck in "Please wait"

Veeam Logoby DenisK » Wed Apr 29, 2015 12:57 pm

Just installed Patch#2 for B&R 8 and for VeeamOne. All working fine. Installed latest version of EndPoint Backup on a workstation. Added backup folder on NAS and gave everyone SMB permissions. Both B&R and PC can see and write to folder. Added folder to B&R as repository and modded permissions for Everyone. For giggles, made user, on which Endpoint is installed, a local administrator.

So backup works just fine. I even see the job in B&R. From PC, I can launch a restore successfully and restore a file with no issues. For testing, I just use File level backup so I could just do a test backup of Documents.

However, when trying to start a restore using B&R console, the process goes fine till the Backup Browser Window opens and I'm stuck on Please Wait. I'm not thinking permissions here right now since everything has been dumbed down. Yesterday, when testing the permissions, the lock on waiting was so bad I had to hard reboot my backup server because I couldn't right-click to kill app, kill it from task manager, or kill the service remotely from another server. I have added and removed repositories and still get the same "waiting."

Anyone else see this?
DenisK
Veeam Vanguard
 
Posts: 21
Liked: 3 times
Joined: Thu Jun 05, 2014 7:41 pm

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby Dima P. » Wed Apr 29, 2015 1:05 pm

Hello DenisK,
What happens if you run file level restore on the same backup file within Endpoint?
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby DenisK » Wed Apr 29, 2015 1:23 pm

Dima P. wrote:Hello DenisK,
What happens if you run file level restore on the same backup file within Endpoint?


Thanks Dima. I posted that already I think. If I run the file level restore from the PC using Endpoint, it worked just fine. Running that scenario again and it's taking a bit and I'll post results shortly.

Edit: Weird. I'm getting the same hang. It refuses to allow you to launch task manager to kill it. Gotta hard reboot PC now. :(
DenisK
Veeam Vanguard
 
Posts: 21
Liked: 3 times
Joined: Thu Jun 05, 2014 7:41 pm

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby DenisK » Wed Apr 29, 2015 1:36 pm

I'm going to have to build, when I have time now, a virtual test PC and server, to work on this since hard rebooting is not an option here.
DenisK
Veeam Vanguard
 
Posts: 21
Liked: 3 times
Joined: Thu Jun 05, 2014 7:41 pm

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby Dima P. » Wed Apr 29, 2015 11:37 pm

DenisK,
It looks like the connectivity issue but I can’t be sure. Please open a support case thru the Endpoint Control Panel > Support > Tech support and post here the case ID once done so we could check your logs with QA team. Thanks in advance.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby DenisK » Thu Apr 30, 2015 11:45 am

Dima P. wrote:DenisK,
It looks like the connectivity issue but I can’t be sure. Please open a support case thru the Endpoint Control Panel > Support > Tech support and post here the case ID once done so we could check your logs with QA team. Thanks in advance.


Probably. I'm working through it now and my initial hunch is that there is a mismatch between the credentials needed to access B&R from the Endpoint and the permissions needed to access the the SMB share. I'll post more as I work through it. Even if I confirm this, the fact that restore process consumes all resources without an apparent timeout (I've seen 15min+) forcing a hard restart should be investigated. Thanks.
DenisK
Veeam Vanguard
 
Posts: 21
Liked: 3 times
Joined: Thu Jun 05, 2014 7:41 pm

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby DenisK » Thu Apr 30, 2015 12:55 pm

Got it working and there was a mismatch in credentials between what is needed to enumerate the backup repositories and the actual credentials needed to restore from the NAS. I've worked around that by creating explicit permissions with Credential Manager. The program shouldn't freeze the whole system up though. Anyone this one can be put to bed for now.
DenisK
Veeam Vanguard
 
Posts: 21
Liked: 3 times
Joined: Thu Jun 05, 2014 7:41 pm

Re: Restore using B&R stuck in "Please wait"

Veeam Logoby Mike Resseler » Sat May 02, 2015 6:12 am

Denis,

Thanks for the heads up and glad that it is resolved now. I do agree with you that we shouldn't freeze up the system and I am convinced that this will be further investigated.

Thanks

Mike
Mike Resseler
Veeam Software
 
Posts: 3151
Liked: 362 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler


Return to Veeam Agent for Windows



Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 11 guests