Restores failing since Update2 of VBR

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Restores failing since Update2 of VBR

Veeam Logoby Jeff L » Tue Aug 30, 2016 1:01 pm

Updated VBR to update 2, now all our Endpoint backups fail restores with error:

"Restore failed: unable to find assembly Veeam.Backup.Model, Version=9.0.0.0,Culture=neutral, PublicKeyToken=bfd684de2276783a."

No updates are available for VEB. (currently running 1.5.306)
Jeff L
Influencer
 
Posts: 23
Liked: 4 times
Joined: Tue Jul 26, 2016 9:35 am
Full Name: Jeff Longley

Re: Restores failing since Update2 of VBR

Veeam Logoby JaxIsland7575 » Tue Aug 30, 2016 2:24 pm 1 person likes this post

Did you open a support case through the Control Panel in VEB? I would want to get a set of logs over to support then post the case # in this thread for tracking.
VMCE v9
JaxIsland7575
Veeam Vanguard
 
Posts: 364
Liked: 98 times
Joined: Mon Apr 27, 2015 1:59 pm
Location: NY, USA
Full Name: Ryan Jacksland

Re: Restores failing since Update2 of VBR

Veeam Logoby Dima P. » Tue Aug 30, 2016 2:28 pm

Hi Jeff,

Indeed, please submit a support case thru the VEB's Control Panel and post the case ID to this thread, so I could pass it direclty to QA. Thanks in advance
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restores failing since Update2 of VBR

Veeam Logoby Jeff L » Tue Aug 30, 2016 2:59 pm

From the restore client or from live client?
Jeff L
Influencer
 
Posts: 23
Liked: 4 times
Joined: Tue Jul 26, 2016 9:35 am
Full Name: Jeff Longley

Re: Restores failing since Update2 of VBR

Veeam Logoby Dima P. » Tue Aug 30, 2016 6:25 pm

Now I am confused. If the recovery was not working how you’ve managed to restore the machine? I was under impression that you got this error while running a Bare Metal Recovery.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restores failing since Update2 of VBR

Veeam Logoby Jeff L » Wed Aug 31, 2016 7:27 am

I meant from the restore ISO (the BMR side) or from the live client that the backups are running from.

The client is still live, I regularly test the restore process.
Jeff L
Influencer
 
Posts: 23
Liked: 4 times
Joined: Tue Jul 26, 2016 9:35 am
Full Name: Jeff Longley

Re: Restores failing since Update2 of VBR

Veeam Logoby Dima P. » Wed Aug 31, 2016 5:35 pm

Understood, thanks. Alive client works then.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: Restores failing since Update2 of VBR

Veeam Logoby Jeff L » Thu Sep 01, 2016 10:38 am

Support case raised, 01894613
Jeff L
Influencer
 
Posts: 23
Liked: 4 times
Joined: Tue Jul 26, 2016 9:35 am
Full Name: Jeff Longley

Re: Restores failing since Update2 of VBR

Veeam Logoby Anguel » Thu Sep 01, 2016 12:27 pm

For me a backup failed with a similar error. The endpoint had not been online for a longer time, so the backup returned a similar error:
Code: Select all
Full backup file merge failed Error: Die Assembly "Veeam.Backup.Model, Version=9.0.0.0, Culture=neutral, PublicKeyToken=bfd684de2276783a" kann nicht gefunden werden.

This means that the assembly cannot be found in German.
Then I ran backup again and it seems to run ok now.
I'm using latest updates for VBR and VEB.
Feel free to forward this to support if interested, I don't have time to report such bugs as this takes time.
Anguel
Enthusiast
 
Posts: 79
Liked: 6 times
Joined: Thu Apr 16, 2015 9:01 am

Re: Restores failing since Update2 of VBR

Veeam Logoby Jeff L » Mon Sep 05, 2016 7:12 am

Still with support, but looks like it could be related to the copy job on VBR;

The orginal backup works, the copy backup fails with the error.
Jeff L
Influencer
 
Posts: 23
Liked: 4 times
Joined: Tue Jul 26, 2016 9:35 am
Full Name: Jeff Longley

Re: Restores failing since Update2 of VBR

Veeam Logoby Jeff L » Tue Sep 06, 2016 12:50 pm 1 person likes this post

All resolved! the solution was to disable the copy backup job. The explanation?
"The thing is that backup copy job is working continuously and it blocks backup files (vbk,vib and so on) for read\write operations.
Disabling the job unlocks the files and allows Endpoint to read them. If you plan to run a restore in future, please disable Backup copy job. It doesn't happen always, but in case of such error the first step is to disable a backup copy job."
Jeff L
Influencer
 
Posts: 23
Liked: 4 times
Joined: Tue Jul 26, 2016 9:35 am
Full Name: Jeff Longley

Re: Restores failing since Update2 of VBR

Veeam Logoby Dima P. » Tue Sep 06, 2016 2:39 pm

Hi guys,

True, backup copy job may affect merge process of the VEB. I’ve just talked to QA team: this behavior was marked as a bug and will be fixed in upcoming versions of Veeam Backup and Replication 9.5 and Veeam Agent for Windows 2.0
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov


Return to Veeam Agent for Windows



Who is online

Users browsing this forum: Yahoo [Bot] and 11 guests