Standalone backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)
Post Reply
ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Server extremly slow after installing Veeam Agent

Post by ESH » Aug 12, 2019 6:26 am

Hello,

a customer has a problem with the server responding extremely slowly and delayed after installing Veeam Agent. Even opening folders directly on the server is sluggish and slow.
Naturally, this also manifests itself on the clients when using the DMS software. The printing of bills takes 2-3 minutes instead of 5 seconds.

However, you can see no workload, neither in the CPU, nor in the disk. (Performance Monitor in Windows)

When uninstalling the software, the server is again performing well immediately after completion of the uninstallation. a reboot is not necessary.

Windows Server 2008 R2 64bit. Latest update status
Intel Xeon X3430 @ 2.4Ghz
8GB Ram
Raid 5 consisting of 15000rpm sas
Veeam Agent for Windows 3.0.2.1170 (previously 2.x with the same issues)

Dima P.
Product Manager
Posts: 10537
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by Dima P. » Aug 12, 2019 10:48 am

Hello and welcome to the community Sven.

Any chance you have any antivirus software installed that could potentially block Veeam Agent for Windows (and maybe start checking it's components for viruses)? Cheers!

ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by ESH » Aug 15, 2019 6:52 am

Hello and thanks!

We've tested it by uninstalling the antivirus Software for 2 Days. No Change.

Dima P.
Product Manager
Posts: 10537
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by Dima P. » Aug 15, 2019 12:12 pm

Thanks for the update Sven. Unfortunately I am out of ideas, so please raise a support case and let our team investigate this issue. Please do not forget to share the case Id in this thread for future reference. Cheers!

ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by ESH » Aug 15, 2019 1:29 pm

Thats what i've done before.
This is Veeam Support with a system generated courtesy notification. Unfortunately, due to high Support Team load we were unable to process your request and it has been archived automatically. Please keep in mind that as a Free Product case, Support is provided on a best effort basis. Support Policy for Free Products can be found here: https://www.veeam.com/veeam_software_su ... icy_ds.pdf
We can imagine how frustrating this must be to not get a valuable reply. Regardless of the Support Contract type, our goal is to ensure the issue is resolved to your satisfaction. Alternatively, visit the Forums to find an answer or ask a question to our helpful Community: https://forums.veeam.com/
That's why I have created a thread here in the forum :mrgreen: :(

The Case ID was 03703780

Dima P.
Product Manager
Posts: 10537
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by Dima P. » Aug 15, 2019 5:16 pm

Understood, thank you! I'll ask support team to reopen the case and start the investigation process.

nitramd
Expert
Posts: 192
Liked: 44 times
Joined: Feb 16, 2017 8:05 pm
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by nitramd » Aug 15, 2019 7:57 pm

Sven,

Do you know what the memory utilization is on the server?

ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by ESH » Aug 16, 2019 7:55 am

30-40% of 8GB RAM are in use.

nitramd
Expert
Posts: 192
Liked: 44 times
Joined: Feb 16, 2017 8:05 pm
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by nitramd » Aug 16, 2019 4:30 pm

Sven,

What's the network utilization like on the server? I suspect it would be low so just something to rule out.

Any idea how large the server's pagefile is? And how is this pagefile being managed, i.e. is it system managed, a custom size or no pagefile?

How much free disk space is available on the boot drive (C:\)?

Have you tried using System Internals Process Explorer?

ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by ESH » Aug 19, 2019 2:02 pm

Network Utilization 0-5% at 3pm in task manager - with process explorer 90-120kb/s average
Pagefile is 8GB on C:\ system managed
62GB used of 99GB on C:\

i want to check this tomorrow morning again

Image Image Image

Dima P.
Product Manager
Posts: 10537
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by Dima P. » Aug 20, 2019 6:50 pm

Thanks for sharing! The last screenshot shows lots of I/O activity for the APC software (which I assume is some sort of power management agent) - is that expected?

nitramd
Expert
Posts: 192
Liked: 44 times
Joined: Feb 16, 2017 8:05 pm
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by nitramd » Aug 21, 2019 1:55 pm

Sven,

So there's a UPS attached to this server?

Sophos also has a high rate of I/O activity but nothing like the APC instance.

Is the C: drive a separate hard drive or is it a partition on the RAID 5 array?

ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by ESH » Aug 26, 2019 11:30 am

Yes, UPS is attached.

C:\ is included in the Raid 5 array

nitramd
Expert
Posts: 192
Liked: 44 times
Joined: Feb 16, 2017 8:05 pm
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by nitramd » Aug 27, 2019 2:29 pm

Here's what we know so far, your client has several processes that I/O intensive; listed in order from highest to lowest:
1.) APC PowerChute agent
2.) Spohos AV processes
3.) MS SQL
4.) Veeam Agent for Windows - when installed
5.) Network Monitoring process

Coupled with the I/O intensive processes is that the fact that the boot drive (C:\) is part of the RAID 5 array where data is stored - I assume.

I would suggest that the RAID array has a lot of resource contention driven by the demands of the C:\ drive, where all of the processes "live and work", and the data that is stored on the rest of the array.

Imagine the read/write heads on the disks, how they're constantly moving back and forth across the platters trying to read and write data; think of a
seismograph that measures earthquakes.

The only thing I can think of that might help is to put the C:\ drive on its own separate disk. Also, another 8GB om RAM would help. I realize that this may not be possible due to expense.

Hope this helps.

ESH
Novice
Posts: 7
Liked: never
Joined: Aug 12, 2019 6:21 am
Full Name: Sven
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by ESH » Aug 28, 2019 7:03 am

Hmmm, so why is the Server instantly fast after completion of the uninstall of veeam? thats the strange thing!

The effort should be kept as low as possible because the server will be replaced next year. nothing should be invested.

Dima P.
Product Manager
Posts: 10537
Liked: 858 times
Joined: Feb 04, 2013 2:07 pm
Full Name: Dmitry Popov
Location: Prague
Contact:

Re: Server extremly slow after installing Veeam Agent

Post by Dima P. » Aug 29, 2019 11:28 am

why is the Server instantly fast after completion of the uninstall of veeam?
Can you make a couple of screenshots of your resource monitor (similar to the one that you've shared before) during backup activity and after backup activity to compare the difference? Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests