Services suddenly stopped working

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

Services suddenly stopped working

Veeam Logoby xanod » Wed Apr 12, 2017 9:22 pm

Hi everyone,
I LOVE Veeam Agent for Windows, everything is OK on all my computers, except two of them.

After the fresh install the GUI is innacessible and just a simple indication says: "Service suddenly stopped working. Please refer to this article for troubleshooting this issue."

I tried to uninstall and reinstall (including all the SQL components) without antivirus (ESET).
The KB1959 didn't fix it.
The RecreateDatabase registry didn't fix it.

I've found errors in Veeam logs in ProgramData:

Code: Select all
[12.04.2017 22:48:42] <08> Info     [AutoUpdate] Checking updates for version 1.5.0.306
[12.04.2017 22:48:42] <08> Info     [AutoUpdate] Downloading new update definition file from https://autolk.veeam.com/json-rpc.php
[12.04.2017 22:48:43] <08> Info     [AutoUpdate] Result is NoUpdates
[12.04.2017 22:48:43] <08> Info     [AutoUpdate] List of alive updates in DB:
[12.04.2017 22:48:43] <08> Info     [AutoUpdate] -----------------------------
[12.04.2017 22:48:43] <08> Info     [AutoUpdate] -----------------------------
[12.04.2017 22:48:43] <05> Info     Enable user notification 085b8fc5-aaa6-42a0-b230-00a88732ba3e
[12.04.2017 22:48:44]      Info     < d98>         Volume name: \\?\GLOBALROOT\Device\CdRom0, type: VDS_VT_SIMPLE, is online
[12.04.2017 22:48:44]      Info     < d98>           GUID path names:
[12.04.2017 22:48:44]      Info     < d98>             \\?\Volume{f25e173f-674a-11e5-824c-806e6f6e6963}\
[12.04.2017 22:48:44]      Info     < d98>         Volume name: \\?\GLOBALROOT\Device\HarddiskVolume1, type: VDS_VT_SIMPLE, is online
[12.04.2017 22:48:44]      Info     < d98>           GUID path names:
[12.04.2017 22:48:44]      Info     < d98>             \\?\Volume{ad8b76c1-6751-11e5-824e-0023ae756cc5}\
[12.04.2017 22:48:44]      Info     < d98>         Volume name: \\?\GLOBALROOT\Device\HarddiskVolume2, type: VDS_VT_SIMPLE, is online
[12.04.2017 22:48:44]      Info     < d98>           GUID path names:
[12.04.2017 22:48:44]      Info     < d98>             \\?\Volume{a83a1117-443b-11e6-8273-806e6f6e6963}\
[12.04.2017 22:48:45]      Info     < d98>         Volume name: \\?\GLOBALROOT\Device\HarddiskVolume3, type: VDS_VT_SIMPLE, is online
[12.04.2017 22:48:45]      Info     < d98>           GUID path names:
[12.04.2017 22:48:45]      Info     < d98>             \\?\Volume{70300129-4435-11e6-826f-806e6f6e6963}\
[12.04.2017 22:48:45]      Info     < d98>     Enumerating VDS volumes. Ok.
[12.04.2017 22:48:45]      Info     < d98> Boot volume is '{70300129-4435-11e6-826f-806e6f6e6963}', disk number: '2'.
[12.04.2017 22:48:45]      Info     < d98> system volume device: '\Device\HarddiskVolume3'.
[12.04.2017 22:48:45]      Info     < d98> Volume '\\?\Volume{70300129-4435-11e6-826f-806e6f6e6963}' is an MBR system volume.
[12.04.2017 22:48:45] <19> Info         Layout: '<ShadowVolumesLayout><ShadowVolumes/><LiveVolumes><LiveVolume Id="{70300129-4435-11e6-826f-806e6f6e6963}" Name="\\?\Volume{70300129-4435-11e6-826f-806e6f6e6963}" Label="" FilesystemType="NTFS" Capacity="256059465728" UsedSize="48930406400" Roles="6" VdsType="VDS_VT_SIMPLE" VdsOfflineStatus="false"><MountPoints><MountPoint Path="C:\"/></MountPoints><Extents><Extent DiskNumber="2" StartingOffset="1048576" ExtentLength="256059465728"/></Extents></LiveVolume><LiveVolume Id="{ad8b76c1-6751-11e5-824e-0023ae756cc5}" Name="\\?\Volume{ad8b76c1-6751-11e5-824e-0023ae756cc5}" Label="CARTO" FilesystemType="NTFS" Capacity="300058182144" UsedSize="265691513344" Roles="0" VdsType="VDS_VT_SIMPLE" VdsOfflineStatus="false"><MountPoints><MountPoint Path="F:\"/></MountPoints><Extents><Extent DiskNumber="0" StartingOffset="8257536" ExtentLength="300058182144"/></Extents></LiveVolume><LiveVolume Id="{a83a1117-443b-11e6-8273-806e6f6e6963}" Name="\\?\Volume{a83a1117-443b-11e6-8273-806e6f6e6963}" Label="DATAS" FilesystemType="NTFS" Capacity="320062061568" UsedSize="82638576640" Roles="0" VdsType="VDS_VT_SIMPLE" VdsOfflineStatus="false"><MountPoints><MountPoint Path="D:\"/></MountPoints><Extents><Extent DiskNumber="1" StartingOffset="8259072" ExtentLength="320062061568"/></Extents></LiveVolume></LiveVolumes><Disks><Disk DiskNumber="0" BusType="SATA" Capacity="300069052416" IsReadOnly="false" ReadOnlyState="2" IsVirtualDisk="false" IsRemovable="false" LogicalSectorSize="512" FriendlyName="WDC WD3000HLFS-75G6U1" PackStateFlags="1"><DriveLayout PartitionStyle="MBR" Signature="129"><Partitions><Partition PartitionNumber="0" StartingOffset="8225280" PartitionLength="300058214400" PartitionStyle="MBR" PartitionType="15" BootIndicator="false" RecognizedPartition="false" HiddenSectors="16065"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="1" StartingOffset="8257536" PartitionLength="300058182144" PartitionStyle="MBR" PartitionType="7" BootIndicator="false" RecognizedPartition="true" HiddenSectors="63"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/></Partitions></DriveLayout><DevSetupInfo DevPath="\\?\scsi#disk&amp;ven_wdc&amp;prod_wd3000hlfs-75g6u#4&amp;303cba2d&amp;0&amp;000000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}" IsExternalDisk="false"/></Disk><Disk DiskNumber="2" BusType="SATA" Capacity="256060514304" IsReadOnly="false" ReadOnlyState="2" IsVirtualDisk="false" IsRemovable="false" LogicalSectorSize="512" FriendlyName="Samsung SSD 850 PRO 256GB" PackStateFlags="1"><DriveLayout PartitionStyle="MBR" Signature="1534522506"><Partitions><Partition PartitionNumber="1" StartingOffset="1048576" PartitionLength="256059465728" PartitionStyle="MBR" PartitionType="7" BootIndicator="true" RecognizedPartition="true" HiddenSectors="2048"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/></Partitions></DriveLayout><DevSetupInfo DevPath="\\?\scsi#disk&amp;ven_samsung&amp;prod_ssd_850_pro_256g#4&amp;303cba2d&amp;0&amp;030000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}" IsExternalDisk="false"/></Disk><Disk DiskNumber="1" BusType="SATA" Capacity="320072933376" IsReadOnly="false" ReadOnlyState="2" IsVirtualDisk="false" IsRemovable="false" LogicalSectorSize="512" FriendlyName="SAMSUNG HD322GJ" PackStateFlags="1"><DriveLayout PartitionStyle="MBR" Signature="-1548115015"><Partitions><Partition PartitionNumber="0" StartingOffset="8226816" PartitionLength="320062093824" PartitionStyle="MBR" PartitionType="15" BootIndicator="false" RecognizedPartition="false" HiddenSectors="16068"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="1" StartingOffset="8259072" PartitionLength="320062061568" PartitionStyle="MBR" PartitionType="7" BootIndicator="false" RecognizedPartition="true" HiddenSectors="63"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/><Partition PartitionNumber="0" StartingOffset="0" PartitionLength="0" PartitionStyle="MBR" PartitionType="0" BootIndicator="false" RecognizedPartition="false" HiddenSectors="0"/></Partitions></DriveLayout><DevSetupInfo DevPath="\\?\scsi#disk&amp;ven_samsung&amp;prod_hd322gj#4&amp;303cba2d&amp;0&amp;010000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}" IsExternalDisk="false"/></Disk></Disks></ShadowVolumesLayout>
[12.04.2017 22:48:45] <19> Info     '
[12.04.2017 22:48:45] <19> Error    Failed to initialize drive detection events
[12.04.2017 22:48:45] <19> Error    Non pris en charge  (System.Management.ManagementException)
[12.04.2017 22:48:45] <19> Error       à System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
[12.04.2017 22:48:45] <19> Error       à System.Management.ManagementEventWatcher.Start()
[12.04.2017 22:48:45] <19> Error       à Veeam.EndPoint.CStorageInsertionDetector..ctor()
[12.04.2017 22:48:45] <19> Error       à Veeam.EndPoint.CExternalDriveInsertionEvent.<Init>b__0()
[12.04.2017 22:48:45] <19> Info     Stopping service...

...

[12.04.2017 22:48:46] <19> Info     Waiting for stopping of all active jobs (timeout [300 sec])...
[12.04.2017 22:48:47] <19> Info     [CEndPointRegistryOptionsWatcher] Stop watcher
[12.04.2017 22:48:47] <19> Info     Posting termination request. Event: [60644701], Thread: [19]
[12.04.2017 22:48:47] <19> Info     Posting termination request. Event: [60644701], Thread: [19]
[12.04.2017 22:48:47] <15> Info     Job states tracker has been stopped.
[12.04.2017 22:48:47] <14> Info     Job states tracker has been stopped.
[12.04.2017 22:48:47] <19> Info     Posting termination request. Event: [60644701], Thread: [19]
[12.04.2017 22:48:47] <19> Info     [RpcTransport] Stopping
[12.04.2017 22:48:47] <19> Info     [RpcTransport] Stopped
[12.04.2017 22:48:47] <19> Info     Disposing uncompleted asynchronous rollback tracked actions, timeout: [00:00:05]
[12.04.2017 22:48:47] <19> Info     [SqlLocalDb] Stopping instance 'VeeamEndPoint'
[12.04.2017 22:48:48] <19> Info     [SqlLocalDB] Instance 'VeeamEndPoint' has been stopped
[12.04.2017 22:48:48] <19> Error    Le thread a été abandonné. (System.Threading.ThreadAbortException)
[12.04.2017 22:48:48] <19> Error       à System.Threading.Thread.AbortInternal()
[12.04.2017 22:48:48] <19> Error       à System.Threading.Thread.Abort()
[12.04.2017 22:48:48] <19> Error       à Veeam.EndPoint.CExternalDriveInsertionEvent.Dispose()
[12.04.2017 22:48:48] <19> Error       à Veeam.Backup.Service.CExternalOrEvent.Dispose()
[12.04.2017 22:48:48] <19> Error       à Veeam.Backup.Common.CDisposableList.Dispose()
[12.04.2017 22:48:48] <19> Info     Service stopped.
[12.04.2017 22:48:48] <22> Info     Stop service status tracking.
[12.04.2017 22:48:48] <01> Info     Disposing SVeeamBackupService...
[12.04.2017 22:48:48] <01> Info     Unregistering TCP client channel [bstcp]
[12.04.2017 22:48:48] <01> Info     Channel successfully unregistered
[12.04.2017 22:48:48] <02> Info     ~CClientSponsor [ss0]
[12.04.2017 22:48:48] <02> Info     [Session ced3a952-233d-4755-8e79-eaf398e7b1f7] Closing...
[12.04.2017 22:48:48] <02> Info     ~CClientSponsor [ss0]
[12.04.2017 22:48:48] <02> Info     [Session 15379fde-d153-407f-8499-a4e4ba8c30fe] Closing...


Each time I open the GUI the Service suddenly stops.

It's the same error on the two computers (But different brand/model - laptop/workstation - 7 Enterprise / 8.1 Enterprise).

I will higly appreciate any help.

Rémy.
xanod
Lurker
 
Posts: 1
Liked: never
Joined: Wed Apr 12, 2017 11:49 am
Full Name: Rémy Landraud

Re: Services suddenly stopped working

Veeam Logoby Mike Resseler » Thu Apr 13, 2017 4:54 am

Hi Remy,

First: Welcome to the forums!

Can you open a support case with us? (It's free, but no SLA). You probably won't be able to do it on the problematic machines (as the UI is not working) but create a case on one of your other computers and mention it that the problem is with other computers. Then support will contact you for further investigation

Please post the case ID here (and after that the follow-up and result)

Thanks
Mike
Mike Resseler
Veeam Software
 
Posts: 3150
Liked: 362 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler


Return to Veeam Agent for Windows



Who is online

Users browsing this forum: Google [Bot] and 4 guests