USB Backup device is not ready

Backup agent for Microsoft Windows servers and workstations (formerly Veeam Endpoint Backup FREE)

USB Backup device is not ready

Veeam Logoby gmele » Fri Feb 19, 2016 12:41 pm

Hi,
We are running VEB and rotating 3 WD 2 TB USB drives. After installing the password lock feature with auto-unlock our Veeam Endpoint scheduled backup which runs during the night no longer works. We receive the following error message:

"2/18/2016 6:47:05 AM :: Error: The device is not ready. Cannot create folder. Folder path: [\\HBMCSRV04\VeeamBackup]. --tr:FC: Failed to create directory. Directory path: [\\HBMCSRV04\VeeamBackup]. --tr:Failed to call DoRpc. CmdName: [FcCreateDir]. The device is not ready. Cannot create folder. Folder path: [\\HBMCSRV04\VeeamBackup]. "

We are using an SMB share in Windows 2012 R2 which points to a directory called VeeamBackup on three rotated WD My Passport 2 TB drives. This process was working correctly before we activated the password lock feature.

If I login to the server as Administrator and open Windows Explorer the backup drive is mounted on F: as it should be. Afterwards the nightly backup will work. If I don't login to the Server after the drive is swapped then it looks like the backup drive is not mounted. I have tried scheduling a .bat script file to access the share before the backups run but the share is not available. Does anyone have an idea on how to mount the backup drive?

Thank you
gmele
Enthusiast
 
Posts: 26
Liked: never
Joined: Thu Apr 30, 2015 9:10 pm
Full Name: Mele Giuseppe

Re: USB Backup device is not ready

Veeam Logoby Dima P. » Fri Feb 19, 2016 3:24 pm

Hi,
we activated the password lock feature

I am not sure I understand to what feature you are referring. Could you please elaborate? Thanks
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: USB Backup device is not ready

Veeam Logoby gmele » Fri Feb 19, 2016 10:35 pm

Hi,

the password lock feature is part of the utility software included with the purchase of Western Digital My Passport USB drives. Since VEB does not encrypt backups we are trying to use the WD Password Lock feature with the auto-unlock option to secure the backup drives. These drives are rotated offsite and are at risk of being lost or stolen.

Thanks.
gmele
Enthusiast
 
Posts: 26
Liked: never
Joined: Thu Apr 30, 2015 9:10 pm
Full Name: Mele Giuseppe

Re: USB Backup device is not ready

Veeam Logoby gmele » Wed Feb 24, 2016 12:30 pm

Hi,

I opened a support cast with Western Digital support. Their recommendation is to disable the Password Lock feature altogether. I have tried using LogonExpert to schedule an automatic login of the Windows backup account before the backups start hoping that this would cause the USB drive to be mounted thereby enabling the SMB share but this does not seem to work. The automatic login is occurring with the execution of a Startup script which tries to access the SMB share but the share is not available. The drive is mounted only when I login with my Administrator account. At this point we have no other option but to disable the WD Password Lock feature. Too bad... :(
gmele
Enthusiast
 
Posts: 26
Liked: never
Joined: Thu Apr 30, 2015 9:10 pm
Full Name: Mele Giuseppe

Re: USB Backup device is not ready

Veeam Logoby Dima P. » Wed Feb 24, 2016 12:59 pm

Thanks for the heads up! Might be a good idea to test the Windows Bitlocker functionality since it has the auto unlock functionality out of the box.
Dima P.
Veeam Software
 
Posts: 6242
Liked: 440 times
Joined: Mon Feb 04, 2013 2:07 pm
Location: SPb
Full Name: Dmitry Popov

Re: USB Backup device is not ready

Veeam Logoby gmele » Mon Feb 29, 2016 12:46 pm

Hi Dima,
thanks for the info. I will look into Windows Bitlocker. Encryption would indeed be the best solution.
gmele
Enthusiast
 
Posts: 26
Liked: never
Joined: Thu Apr 30, 2015 9:10 pm
Full Name: Mele Giuseppe


Return to Veeam Agent for Windows



Who is online

Users browsing this forum: majones, Yahoo [Bot] and 9 guests