Standalone backup agents for Linux, Mac, AIX & Solaris workloads on-premises or in the public cloud
Post Reply
pck_robert
Novice
Posts: 3
Liked: never
Joined: Jan 20, 2020 5:15 pm
Full Name: Robert Cotran
Contact:

Failed to find the agent certificate

Post by pck_robert »

Hi all,

I recently had to restore a Linux VM in Azure using Veeam.

Since the restore, backups of the restored system are no longer working. Logs have this entry:

Code: Select all

[02.08.2022 17:36:47.445] <140204991029760> prtcl  | ERR |Failed to find the agent certificate. Possible reason: a recent change of hardware could cause the HWID to change as well.
I'm not sure what certificate it's looking for or how to resolve this.

Any help would be very appreciated!

Thank you,

Robert

Mildur
Veeam Software
Posts: 3815
Liked: 1229 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: St. Gallen, Switzerland
Contact:

Re: Failed to find the agent certificate

Post by Mildur »

Hello,

Is this about Veeam Agent for Linux or Veeam Backup for Azure?
If it's about Veeam Agent for Linux, then try the following steps (no guarantee that it works, but it was tested successfully in a similar case by one of my colleagues):
1) Stop the service:
# systemctl stop veeamservice
2) Make database backup:
# mv /var/lib/veeam/veeam_db.sqlite /var/lib/veeam/veeam_db.sqlite.bak
3) Start the service:
# systemctl start veeamservice
4) Wait a few minutes for the database to rebuild
5) Rescan machine in the protection group
If that doesn't help, please provide a support case ID for this issue, as requested when you click New Topic. Without case number, the topic will eventually be deleted by moderators.

Best regards,
Fabian

PS: support can only help if you upload logs
https://www.veeam.com/kb1832
https://helpcenter.veeam.com/docs/agent ... tml?ver=50
Product Management Analyst @ Veeam Software

pck_robert
Novice
Posts: 3
Liked: never
Joined: Jan 20, 2020 5:15 pm
Full Name: Robert Cotran
Contact:

Re: Failed to find the agent certificate

Post by pck_robert »

Thank you, that worked!!

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests