Standalone backup agents for Linux and Unix workloads on-premises or in the public cloud
Post Reply
matt_oster
Novice
Posts: 3
Liked: 1 time
Joined: Oct 23, 2020 3:11 pm
Full Name: Matthew Oster
Contact:

Error installing Linux Agent 4 on RHEL 7.5

Post by matt_oster »

I have an open Veeam case about this, case # 04456963, as well as a case with RedHat as well, but wanted to throw this out there in the event that someone else has had this issue and could share the solution.

We recently upgraded our 9.5 Veeam B&R environment to 10 without a hitch, except when it came to updating the agents running on our RHEL 7.5 servers. We're currently on agent version 3.0.2.1185 but when we go to upgrade to 4 we get errors about python3.

I've tried everything I can find online to get python3 installed into a test server before attempting the same on these production boxes and I just can't seem to get it going. I try to install the kmod rpm manually and get the following error:

[root@jldevrhel01 ~]# rpm -i kmod-veeamsnap-4.0.1.2365-1.el7.x86_64.rpm
warning: kmod-veeamsnap-4.0.1.2365-1.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID efdcea77: NOKEY
error: Failed dependencies:
/usr/bin/python3 is needed by kmod-veeamsnap-4.0.1.2365-1.el7.x86_64
python3 is needed by kmod-veeamsnap-4.0.1.2365-1.el7.x86_64
[root@jldevrhel01 ~]#

Any thoughts, pointers or anything on this would be greatly appreciated. Thanks in advance!

PTide
Product Manager
Posts: 5731
Liked: 573 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Error installing Linux Agent 4 on RHEL 7.5

Post by PTide »

Hi,

Have you tried to install python3-setuptools instead of python3? It is required for CentOS, RHEL 7.0 and later if a pre-built binary kmod-veeamsnap package is to be installed.

Thanks!

matt_oster
Novice
Posts: 3
Liked: 1 time
Joined: Oct 23, 2020 3:11 pm
Full Name: Matthew Oster
Contact:

Re: Error installing Linux Agent 4 on RHEL 7.5

Post by matt_oster »

I was able to find and install python33-python-setuptools but I'm still getting the same error as above.

matt_oster
Novice
Posts: 3
Liked: 1 time
Joined: Oct 23, 2020 3:11 pm
Full Name: Matthew Oster
Contact:

Re: Error installing Linux Agent 4 on RHEL 7.5

Post by matt_oster » 1 person likes this post

We figured it out, for safety we have our RHEL servers locked down to repos for the version they're running, so in this case 7.5. The packages Veeam needed to install the agent weren't in standard, easy installable repos until RHEL 7.7. Taking the lock away allowed us to update the agents, and we just put the lock back in place when we were done.

PTide
Product Manager
Posts: 5731
Liked: 573 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Error installing Linux Agent 4 on RHEL 7.5

Post by PTide »

Thank you for reporting back

Cheers

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests