Standalone backup agents for Linux and Unix workloads on-premises or in the public cloud
Post Reply
mamosorre84
Service Provider
Posts: 186
Liked: 15 times
Joined: Oct 24, 2016 3:56 pm
Full Name: Marco Sorrentino
Location: Ancona - Italy
Contact:

Error restoring LVM

Post by mamosorre84 »

Hi,

I try to restore a LVM from a file-level backup in a cloud repository, VAL 4.0.

The restore process goes fine, but I see an error at the end of the job:
........
Deactivating LVM logical volume [vg_data/lv_mysql].
Deactivating LVM logical volume [lv_mysql].
WARN|LvmLogicalVolume: Unable to deactivate: Logical volume vg_data/lv_mysql in use.
>> |Deactivate failed.
Sleep and try again. attempt: 0/10
.........
Deactivating LVM logical volume [lv_mysql]. Failed.
[SessionLog][error] Failed to perform post-restore disks configuration adjustment.
Post-restore disks configuration adjustment. Failed.
........


The LVM is restored but not mounted (I have to mount it manually).

Any idea? Is it an issue or a normal behaviour?

Thanks

Marco S.

PTide
Product Manager
Posts: 5651
Liked: 555 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Error restoring LVM

Post by PTide »

Hi,

It's hard to say without logs. In general, during volume restores VAL might be unable to adjust fstab (so that restored volumes will be mounted automatically). However, since you're using file-level restore it's simply not the case.

Kindly open a support case and post your case ID in this thread so we can review it.

Thanks!

mamosorre84
Service Provider
Posts: 186
Liked: 15 times
Joined: Oct 24, 2016 3:56 pm
Full Name: Marco Sorrentino
Location: Ancona - Italy
Contact:

Re: Error restoring LVM

Post by mamosorre84 »

Hi,

sorry for mistake, I wanted to say volume-level backup.

The error was from a production server with mysql instance, but I replicated it in my lab in a fresh Ubuntu install yesterday.

I've opened the case number 04156947.

Thanks

Marco S.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests