Standalone backup agents for Linux and Unix workloads on-premises or in the public cloud
Post Reply
Byolock
Lurker
Posts: 1
Liked: never
Joined: May 25, 2020 3:15 pm
Contact:

How to check if Linux Agent is encrypting traffic to B&R

Post by Byolock »

I've noticed the following unexpected behavior when a backup from an agent is initiated :

This is a screenshot taken of a windows agent job:
Image

In this case the third Action is "Network traffic will be encrypted".

This is a screenshot taken of a linux agent job:
Image

The Action "Network traffic will be encrypted" is missing. Both, the windows and linux machine are outside the local network reachable only by a public IP.

Does the Linux Agent just dont print this action out or is it in fact transmitting without encryption?
If it is not printing out that Action, is there any way to check the backup traffic gets enrypted?

Gostev
SVP, Product Management
Posts: 26919
Liked: 4373 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: How to check if Linux Agent is encrypting traffic to B&R

Post by Gostev »

Since the data movement engine both agents use is shared, most likely VAL just doesn't print the action.
@HannesK could you guys please confirm with QC?

HannesK
Veeam Software
Posts: 6324
Liked: 953 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: How to check if Linux Agent is encrypting traffic to B&R

Post by HannesK »

Hello,
If it is not printing out that Action, is there any way to check the backup traffic gets enrypted?
I just did a quick check in the logs of my lab and saw that

Code: Select all

 srv| Connection will be encrypted.

in C:\ProgramData\Veeam\Backup\<jobname>\<host>\agent*.target.log is the difference between unencrypted and encrypted connection.

I will double-check with QC also to fix the UI and come back as soon as I have a confirmation.

Best regards,
Hannes

HannesK
Veeam Software
Posts: 6324
Liked: 953 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: How to check if Linux Agent is encrypting traffic to B&R

Post by HannesK »

sorry for the late response. As I mentioned earlier: the traffic is encrypted. That's working fine.

It's a UI issue that is planned to be fixed with V11. Bug number is 243715

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests