Standalone backup agents for Linux and Unix workloads on-premises or in the public cloud
Post Reply
BMF614
Lurker
Posts: 2
Liked: never
Joined: Jun 09, 2020 1:12 pm
Contact:

SSH to CentOS 7 doesn't work in Veeam but it does in Putty

Post by BMF614 »

Hello,

Case #04220349.

I don't really want my Veeam server being able to SSH into my servers but I guess that is the only way to use the product. I would prefer to just install the agent using ansible and then have the server connect to the agent but I guess that is not how Veeam works. So here I am creating an account with sudo privs on my server.

Anyway, I created a user and an SSH keypair with a passphrase and provided that information to Veeam. I tested using the Putty client built into Veeam and it works perfectly in Putty but Veeam just comes up and says: "6/9/2020 9:08:46 AM :: Unable to install backup agent: cannot connect to [[ip]] Error: Authentication failed" which is really not useful at all. On the server it just says: Jun 9 09:08:46 hostname sshd[16572]: Connection reset by [[veam server ip]] port 61550 [preauth]

Like I said using the putty client built into Veeam works flawlessly. So.. no clue, any ideas?

nitramd
Expert
Posts: 260
Liked: 66 times
Joined: Feb 16, 2017 8:05 pm
Contact:

Re: SSH to CentOS 7 doesn't work in Veeam but it does in Putty

Post by nitramd »

Sounds like a possible firewall issue. Have a look this document: https://helpcenter.veeam.com/docs/agent ... tml?ver=40

BMF614
Lurker
Posts: 2
Liked: never
Joined: Jun 09, 2020 1:12 pm
Contact:

Re: SSH to CentOS 7 doesn't work in Veeam but it does in Putty

Post by BMF614 »

Did you see the part where I mentioned that the built in putty on the server can connect to the host via SSH?

How could it possibly be a firewall issue?

PTide
Product Manager
Posts: 5626
Liked: 549 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: SSH to CentOS 7 doesn't work in Veeam but it does in Putty

Post by PTide » 1 person likes this post

Hi @BMF614,

Code: Select all

Jun 9 09:08:46 hostname sshd[16572]: Connection reset by [[veam server ip]] port 61550 [preauth]
If Windows server is used as a target repository, then the communication between the repository and the Agent will involve dynamic RPC port range (49152 to 65535 for Windows 2008 or newer). As you can see port 61550 is in that range.

That is, my guess is that it might be your repository server that is located on the same machine as VBR and is blocking the inbound connection to port 61550.

Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests