Standalone backup agents for Linux and Unix workloads on-premises or in the public cloud
Post Reply
oli4
Enthusiast
Posts: 48
Liked: 2 times
Joined: Aug 14, 2012 11:34 am
Contact:

Veeam Linux Recovery Media

Post by oli4 »

Hello

I'm struggling with the Veeam Recovery Media. I have downloaded the version veeam-recovery-media-4.0.1.2365_x86_64.iso and tried to boot my server (Huawei with standard INTEL NIC's).
It boot from the media but after a while it fails and the screen stays black.

Then I modified the media with the efi switch and booted again, now it works but when I try to configure the network adapters the list is empty. I then modified the media and also added the
nic drivers (added the .ko and .ko.xz version), but still no success.

Is there anything else I can try?

Regards
oli4

PTide
Product Manager
Posts: 5626
Liked: 549 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: Veeam Linux Recovery Media

Post by PTide »

Hi,

Did you add drivers as files using --copy <additional_path>, or you just patched the recovery?

If you just import drivers into the recovery media then the drivers has to be:

1. compiled for the same kernel version as recovery media kernel
2. loaded once the recovery media is booted (using 'modprobe')

Without that drivers won't work properly.

If you patch the recovery media, then VAL will inject all drivers into the media and patch the kernel. That should be enough for the hardware to work:

Code: Select all

veeamconfig patchiso --efi --input <input_path> --output <output_path>
Another option would be to take any LiveCD of your choice that is guaranteed to work with your hardware, install Veeam Agent inside it, and then start recovery UI from there. More details here

Thank you

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests