Agentless, cloud-native backup for Amazon AWS
Post Reply
lukklin
Service Provider
Posts: 20
Liked: 2 times
Joined: Sep 03, 2015 8:16 am
Full Name: Lukas Klinger
Contact:

Creating default IAM account fails

Post by lukklin »

Hello everybody,

I would like to try the Veeam Backup for AWS, the cloud formation template was running successfully, but inside the software, it seems to fail during the creation of the default IAM account:

Case ID: 03894503

Has anyone an idea, what to check?

Thanks!
Lukas

nielsengelen
Veeam Software
Posts: 3435
Liked: 686 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Creating default IAM account fails

Post by nielsengelen »

Best would be to wait for feedback from support here.
https://foonet.be

Mike Resseler
Product Manager
Posts: 6130
Liked: 714 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Creating default IAM account fails

Post by Mike Resseler »

Hey Lukas,

Where did it exactly fail? Somewhere in this procedure? https://helpcenter.veeam.com/docs/vbaws ... tml?ver=10

lukklin
Service Provider
Posts: 20
Liked: 2 times
Joined: Sep 03, 2015 8:16 am
Full Name: Lukas Klinger
Contact:

Re: Creating default IAM account fails

Post by lukklin »

Hi Mike,

It fails at this point: https://helpcenter.veeam.com/docs/vbaws ... tml?ver=10

Because there is no default IAM user been created during install.

Mike Resseler
Product Manager
Posts: 6130
Liked: 714 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Creating default IAM account fails

Post by Mike Resseler »

OK. So you need to add an IAM role with the necessary rights. Maybe there is an issue?

See here: https://www.veeam.com/kb3032

lukklin
Service Provider
Posts: 20
Liked: 2 times
Joined: Sep 03, 2015 8:16 am
Full Name: Lukas Klinger
Contact:

Re: Creating default IAM account fails

Post by lukklin »

Yes, I know that kb. I've created this IAM role but the wizard shows this message: "The default account is not initialized" (In the veeam console)

Mike Resseler
Product Manager
Posts: 6130
Liked: 714 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Creating default IAM account fails

Post by Mike Resseler »

OK. I noticed our support is looking in certain logs. Please keep us informed about what is happening

Thanks
Mike

lukklin
Service Provider
Posts: 20
Liked: 2 times
Joined: Sep 03, 2015 8:16 am
Full Name: Lukas Klinger
Contact:

Re: Creating default IAM account fails

Post by lukklin »

I will do

lukklin
Service Provider
Posts: 20
Liked: 2 times
Joined: Sep 03, 2015 8:16 am
Full Name: Lukas Klinger
Contact:

Re: Creating default IAM account fails

Post by lukklin » 1 person likes this post

It looks like there were some network issues during the initial deployment of the appliance, which prevented the appliance to reach AWS IAM.

The support and I were able to get the appliance to work by simply restarting some services:

Code: Select all

sudo systemctl restart veeam-updater.service

Code: Select all

sudo systemctl restart veeamawsbackup.service

Code: Select all

sudo systemctl restart veeamawsbackupweb.service
But I'm very happy with the solution, even for a 1.0 release..Backup & FLR was working very seamless so far :-)

Cheers!
Lukas

nielsengelen
Veeam Software
Posts: 3435
Liked: 686 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Creating default IAM account fails

Post by nielsengelen »

Thanks for the follow-up Lukas. Any extra feedback is appreciated!
https://foonet.be

master_mike
Novice
Posts: 6
Liked: never
Joined: Dec 20, 2019 7:21 pm
Full Name: Michael Masters
Contact:

Re: Creating default IAM account fails

Post by master_mike »

I am having the same issue after deploying the clod formation for veeam twice now... The default account is not initialized.
Under accounts it is empty, the default account is not created.
I cant seem to SSH intot he appliance either, as I get no authorization methods specifed when i do.

Any insight into the issue?

Mike

Mike Resseler
Product Manager
Posts: 6130
Liked: 714 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: Creating default IAM account fails

Post by Mike Resseler »

Hi @master_mike

Could you create a support call?

Thanks
Mike

HannesK
Veeam Software
Posts: 5739
Liked: 791 times
Joined: Sep 01, 2014 11:46 am
Location: Austria
Contact:

Re: Creating default IAM account fails

Post by HannesK »

Hello,
thanks @lukklin for posting the solution. I ran into the same issue.

Best regards,
Hannes

master_mike
Novice
Posts: 6
Liked: never
Joined: Dec 20, 2019 7:21 pm
Full Name: Michael Masters
Contact:

Re: Creating default IAM account fails

Post by master_mike »

my issue was networking related, and because I deployed into a private VPC behind a NAT, which would cause this issue. I had to deploy into a VPC with IGW and no NAT.
Even thought the NAT gave the instance a public IP and the security groups and NACL was setup properly, I guess it still had issues connecting to the AWS services it needed to to activate the default account. Support wrote this KB about the issue.. https://www.veeam.com/kb3071

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests