Agentless, cloud-native backup for Amazon AWS
Post Reply
master_mike
Novice
Posts: 6
Liked: never
Joined: Dec 20, 2019 7:21 pm
Full Name: Michael Masters
Contact:

Veeam service will not start...

Post by master_mike »

I rebooted my Veeam for AWS instance and now the veeam backup service will not start.
Errors in the logs:
------------------------------------------------------------------------------------------------------------------------------
ubuntu@ip-XX-XX-XXX-XXX:~$ sudo systemctl status veeamawsbackupweb.service
● veeamawsbackupweb.service - Veeam Backup for AWS Web
Loaded: loaded (/lib/systemd/system/veeamawsbackupweb.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2020-01-29 21:02:14 UTC; 33s ago
Process: 9057 ExecStart=/opt/veeam.aws.service/Veeam.CloudBackup.WebService (code=exited, status=255)
Main PID: 9057 (code=exited, status=255)
------------------------------------------------------------------------------------------------------------------------------------
ubuntu@ip-XX-XX-XX-XXX:/opt/veeam.aws.service$ sudo systemctl status veeamawsbackup.service
● veeamawsbackup.service - Veeam Backup for AWS
Loaded: loaded (/lib/systemd/system/veeamawsbackup.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2020-01-29 21:11:42 UTC; 55s ago
Process: 10001 ExecStart=/opt/veeam.aws.service/Veeam.CloudBackup.Service (code=exited, status=255)
Main PID: 10001 (code=exited, status=255)
-------------------------------------------------------------------------------------------------------------------------------------
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: System.FormatException: A duplicate key 'CProductUpdateOptions:LastProductUpdateCheck' was found.
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at Microsoft.Extensions.Configuration.FileConfigurationProvider.Load(Boolean reload)
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at Microsoft.Extensions.Configuration.ConfigurationRoot..ctor(IList`1 providers)
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at Microsoft.Extensions.Configuration.ConfigurationBuilder.Build()
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at System.Lazy`1.ViaFactory(LazyThreadSafetyMode mode)
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at System.Lazy`1.ExecutionAndPublication(LazyHelper executionAndPublication, Boolean useDefaultConstructor)
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at System.Lazy`1.CreateValue()
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at Veeam.CloudBackup.Configuration.SOptions.GetOptions[T]()
Jan 29 21:15:43 Veeam.CloudBackup.Service[10291]: at Veeam.CloudBackup.Service.SProgram.Main()
Jan 29 21:15:43 systemd[1]: veeamawsbackup.service: Main process exited, code=exited, status=255/n/a
Jan 29 21:15:43 systemd[1]: veeamawsbackup.service: Failed with result 'exit-code'.
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I have a ticket open with support, I wanted to put this out there to see if anyone else has ran into this yet..

Thanks
Mike

nielsengelen
Veeam Software
Posts: 3435
Liked: 686 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Veeam service will not start...

Post by nielsengelen »

If possible, could you share the support case ID so we can follow it as well for future reference?
https://foonet.be

master_mike
Novice
Posts: 6
Liked: never
Joined: Dec 20, 2019 7:21 pm
Full Name: Michael Masters
Contact:

Re: Veeam service will not start...

Post by master_mike »

Case # 03975687

master_mike
Novice
Posts: 6
Liked: never
Joined: Dec 20, 2019 7:21 pm
Full Name: Michael Masters
Contact:

Re: Veeam service will not start...

Post by master_mike »

issue resolved...
in the directory /etc/veeam/awsbackup config.ini has 2 Lines:

LastProductUpdateCheck = "5248846113781377311"

with 2 different numbers, is the reasoning for the Error:System.FormatException: A duplicate key 'CProductUpdateOptions:LastProductUpdateCheck' was found.
removed the second entry and left a black space and rebooted and the services started and I am back online.
Support does not know how or why it got 2 different entries in the INI... and are going to look into the issue.

nielsengelen
Veeam Software
Posts: 3435
Liked: 686 times
Joined: Jul 15, 2013 11:09 am
Full Name: Niels Engelen
Contact:

Re: Veeam service will not start...

Post by nielsengelen »

Thanks for sharing the case and outcome. We will analyse it as well.
https://foonet.be

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests