Maintain control of your Microsoft Office 365 email data
Post Reply
lemtargatwing
Service Provider
Posts: 19
Liked: 2 times
Joined: Jul 28, 2017 2:48 pm
Full Name: Kyle Witte
Contact:

beta 1.5 WinRM service issue

Post by lemtargatwing » Jul 28, 2017 6:27 pm

When trying to connect to an on-prem server over HTTPS, getting error:

The WinRM service cannot process the request because the request needs to be sent to a different machine.

Mike Resseler
Veeam Software
Posts: 5000
Liked: 530 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: beta 1.5 WinRM service issue

Post by Mike Resseler » Aug 07, 2017 8:00 pm

Hi Kyle,

Sorry for my late reply. Could you please collect the logs (see here how to get those: veeam-backup-for-microsoft-office-365-f ... 44217.html) and place them on your favorite file share (dropbox, onedrive, whatever you like) and PM me a link to it?

I will ask the engineers to investigate

Thanks
Mike

lemtargatwing
Service Provider
Posts: 19
Liked: 2 times
Joined: Jul 28, 2017 2:48 pm
Full Name: Kyle Witte
Contact:

Re: beta 1.5 WinRM service issue

Post by lemtargatwing » Aug 16, 2017 6:49 pm

PM Sent. Thanks for the reply.

Kostya
Veeam Software
Posts: 104
Liked: 28 times
Joined: Jun 18, 2012 9:38 am
Full Name: Kostya Yasyuk
Contact:

Re: beta 1.5 WinRM service issue

Post by Kostya » Aug 25, 2017 7:25 pm

Hi Kyle, it seems like you are using CAS array or hybrid org? If that's the case, try to connect to your organisation using PowerShell, with the same options as were used in VBO365. You might need to use "setspn -S HTTP/COMPUTER SERVER" to make it work.

SBarrett847
Service Provider
Posts: 271
Liked: 39 times
Joined: Feb 02, 2016 5:02 pm
Full Name: Stephen Barrett
Contact:

Re: beta 1.5 WinRM service issue

Post by SBarrett847 » Aug 28, 2017 2:55 pm

I remember having to enable something like Basic Authentication under the Powershell site in IIS on the Exchange DAG servers to get past this.

Mike Resseler
Veeam Software
Posts: 5000
Liked: 530 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: beta 1.5 WinRM service issue

Post by Mike Resseler » Aug 29, 2017 5:35 am

Stephen,

That indeed is necessary:

1. In IIS Admin on the Exchange server, Select the PowerShell Virtual Folder and enable Basic Authentication.
2. On the on-prem Exchange Server, enable application impersonation for the account being used.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests