Fails with an error in XML document

Maintain control of your Microsoft Office 365 email data

XML Error on running backup

Veeam Logoby cdlane » Tue Sep 27, 2016 2:24 pm

Please find the error as discussed with Mike Resseler at https://www.veeam.com/blog/how-backup-o ... email.html

26/09/2016 13:07:13 :: There is an error in XML document (1, 31559).. '', hexadecimal value 0x08, is an invalid character. Line 1, position 31559.

It ran for 8 minutes and 50 seconds before failing.

Best regards,

Chris
cdlane
Enthusiast
 
Posts: 43
Liked: 3 times
Joined: Sun Aug 09, 2015 5:48 pm
Full Name: Chris Lane

[MERGED] Fails with an error in XML document

Veeam Logoby bfoley » Tue Sep 27, 2016 2:24 pm

I set it up to backup all the mailboxes in my tenant. It fails within 12 seconds with the error "There is an error in XML document (1, 15712).. '', hexadecimal value 0x08, is an invalid character. Line 1, position 15712."

Here is the error from the log:

Code: Select all
9/26/2016 1:31:50 PM   22 (43192) Preparing folders for items processing...
9/26/2016 1:31:51 PM   20 (42840) Error: There is an error in XML document (1, 15712).
9/26/2016 1:31:51 PM   20 (42840) Stack:
9/26/2016 1:31:51 PM   20 (42840)    at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at EWServices.ExchangeServiceBinding.FindFolder(FindFolderType FindFolder1)
   at Veeam.Ews.ExFolder.<GetFolders>d__21.MoveNext()
   at Veeam.Ews.ExFolderWalker.Walk(IFolderVisitor visitor)
   at Veeam.Archiver.Source.MailboxActivator.PrepareFolders(IMailboxContext bind, ExcludedFolders excluded, CancellationToken cancel)
   at Veeam.Archiver.Source.MailboxActivator.DoWork(CancellationToken cancel)
   at Veeam.Archiver.Source.WorkAction.WorkWrap(CancellationToken cancel)
9/26/2016 1:31:51 PM   20 (42840) Error: '', hexadecimal value 0x08, is an invalid character. Line 1, position 15712.
9/26/2016 1:31:51 PM   20 (42840) Stack:
9/26/2016 1:31:51 PM   20 (42840)    at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
   at System.Xml.XmlTextReaderImpl.ParseNumericCharRefInline(Int32 startPos, Boolean expand, StringBuilder internalSubsetBuilder, Int32& charCount, EntityType& entityType)
   at System.Xml.XmlTextReaderImpl.ParseCharRefInline(Int32 startPos, Int32& charCount, EntityType& entityType)
   at System.Xml.XmlTextReaderImpl.ParseText(Int32& startPos, Int32& endPos, Int32& outOrChars)
   at System.Xml.XmlTextReaderImpl.ParseText()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlReader.ReadElementString()
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read85_ExtendedPropertyType(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read384_FolderType(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read448_FindFolderParentType(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read449_FindFolderResponseMessageType(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read454_ArrayOfResponseMessagesType(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read501_FindFolderResponseType(Boolean isNullable, Boolean checkType)
   at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderExchangeServiceBinding.Read925_FindFolderResponse()
   at Microsoft.Xml.Serialization.GeneratedAssembly.ArrayOfObjectSerializer347.Deserialize(XmlSerializationReader reader)
   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
9/26/2016 1:31:52 PM   21 (44992) Job processing failed
bfoley
Novice
 
Posts: 6
Liked: 2 times
Joined: Wed Nov 30, 2011 7:01 pm
Full Name: Brian Foley

Re: Fails with an error in XML document

Veeam Logoby PTide » Tue Sep 27, 2016 3:13 pm

Chris, Brian

This has to be investigated by support team, please contact them and post your case IDs

Thank you
PTide
Veeam Software
 
Posts: 2894
Liked: 236 times
Joined: Tue May 19, 2015 1:46 pm

Re: Fails with an error in XML document

Veeam Logoby bfoley » Tue Sep 27, 2016 4:10 pm

I tried. Since it is not a supported product, they would not create a case ID.
bfoley
Novice
 
Posts: 6
Liked: 2 times
Joined: Wed Nov 30, 2011 7:01 pm
Full Name: Brian Foley

Re: Fails with an error in XML document

Veeam Logoby PTide » Tue Sep 27, 2016 4:26 pm

Sorry, my bad. Reported directly to QA team.

Thanks
PTide
Veeam Software
 
Posts: 2894
Liked: 236 times
Joined: Tue May 19, 2015 1:46 pm

Re: Fails with an error in XML document

Veeam Logoby Kostya » Wed Sep 28, 2016 2:07 pm

bfoley wrote:I tried. Since it is not a supported product, they would not create a case ID.

Brian, could you please upload logs to FTP? I've sent you the FTP link via PM.
Kostya
Veeam Software
 
Posts: 90
Liked: 23 times
Joined: Mon Jun 18, 2012 9:38 am
Full Name: Kostya Yasyuk

Re: XML Error on running backup

Veeam Logoby Kostya » Wed Sep 28, 2016 2:26 pm

cdlane wrote:26/09/2016 13:07:13 :: There is an error in XML document (1, 31559).. '', hexadecimal value 0x08, is an invalid character. Line 1, position 31559.
It ran for 8 minutes and 50 seconds before failing.

Chris, could you please upload logs to FTP? I've sent you the FTP link via PM.
Kostya
Veeam Software
 
Posts: 90
Liked: 23 times
Joined: Mon Jun 18, 2012 9:38 am
Full Name: Kostya Yasyuk

Re: Fails with an error in XML document

Veeam Logoby cdlane » Mon Oct 03, 2016 3:43 pm

Thanks for the PM but I have exactly the same error with the fix.
cdlane
Enthusiast
 
Posts: 43
Liked: 3 times
Joined: Sun Aug 09, 2015 5:48 pm
Full Name: Chris Lane

Re: Fails with an error in XML document

Veeam Logoby Kostya » Tue Oct 04, 2016 10:40 am

Could you please upload new logs with the fix installed?
Kostya
Veeam Software
 
Posts: 90
Liked: 23 times
Joined: Mon Jun 18, 2012 9:38 am
Full Name: Kostya Yasyuk

Re: Fails with an error in XML document

Veeam Logoby Kostya » Thu Oct 06, 2016 4:12 pm

Experimental fix provided via PM.
Kostya
Veeam Software
 
Posts: 90
Liked: 23 times
Joined: Mon Jun 18, 2012 9:38 am
Full Name: Kostya Yasyuk

Re: Fails with an error in XML document

Veeam Logoby bfoley » Wed Oct 12, 2016 4:59 pm 1 person likes this post

I can confirm with the last private fix, this problem seems to be corrected.

I was able to successfully backup 122 mailboxes in 1 day, 13 hours. A total of 477.53 GB (2191298 items). Processing rate was 3.60 MB/s, read rate 95.50 KB/s, write rate 8.65 MB/s.

I should mention that it might have been faster, however we currently have another service running that does Office 365 backups (from CodeTwo), which I did not shutdown (it runs on another server though, actually it runs on my Veeam backup server).
bfoley
Novice
 
Posts: 6
Liked: 2 times
Joined: Wed Nov 30, 2011 7:01 pm
Full Name: Brian Foley

Re: Fails with an error in XML document

Veeam Logoby jchillman » Wed Oct 12, 2016 5:52 pm

Have you run an incremental backup yet? I would be curious as to how this compares.
jchillman
Service Provider
 
Posts: 6
Liked: never
Joined: Wed Jan 13, 2016 8:49 pm
Full Name: James Chillman

Re: Fails with an error in XML document

Veeam Logoby bfoley » Fri Oct 14, 2016 6:46 pm

Incrementals are MUCH slower. Mainly because it has to read through every mailbox and look for changed items. On 122 mailboxes it's running for about an hour and a half for each incremental run (I think it's set to rerun every 5 minutes) at a processing rate of roughly 60 KB/s.
bfoley
Novice
 
Posts: 6
Liked: 2 times
Joined: Wed Nov 30, 2011 7:01 pm
Full Name: Brian Foley

Re: Fails with an error in XML document

Veeam Logoby Kostya » Sat Oct 15, 2016 7:09 am

Brian thanks for letting us know. So, it takes 37 hours for initial backup and 1,5 hours for incremental in your case, which is pretty good.
Kostya
Veeam Software
 
Posts: 90
Liked: 23 times
Joined: Mon Jun 18, 2012 9:38 am
Full Name: Kostya Yasyuk

Re: Fails with an error in XML document

Veeam Logoby cdlane » Mon Oct 17, 2016 12:23 pm 1 person likes this post

HI All,

The latest private fix resolved my XML and my network share repository errors in B&R.

Initial Backup - 79 mailboxes in 1 day, 1 hours. A total of 320.47 GB (1,152,493 items). Processing rate was 3.55 MB/s, read rate 2.86KB/s, write rate 11.08 MB/s.
Latest Incremental - 81 mailboxes in 24 minutes. A total of 187.09 MB (3,721 items). Processing rate was 94.11 KB/s, read rate 719.77KB/s, write rate 9.74 MB/s.

All to a Buffalo NAS for testing purposes.

Best regards,

Chris
cdlane
Enthusiast
 
Posts: 43
Liked: 3 times
Joined: Sun Aug 09, 2015 5:48 pm
Full Name: Chris Lane

Next

Return to Veeam Backup for Microsoft Office 365



Who is online

Users browsing this forum: Bing [Bot] and 2 guests