Maintain control of your Microsoft Office 365 email data
Post Reply
SKratzTS
Enthusiast
Posts: 59
Liked: 8 times
Joined: Jan 06, 2017 7:23 pm
Full Name: Steve Kratz
Contact:

New 2.2 install - Sharepoint errors

Post by SKratzTS » Jul 30, 2018 5:59 pm

7/30/2018 12:24:11 PM :: Processing site https://XXXXXXXXXXXXXXX.sharepoint.com/teams/IT Wiki finished with warning: Failed to backup list: IT Wiki, The request uses too many resources. :: 0:29:46

I've bumped up the threads allowed in the proxy configuration - no change. This IT Wiki isn't huge, but does have a few hundred DOC/XLS/Visio docs.

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Jul 30, 2018 6:06 pm

Hey Steve,

From what you write I have a feeling that MSFT is blocking us because we want to get too many resources at the same time. But I don't have enough information to confirm it. Can you create a support request, post the case ID here and let us know the outcome after the investigation of the engineers?

Many thanks
Mike

SKratzTS
Enthusiast
Posts: 59
Liked: 8 times
Joined: Jan 06, 2017 7:23 pm
Full Name: Steve Kratz
Contact:

Re: New 2.2 install - Sharepoint errors

Post by SKratzTS » Jul 30, 2018 8:49 pm

Will do...

SKratzTS
Enthusiast
Posts: 59
Liked: 8 times
Joined: Jan 06, 2017 7:23 pm
Full Name: Steve Kratz
Contact:

Re: New 2.2 install - Sharepoint errors

Post by SKratzTS » Jul 30, 2018 9:31 pm

Case #03123995 - logs uploaded.

scott.anderson
Service Provider
Posts: 64
Liked: 8 times
Joined: Sep 14, 2011 6:48 am
Full Name: Scott Anderson
Contact:

Re: New 2.2 install - Sharepoint errors

Post by scott.anderson » Aug 01, 2018 5:44 am

Dito, we are seeing the exact same behavior.

Have modified the default on the Backup Proxy config for the number of threads.

Default was 64

Changed it to 10

Lets see what happens!

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Aug 01, 2018 6:21 am

Hi Scott,

I fear (if you have the same error) we need to search somewhere else. An example (for on-premises environment) is here: https://blogs.technet.microsoft.com/sha ... operation/

Could you also create a support case? I am going to mail your case and Steve's case to our DEV team (I have a feeling we are hitting a MSFT limit which we should avoid somehow)

russell01
Veeam ProPartner
Posts: 9
Liked: 1 time
Joined: Oct 28, 2016 1:46 pm
Contact:

Re: New 2.2 install - Sharepoint errors

Post by russell01 » Aug 01, 2018 9:33 am

We're also getting this issue a long with a few more. Some examples below;

01/08/2018 09:44:11 :: Processing site xxxx finished with warning: Failed to backup list: xxxx, Specified argument was out of the range of valid values. Parameter name: value :: 0:10:04

01/08/2018 09:44:12 :: Processing site xxxx finished with warning: Failed to backup list: xxxx, The request uses too many resources. :: 0:28:50


We have an active support ticket with Veeam: Case # 03122202


Another issues we were having (and have a workaround), we enforced "Modern Authentication" on SharePoint and were getting this error:

30/07/2018 08:15:20 63 (12080) Error: Cannot contact web site 'https://xxxx-admin.sharepoint.com/' or the web site does not support SharePoint Online credentials. The response status code is 'Unauthorized'. The response headers are 'X-SharePointHealthScore=1, X-MSDAVEXT_Error=917656; Access+denied.+Before+opening+files+in+this+location%2c+you+must+first+browse+to+the+web+site+and+select+the+option+to+login+automatically., SPRequestDuration=149, SPIisLatency=0, MicrosoftSharePointTeamServices=16.0.0.7918, X-Content-Type-Options=nosniff, X-MS-InvokeApp=1; RequireReadOnly, X-MSEdge-Ref=Ref A: 229E142A02334723BC3C919F9FF37B88 Ref B: LON21EDGE1207 Ref C: 2018-07-30T07:15:21Z, Content-Length=0, Content-Type=text/plain; charset=utf-8, Date=Mon, 30 Jul 2018 07:15:20 GMT, P3P=CP="ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI", X-Powered-By=ASP.NET'.

The workaround is to run the command in the SharePoint powershell module; "Set-SPOTenant -LegacyAuthProtocolsEnabled $true", we then had to wait about 3-4 hours and it started working.

Markush-VE
Veeam Software
Posts: 497
Liked: 45 times
Joined: Jan 07, 2013 9:26 am
Full Name: Markus Hergt
Location: Germany
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Markush-VE » Aug 02, 2018 2:25 pm

i also ran into this issue during a POC with an O365 sharepoint environment:

Image

please post any solution also here

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Aug 02, 2018 5:35 pm

All, please make sure you create a support call so we have more logs to debug this!

Thanks
Mike

PS: Don't forget to post your CASE ID's here!

southwell
Lurker
Posts: 1
Liked: never
Joined: Apr 08, 2015 12:48 pm
Contact:

Re: New 2.2 install - Sharepoint errors

Post by southwell » Aug 08, 2018 8:46 am

Same issues here on Onedrive and Sharepoint Online: 03137689

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Aug 08, 2018 12:07 pm

Thanks Southwell
And welcome to our forums with your first post ;-)

coreypenford
Influencer
Posts: 14
Liked: never
Joined: Mar 28, 2018 6:46 pm
Contact:

Re: New 2.2 install - Sharepoint errors

Post by coreypenford » Aug 20, 2018 9:07 pm

Same issue as Russel

Case # 03154343

Error: Cannot contact web site 'https://xxxx-admin.sharepoint.com/' or the web site does not support SharePoint Online credentials. The response status code is 'Unauthorized'. The response headers are 'X-SharePointHealthScore=1, X-MSDAVEXT_Error=917656; Access+denied.+Before+opening+files+in+this+location%2c+you+must+first+browse+to+the+web+site+and+select+the+option+to+login+automatically., SPRequestDuration=149, SPIisLatency=0, MicrosoftSharePointTeamServices=16.0.0.7918, X-Content-Type-Options=nosniff, X-MS-InvokeApp=1; RequireReadOnly, X-MSEdge-Ref=Ref A: 229E142A02334723BC3C919F9FF37B88 Ref B: LON21EDGE1207 Ref C: 2018-07-30T07:15:21Z, Content-Length=0, Content-Type=text/plain; charset=utf-8, Date=Mon, 30 Jul 2018 07:15:20 GMT, P3P=CP="ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI", X-Powered-By=ASP.NET'.

This error code happens when trying to create a backup job for Sharepoint or Onedrive. As per the following KB (https://helpcenter.veeam.com/docs/vbo36 ... tml?ver=20), the user we use for connecting to 365 has the SharePoint Administrator role

We have not tried to enable the legacy auth yet, as it was not listed in the Veeam requirements.

By default, Sharepoint Online has modern auth on (https://support.office.com/en-us/articl ... 95c0f9168a)

Had 0 problems with auth on the old version, and on the new version mailbox backups continue to work. Seems a bit weird that we have to enable legacy auth for Sharepoint+OneDrive

SYSADMIT
Novice
Posts: 7
Liked: 3 times
Joined: Apr 07, 2016 10:19 am
Contact:

Re: New 2.2 install - Sharepoint errors

Post by SYSADMIT » Aug 22, 2018 9:52 am

Just confirm that I have solved the problem thanks to @coreypenford.

It was an authentication problem. Connecting to the Sharepoint online and adding the user to the role, solved.

I have posted a post that explains it:

https://www.sysadmit.com/2018/08/veeam- ... ursos.html

The post is in Spanish, but you can use the blog English translation gadget.

Polina
Veeam Software
Posts: 787
Liked: 108 times
Joined: Oct 21, 2011 11:22 am
Full Name: Polina Vasileva
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Polina » Aug 22, 2018 11:07 am

@coreypenford, @SYSADMIT,

Appreciate your input to the issue investigation (and such a helpful blog post!). I'm going to share these outcomes with our support team; and please take some time to open a support case (if you didn't do this yet) to help us collect more logs and statistics.

Assigning permissions as it's suggested in the blog post is, indeed, the way to go for now, as Modern authentication is not supported in v2 (however, we are researching the options).

vschindler
Novice
Posts: 6
Liked: 1 time
Joined: Aug 22, 2018 11:58 am
Full Name: Vitali Schindler
Contact:

Re: New 2.2 install - Sharepoint errors

Post by vschindler » Aug 22, 2018 12:09 pm

@sysadmit

In my opinion, the problem is not in authorization. I gave the rights over Azure AdminPortal. Then I checked with PowerShell. The user account is SharePoint System Administrator and the error still exists, although all other functions (onedrive, mails) are working properly.
Will say that in my case this error is only with one specific folder. All other folders in the SharePoint Site are backed up. So I have almost a whole backup.

SYSADMIT
Novice
Posts: 7
Liked: 3 times
Joined: Apr 07, 2016 10:19 am
Contact:

Re: New 2.2 install - Sharepoint errors

Post by SYSADMIT » Aug 22, 2018 1:20 pm

@Polina, thanks for your answer!

Polina
Veeam Software
Posts: 787
Liked: 108 times
Joined: Oct 21, 2011 11:22 am
Full Name: Polina Vasileva
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Polina » Aug 22, 2018 1:34 pm

Vitali,

Could you please open a support case and post its ID here? This would be very helpful.

vschindler
Novice
Posts: 6
Liked: 1 time
Joined: Aug 22, 2018 11:58 am
Full Name: Vitali Schindler
Contact:

Re: New 2.2 install - Sharepoint errors

Post by vschindler » Aug 23, 2018 7:11 am

Hi Polina,
have a support case with ID#03159590 opened.

Polina
Veeam Software
Posts: 787
Liked: 108 times
Joined: Oct 21, 2011 11:22 am
Full Name: Polina Vasileva
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Polina » Aug 23, 2018 8:27 am

Vitali,

Thanks! I'll keep an eye on it.

SYSADMIT
Novice
Posts: 7
Liked: 3 times
Joined: Apr 07, 2016 10:19 am
Contact:

Re: New 2.2 install - Sharepoint errors

Post by SYSADMIT » Aug 23, 2018 8:41 am

@vschindler

I'll explain my specific case:

The backup once reached a sharepoint folder gave the warning:

"Processing site xxxx finished with warning: Failed to backup list: xxxx, The request uses too many resources."

and the backup did not continue, the process stayed there. Reviewing the task manager, Windows Server had resources free of CPU, RAM, etc ...

By adding the user to the role, it started to work.

The warning continued, but the backup continued until the end.

vschindler
Novice
Posts: 6
Liked: 1 time
Joined: Aug 22, 2018 11:58 am
Full Name: Vitali Schindler
Contact:

Re: New 2.2 install - Sharepoint errors

Post by vschindler » Aug 24, 2018 8:11 am

@SYSADMIT

You're right.

Yes, backup goes to the end with Warning, but then the folder is empty. When something is deleted in this folder, then you're unlucky. In my case, Folder Wiki is available, but without a file. I intend to copy all files from this folder and secure myself with it.
But in the future this problem should be solved. This is just the first version of SharePoint Backup.

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Aug 28, 2018 3:32 pm

Vitali,

Sorry for my late reply. Are you still suffering from this problem? Because then it needs to get fixed. When you backup a folder, (although a wiki is special since it is some sort of XHTM file if I am not mistaken), the file should be there.

vschindler
Novice
Posts: 6
Liked: 1 time
Joined: Aug 22, 2018 11:58 am
Full Name: Vitali Schindler
Contact:

Re: New 2.2 install - Sharepoint errors

Post by vschindler » Aug 29, 2018 1:42 pm

Mike,

Yes, problem still exists. Although the folder WiKi is present in the backup, the contents of this folder is empty. For other folders, everything is OK. And the mistake continues -
28.08.2018 21:09:31 :: Processing site https://companyname.sharepoint.com/DepartamentIT finished with warning: Failed to backup list: Wiki, Die Anforderung verwendet zu viele Ressourcen. :: 0:03:04

wileywimberly
Service Provider
Posts: 32
Liked: never
Joined: Sep 29, 2015 4:52 pm
Full Name: Wiley Wimberly
Contact:

Re: New 2.2 install - Sharepoint errors

Post by wileywimberly » Aug 29, 2018 2:24 pm

We are also seeing "Failed to backup list: XXX, The request uses too many resources" on four sites. Many others complete without issue.

Case #03166798

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Aug 29, 2018 2:35 pm

@Vitali,

Did you upload the logs? I looked at your case but I see no logs?

@Wiley,
Please create a support case also. Thanks EDITED: Sorry Wiley, you already posted your case number, my bad :-(

coreypenford
Influencer
Posts: 14
Liked: never
Joined: Mar 28, 2018 6:46 pm
Contact:

Re: New 2.2 install - Sharepoint errors

Post by coreypenford » Aug 30, 2018 5:55 pm

Still roadblocked with Case # 03154343

By this thread and the support agents recommendation, we need to run 'Set-SPOTenant -LegacyAuthProtocolsEnabled $true' to enable legacy auth on Sharepoint (as I said earlier, modern is on by default).

The problem is, we have a strict change control board in place for things like this. And I can't find any documentation on what legacy authentication actually is. Not to mention no Veeam documentation on this being a requirement..

vschindler
Novice
Posts: 6
Liked: 1 time
Joined: Aug 22, 2018 11:58 am
Full Name: Vitali Schindler
Contact:

Re: New 2.2 install - Sharepoint errors

Post by vschindler » Aug 31, 2018 8:42 am

@Mike Resseler,

Hallo Mike,
I was on business, could not upload logs. Now I have made the settings for Extended Logging and try to restart the jobs, but now I get the error that File Repository.xml is owned by another process.
As soon as I fix this error, I'll upload the logs

Mike Resseler
Product Manager
Posts: 5695
Liked: 599 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: New 2.2 install - Sharepoint errors

Post by Mike Resseler » Sep 04, 2018 5:42 am

@Vitaliy,
Thanks!

@Coreypenford: Unfortunately we need this native authentication for now (Or legacy). We are investigating to support the modern authentication approach, but it requires quite some work as we don't want you to retype a password or do a challenge every day or similar to run a service :-).

No ETA for this however at this point in time, but we are working on it

vschindler
Novice
Posts: 6
Liked: 1 time
Joined: Aug 22, 2018 11:58 am
Full Name: Vitali Schindler
Contact:

Re: New 2.2 install - Sharepoint errors

Post by vschindler » Sep 28, 2018 8:42 am 1 person likes this post

Hi,

Installing update https://www.veeam.com/kb2765 fixes the bug in my case. Backup ran today without error.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests