Comprehensive data protection for all workloads
Post Reply
stevenj

2003 AD servers seem to lock up while replication taes place

Post by stevenj » Dec 06, 2010 3:45 am

Hi,

I am having an issue with trying to replicate 4 x AD servers.....the incrimental takes about 30mins during which time the AD servers seem un-responsive....which kind of buggers AD....

I cant see any sign of a fault....so Im scratching my head here, any ideas please?

regards

Vitaliy S.
Product Manager
Posts: 23010
Liked: 1560 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: 2003 AD servers seem to lock up while replication taes p

Post by Vitaliy S. » Dec 06, 2010 8:36 am

Hello Steven,

Could you please tell what is the replication target for your virtual AD servers? Do those servers become unresponsive on the snapshot commitment task? Also what is the host version you're running AD VMs on?

Thanks!

stevenj

Re: 2003 AD servers seem to lock up while replication taes p

Post by stevenj » Dec 06, 2010 9:39 pm

Replication target is 4.02 build 261974 ESXi....a Dell R900 4 x 4 3Ghz with 128Gb ram, SAN is Sun 7410 in fibre channel mode. I dont know when they become un-responsive, I will do a trial now I have been informed of it to gather more info....I have been told they seem to go un-responsive for the entire 30min incremental replication, I will check.

Host is 4.02 build 261974 ESXi R710 2 x hex 3.33Ghz with 144Gb ram, SAN is EMC CX3-80..

stevenj

Re: 2003 AD servers seem to lock up while replication taes p

Post by stevenj » Dec 06, 2010 11:22 pm

report from my AD person....it seems to be the snapshot period.

Last week (I think it was Tuesday 30th) whilst I was working in the Exchange 2010 POC environment, the Exchange servers fell out of communication with the lab’s domain controllers. I checked the DCs, and they seemed to be up, but Exchange was producing errors about not being able to communicate with them. I could ping them, connect to their consoles, but AD services seemed to be stalled from the Exchange perspective.

I checked the vSphere and snapshots were being taken of the RESWIN DC. That was the DC that the Exchange servers were using at that point. I watched until the processes were complete, retrying my AD tasks every few minutes. They failed right up until the ‘svc-veeam_dr’ service account has completed its tasks. As soon as these snapshots were complete normal comms was resumed. I’ve checked today however, and I can’t find any task logs of the events in vSphere.

Gostev
SVP, Product Management
Posts: 24812
Liked: 3573 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: 2003 AD servers seem to lock up while replication taes p

Post by Gostev » Dec 07, 2010 12:06 am

In short, it is completely impossible for VMware snapshot to affect any server in such a way. So, if there is a reason for this behavior - it cannot be related to snapshot presence.

tsightler
VP, Product Management
Posts: 5425
Liked: 2244 times
Joined: Jun 05, 2009 12:57 pm
Full Name: Tom Sightler
Contact:

Re: 2003 AD servers seem to lock up while replication taes p

Post by tsightler » Dec 07, 2010 2:50 am

Any chance it's something to do with VSS? Have you tried disabling the application aware processing just to see?

I suppose if you have an exceptionally busy domain controller (I've seen some pretty busy DC's in larger environments with lots of auditing enabled) it might perform so poorly with a snapshot that it would appear to hang, however, you should have more than one domain controller, so even if that one DC with a snapshot quit responding life should continue as normal on the other controllers and Exchange should simply fail over to using them.

That being said, we backup/replicate all of our domain controllers and have never experienced anything like this at all. What version of Windows?

Gostev
SVP, Product Management
Posts: 24812
Liked: 3573 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: 2003 AD servers seem to lock up while replication taes p

Post by Gostev » Dec 07, 2010 10:29 pm

tsightler wrote:Have you tried disabling the application aware processing just to see?
Definitely do not want to do that, except for a sake of experiment, with a separate backup job. And delete all produced backups immediately to prevent any chance of accidentally restoring them back into production environment. Otherwise, USN rollback will FUBAR the domain controller.

tsightler
VP, Product Management
Posts: 5425
Liked: 2244 times
Joined: Jun 05, 2009 12:57 pm
Full Name: Tom Sightler
Contact:

Re: 2003 AD servers seem to lock up while replication taes p

Post by tsightler » Dec 08, 2010 4:50 pm

Obviously I meant to test the issue. If the problem still occurs, then it's obviously a VMware snapshot issue since Veeam isn't even involved. If the problem does not occur, then it might be some strange interaction with VSS.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot], iL1fe, TheJourney, TimLawhead and 42 guests