9.0.0.1715 > 9.5.0.823 in-place upgrade error

Availability for the Always-On Enterprise

9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby DDIT » Tue Feb 21, 2017 9:14 am

Hi,

I have 9.0.0.1715 installed on 2012R2, along with Veeam Backup for O365.

I have this morning downloaded the latest 9.5 ISO, mounted, then run setup.exe. I click the huge 'upgrade' button, but get "another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remote Programs on the Control Panel."

Page 21 of the release notes (https://www.veeam.com/pdf/release_notes/veeam_backup_9_5_release_notes_en.pdf) says "Veeam Backup & Replication 9.5 supports automated in-place upgrade from version 9.0 (any update level)"

Should I remove v9 first? Or am I missing something obvious?

No rush.
Thanks.

ISO MD5 matches that on the download page: 1c0365e74e872b53b1a5a4b725f52d43
DDIT
Influencer
 
Posts: 19
Liked: 3 times
Joined: Thu Oct 29, 2015 5:58 pm
Full Name: Michael Yorke

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby Mike Resseler » Tue Feb 21, 2017 9:19 am

Hmmm,

It might be because of O365. We never looked at it because you actually need 9.5 to have O365 installed together because of the Veeam Explorer for Exchange version. Could you check what version that is? That might be the one doing difficult. I think you upgraded the Veeam explorer when installing VBO (PS: Is that already update 1?)

I would also create a support call for this, post the case ID here (and resolution afterwards)

Brgds,
Mike
Mike Resseler
Veeam Software
 
Posts: 2639
Liked: 316 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby DDIT » Tue Feb 21, 2017 3:47 pm

Hi,

I installed Veeam Backup for O365 just last week. Whilst the O365 backups were fine, I could not browse the backups with Veeam Explorer for Exchange. I remembered that the download for O365 contained a separate updater for Veeam Explorer for Exchange, so installed this (which upgraded Veeam Explorer to 9.5) which then fixed the problems browsing the backups.

So maybe you are correct in that this has broken the upgrade for VBR 9.5. I have opened a support case #02077915 and will post updates here.
DDIT
Influencer
 
Posts: 19
Liked: 3 times
Joined: Thu Oct 29, 2015 5:58 pm
Full Name: Michael Yorke

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby Mike Resseler » Wed Feb 22, 2017 6:12 am

Thanks Michael,

I am actually curious what the result is going to be here ;-)
Mike Resseler
Veeam Software
 
Posts: 2639
Liked: 316 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby DDIT » Fri Feb 24, 2017 12:47 pm

Ok, so just got off the support chat with the engineer.

He confirmed the same error when he ran the upgrade. So, he checked the version number within Veeam B&R (File > Help > About = 9.0.0.1715). Then went into the Control Panel and noticed...

Veeam Backup & Replication 9.5.0.912

and below that

Veeam Backup for Microsoft Office 365 9.5.0.912

I suggested that when I installed Veeam for O365 last week, and also Veeam Explorer it must have incorrectly updated the version number for Veeam B&R. He dismissed that as unlikely and said he has never seen it do that.

I'm not sure. Is someone prepared to test?

For the record, the Veeam for O365 download contains two MSI files (VeeamBackupOffice365_1.0.0.912.msi & VeeamExplorerForExchange_9.5.0.912.msi). I installed both on my Veeam Server. Notice the version number on the Veeam Explorer for Exchange MSI. Coincidence?!

The conclusion is I should just uninstall Veeam B&R v9 and install v9.5 fresh, which I expect will work fine. The engineer did not do this on this support call as time was tight, so I will attempt this myself next week when I have more time.

Regards
Michael.
DDIT
Influencer
 
Posts: 19
Liked: 3 times
Joined: Thu Oct 29, 2015 5:58 pm
Full Name: Michael Yorke

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby DDIT » Tue Mar 07, 2017 3:15 pm

Hi,

I uninstalled v9.0 manually, then installed v9.5 manually. The configuration database was found and upgraded during the installation. All appears to be working well with 9.5. Case closed.

Regards
Michael.
DDIT
Influencer
 
Posts: 19
Liked: 3 times
Joined: Thu Oct 29, 2015 5:58 pm
Full Name: Michael Yorke

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby Mike Resseler » Wed Mar 08, 2017 6:52 am

Thanks Michael,

Did you had to remove the Veeam Explorer? Or anything related to VBO?
Mike Resseler
Veeam Software
 
Posts: 2639
Liked: 316 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby DDIT » Mon Mar 13, 2017 7:53 am

Nope. I did not remove any other Veeam products prior to the upgrade.

Just manually uninstalled Veeam B&R v9 from the Control Panel > Programs and Features. The started the install of v9.5
DDIT
Influencer
 
Posts: 19
Liked: 3 times
Joined: Thu Oct 29, 2015 5:58 pm
Full Name: Michael Yorke

Re: 9.0.0.1715 > 9.5.0.823 in-place upgrade error

Veeam Logoby Mike Resseler » Tue Mar 14, 2017 7:58 am

Thanks Michael! Appreciate the response
Mike Resseler
Veeam Software
 
Posts: 2639
Liked: 316 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot], rkovhaev, Yahoo [Bot] and 15 guests