Comprehensive data protection for all workloads
GregorD
Enthusiast
Posts: 53
Liked: 5 times
Joined: May 31, 2018 6:44 pm
Full Name: Gregor Duzic
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by GregorD » Feb 11, 2019 7:25 pm

CamileB
do you have installed sp2 for Windows 2008? https://support.microsoft.com/en-us/hel ... r-2008-sp2

DakoJordan
Lurker
Posts: 2
Liked: 2 times
Joined: Apr 02, 2018 3:32 pm
Full Name: Jordan A. Klocko
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by DakoJordan » Feb 12, 2019 4:37 pm 2 people like this post

wishr wrote:
Feb 07, 2019 9:55 am
That's a bit strange that you are experiencing the issue on 2012R2, however I would first of all check for SHA-2 code signing updates.

Please keep us posted about the situation.
Hi Wishr,

I had opened a case with Veeam to get this resolved, but I ended up finding the workaround solution myself. I believe it has to do with permissions/UAC, but I'm unsure where. Hopefully this is useful to others that might be having the same issue. Here's what I discovered:

Server 1:
  • OS: Windows Server 2016
    • Patch Status: fully patched
    • Driver Signature Enforcement: Disabled through pre-boot menu
    • Current user: User-created admin account with membership in domain admins
    • Problem
      • Installing the MSI by right-clicking the MSI and choosing install prompts for elevation through UAC
      • Installation fails on the “processing drivers” step of the installer with the error “Failed to install file system drivers”
    • Resolution
      • Open a command prompt as admin
      • Navigate to the Packages folder of the mounted ISO of Update 4
      • Run MsiExec /I VeeamMountService.msi
      • Install succeeds without issue
Server 2:
  • OS: Windows Server 2012 R2
    • Patch Status: not fully patched
    • Driver Signature Enforcement: Enabled
    • Current user: User-created admin account with membership in domain admins
    • Problem
      • Installing the MSI by right-clicking the MSI and choosing install prompts for elevation through UAC
      • Installation fails on the “processing drivers” step of the installer with the error “Failed to install file system drivers”
    • Resolution
      • Navigate to the Packages folder of the mounted ISO of Update 4 through Windows Explorer
      • Shift-right-click MSI and choose “Run as different user”
      • Enter domain administrator credentials (so the CMD window is running as the native domain administrator account, not the admin account created by us)
      • Install succeeds without issue

wishr
Veeam Software
Posts: 1331
Liked: 132 times
Joined: Aug 07, 2018 3:11 pm
Full Name: Fedor Maslov
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by wishr » Feb 13, 2019 9:31 am

Hi Jordan,

Thanks for sharing the information. Could you please also let us know your support case ID?

Thank you

Post Reply

Who is online

Users browsing this forum: oleg.feoktistov, sreedama2, wishr and 38 guests