Comprehensive data protection for all workloads
DanielCIS
Service Provider
Posts: 8
Liked: 1 time
Joined: Jan 28, 2015 9:52 pm
Full Name: Daniel Hadland
Contact:

9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by DanielCIS » Jan 25, 2019 4:50 pm

Hi all,

I've upgraded to the GA version of 9.5U4 all ok but having an issue with a secondary proxy failing to upgrade. Initially from the VBR console I was getting output saying "Upgrade failed, see installer logs" or similar. I then went to the secondary proxy and manually installed the relevant packages and have narrowed it down to the Mount Service.

When I run the installer for just this package it throws the error "Veeam Mount Service Installer Information - Failed to install file system drivers." Looking at the FlrDrvInstaller.log file I then get the following:

Code: Select all

[25.01.2019 16:45:15] < 10952> ================================================================================
[25.01.2019 16:45:15] < 10952> VeeamFlrDrvInstaller.
[25.01.2019 16:45:15] < 10952> Host process path: C:\Program Files\Common Files\Veeam\Backup and Replication\Mount Service\Veeam.Backup.MountService.exe.
[25.01.2019 16:45:15] < 10952> Process: 64 bit.
[25.01.2019 16:45:15] < 10952> SureFlrDriversInstalled
[25.01.2019 16:45:15] < 10952>   Service [VirtualDK] [install]
[25.01.2019 16:45:15] < 10952>     Loading legacy driver VirtualDK
[25.01.2019 16:45:15] < 10952>       Service VirtualDK was registered at the SCM for the first time. Binary file path [C:\Program Files\Common Files\Veeam\Backup and Replication\Mount Service\vdk.sys].
[25.01.2019 16:45:15] < 10952>     Loading legacy driver VirtualDK Failed.
[25.01.2019 16:45:15] < 10952>   Service [VirtualDK] [install] Failed.
[25.01.2019 16:45:15] < 10952> ERR |Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.
[25.01.2019 16:45:15] < 10952> >>  |Failed to start service VirtualDK.
[25.01.2019 16:45:15] < 10952> >>  |--tr:Error code: 0x00000241
[25.01.2019 16:45:15] < 10952> >>  |An exception was thrown from thread [10952].
[25.01.2019 16:45:15] < 10952> SureFlrDriversInstalled Failed.
[25.01.2019 16:45:15] < 10952> VeeamFlrDrvInstaller detached.
[25.01.2019 16:45:15] < 10952> ================================================================================
[25.01.2019 16:45:15] < 10952> 
[25.01.2019 16:45:52] < 10136> cli| LOG: Initializing log file ...
[25.01.2019 16:45:52] < 10136> ================================================================================
[25.01.2019 16:45:52] < 10136> VeeamFlrDrvInstaller.
[25.01.2019 16:45:52] < 10136> Host process path: C:\Program Files\Common Files\Veeam\Backup and Replication\Mount Service\Veeam.Backup.MountService.exe.
[25.01.2019 16:45:52] < 10136> Process: 64 bit.
[25.01.2019 16:45:52] < 10136> SureDriversUninstalled
[25.01.2019 16:45:52] < 10136>   Un-installing FLR driver.
[25.01.2019 16:45:52] < 10136>     Trying to open FLR driver
[25.01.2019 16:45:52] < 10136>     FLR driver is not installed
[25.01.2019 16:45:52] < 10136>     There is no installed FLR driver.
[25.01.2019 16:45:52] < 10136>   FLR driver was successfully un-installed.
[25.01.2019 16:45:52] < 10136>   Unloading service VeeamFSR.
[25.01.2019 16:45:52] < 10136>   Service VeeamFSR does not exist.
[25.01.2019 16:45:52] < 10136>   Unloading service VirtualDK.
[25.01.2019 16:45:52] < 10136>   VirtualDK stopped.
[25.01.2019 16:45:52] < 10136>   Service VirtualDK was deleted.
[25.01.2019 16:45:52] < 10136> SureDriversUninstalled ok.
[25.01.2019 16:45:52] < 10136> VeeamFlrDrvInstaller detached.
[25.01.2019 16:45:52] < 10136> ================================================================================
[25.01.2019 16:45:52] < 10136> 
Platform is Windows Server 2008 R2 Datacentre, any thoughts?

Thanks,
Dan

foggy
Veeam Software
Posts: 17725
Liked: 1483 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by foggy » Jan 25, 2019 5:01 pm

Hi Dan, please open a case with our technical support for a closer look. Thanks!

Gostev
SVP, Product Management
Posts: 24022
Liked: 3257 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by Gostev » Jan 25, 2019 5:02 pm

Daniel, as requested when you click New Topic: please avoid posting random log snippets that you think might be relevant to your issue, and instead include a support case ID containing the full debug log package. These core forum rules are always important to follow, but right now they are absolutely essential to follow with the usual spike of posts on technical issues due to the new major release. Thanks for understanding!

DanielCIS
Service Provider
Posts: 8
Liked: 1 time
Joined: Jan 28, 2015 9:52 pm
Full Name: Daniel Hadland
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by DanielCIS » Jan 25, 2019 5:51 pm 1 person likes this post

Hi all,

No problem, case logged #03381868

Cheers,
Dan

mickej67
Novice
Posts: 9
Liked: 1 time
Joined: Nov 20, 2014 4:09 pm
Full Name: Michael Johansson
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by mickej67 » Jan 28, 2019 10:27 am

Any solution?

v.eremin
Product Manager
Posts: 16160
Liked: 1320 times
Joined: Oct 26, 2012 3:28 pm
Full Name: Vladimir Eremin
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by v.eremin » Jan 28, 2019 1:05 pm

It seems that original issue has been caused by driver signature enforcement policy, but we're still waiting to hear from Daniel to confirm the guess.

In the meantime, kindly, open your own ticket and provide debug logs - the root cause might vary.

Thanks!

mickej67
Novice
Posts: 9
Liked: 1 time
Joined: Nov 20, 2014 4:09 pm
Full Name: Michael Johansson
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by mickej67 » Jan 29, 2019 8:29 am

I am getting this on a Windows 2008 R2.

The VeeamFCT service failed to start due to the following error:
Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.

GregorD
Enthusiast
Posts: 52
Liked: 5 times
Joined: May 31, 2018 6:44 pm
Full Name: Gregor Duzic
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by GregorD » Jan 29, 2019 6:13 pm

I have the same error , i cannot update mount Service on Windows Server 2008 r2 Standard
Case is open
when i manually start the msi for Installation mount Service it Comes to VmAddFwRulesPhased and then i become Access denied.
But i dont have antivirus. Windows Firewall is disabled.

Gostev
SVP, Product Management
Posts: 24022
Liked: 3257 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by Gostev » Jan 30, 2019 12:51 am

Can you make sure you have all the latest Windows Updates installed on your server?

GregorD
Enthusiast
Posts: 52
Liked: 5 times
Joined: May 31, 2018 6:44 pm
Full Name: Gregor Duzic
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by GregorD » Jan 30, 2019 9:45 am

Can you be more specific ,which update is requiered? We use WSUS and everything is enabled to install.

bogdan.grecu
Lurker
Posts: 1
Liked: never
Joined: Jan 31, 2017 7:07 am
Full Name: Bogdan G
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by bogdan.grecu » Jan 30, 2019 9:51 am

Hello Daniel,

You might want to try this:

Enter in Advanced Options menu in Windows 2008R2:

Close all programs and reboot your computer.
Press the "F8" key as your computer is booting up, before the appearance of the Windows logo.
When the "Windows Advanced Options Menu" appears on your screen, use your keyboard arrow keys to highlight the “Disable Driver Signature Enforcement” option and then press "ENTER".

Jay.SD
Novice
Posts: 4
Liked: 2 times
Joined: Jan 30, 2019 5:07 pm
Full Name: Jeremy Ayson
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by Jay.SD » Jan 30, 2019 5:13 pm

I've got a similar issue after upgrading from 9.5.0 to U4. Remote managed server fails to upgrade its components. Nothing relevant in the installer logs. My currently opened ticket has been escalated.

Transport and vPowerNFS components both are update on the remote server but Mount Service and WAN Acc. Service are still at the older version.

Is it possible to upgrade the mount service on the remote server manually?

GregorD
Enthusiast
Posts: 52
Liked: 5 times
Joined: May 31, 2018 6:44 pm
Full Name: Gregor Duzic
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by GregorD » Jan 30, 2019 8:11 pm

yes open dvd folder packages and there you have all services

Jay.SD
Novice
Posts: 4
Liked: 2 times
Joined: Jan 30, 2019 5:07 pm
Full Name: Jeremy Ayson
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by Jay.SD » Jan 30, 2019 9:00 pm

Well that attempt didn't work. I was able to upgrade the WAN Service locally but not the mount service. My ticket is currently "In research".

Jay.SD
Novice
Posts: 4
Liked: 2 times
Joined: Jan 30, 2019 5:07 pm
Full Name: Jeremy Ayson
Contact:

Re: 9.5 U3a to U4 Upgrade Issues - Veeam Mount Service

Post by Jay.SD » Jan 31, 2019 5:14 am

second remote session with a Veeam Engineer could not resolve the issue. Veeam support has all the logs after multiple troubleshooting steps.
I do know one thing about this issue Windows 2008 R2 is the common in this thread so far...

Post Reply

Who is online

Users browsing this forum: Karinne and 41 guests