9.5 Update 1 instructions missing a bit of info

Availability for the Always-On Enterprise

9.5 Update 1 instructions missing a bit of info

Veeam Logoby philfreund » Fri Feb 24, 2017 1:47 pm

I just upgraded from 9.5 base to 9.5 Update 1 and found that the upgrade procedure notes are missing a few things.

1. I used the steps in the note and followed all of the steps as stated. However, I found that that I had to do another server reboot after applying the update since the Veeam Backup Service didn't restart. (At least 3 of the services didn't restart.) Everything went smoothly after that.

2. There's no note indicating that if you have Enterprise Manager installed, you need to run the Update 1 upgrade against it.
philfreund
Influencer
 
Posts: 21
Liked: 2 times
Joined: Fri Apr 01, 2016 6:16 pm
Full Name: Phil Freund

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby Mike Resseler » Fri Feb 24, 2017 2:00 pm

Phil,

What notes are you referring to?
Mike Resseler
Veeam Software
 
Posts: 3088
Liked: 359 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby philfreund » Fri Feb 24, 2017 2:25 pm

KB 2222 Release Notes for Veeam Backup & Replication 9.5 Update 1
philfreund
Influencer
 
Posts: 21
Liked: 2 times
Joined: Fri Apr 01, 2016 6:16 pm
Full Name: Phil Freund

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby Mike Resseler » Fri Feb 24, 2017 2:45 pm

Phil,

Normally the entire procedure is described in the release notes (the other is a KB article) which can be found here: https://www.veeam.com/pdf/release_notes ... tes_en.pdf

But I do believe that the services should have been restarted so there might have gone something wrong during the upgrade. Is everything now working as expected?
Mike Resseler
Veeam Software
 
Posts: 3088
Liked: 359 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby philfreund » Fri Feb 24, 2017 2:48 pm

Everything is running fine now. Just had to do the extra reboot to get the services started. BTW, this happened on both of my servers that I had to upgrade.
philfreund
Influencer
 
Posts: 21
Liked: 2 times
Joined: Fri Apr 01, 2016 6:16 pm
Full Name: Phil Freund

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby Mike Resseler » Fri Feb 24, 2017 2:50 pm

Thanks for letting me know. Any change that you still remember exactly what services didn't start (I have a feeling that they tried to start but that another service was not available so they timed-out
Mike Resseler
Veeam Software
 
Posts: 3088
Liked: 359 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby philfreund » Fri Feb 24, 2017 2:56 pm

I don't remember all of them but I do remember that besides the Veeam Backup Service, the Veeam Installer Service wasn't started.
philfreund
Influencer
 
Posts: 21
Liked: 2 times
Joined: Fri Apr 01, 2016 6:16 pm
Full Name: Phil Freund

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby Mike Resseler » Fri Feb 24, 2017 4:40 pm

Again, thanks Phil. We take these kind of things very serious (trust me on that one) so we investigate issues all the time and the more information we get... Well, you know ;-)
Mike Resseler
Veeam Software
 
Posts: 3088
Liked: 359 times
Joined: Fri Feb 08, 2013 3:08 pm
Location: Belgium, the land of the fries, the beer, the chocolate and the diamonds...
Full Name: Mike Resseler

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby Gostev » Sat Feb 25, 2017 12:03 am

Mike Resseler wrote:But I do believe that the services should have been restarted so there might have gone something wrong during the upgrade.

Not restarted, just started (by the update installer) as services should be stopped for the duration of the update. And if the installer cannot start services. If reboot was required, perhaps the services simply were not stopped before the update?
Gostev
Veeam Software
 
Posts: 21354
Liked: 2333 times
Joined: Sun Jan 01, 2006 1:01 am
Full Name: Anton Gostev

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby philfreund » Sat Feb 25, 2017 1:09 am

I had actually followed the instructions and shutdown all of the services before applying the update. Thus they didn't all start until I did the reboot.

BTW, how was I supposed to find the full Release Notes? There is no link to them in the KB.
philfreund
Influencer
 
Posts: 21
Liked: 2 times
Joined: Fri Apr 01, 2016 6:16 pm
Full Name: Phil Freund

Re: 9.5 Update 1 instructions missing a bit of info

Veeam Logoby Gostev » Sat Feb 25, 2017 2:09 am 1 person likes this post

philfreund wrote:Thus they didn't all start until I did the reboot.

Update setup always starts the services before exiting, or tells you if reboot is required due to locked files - thus the KB article itself does not instruct you to perform the reboot.

I don't recall any other users reporting issue similar to yours, so I can only assume it could have been something environment-specific, for example antivirus preventing the service from starting. We may be able to find the reason if you send us the MSI log file (it will show whether the service was started successfully from the OS perspective).

And you were not supposed to find the Release Notes because you don't need them to install the update (the KB article has all the info). That said, all product documentation can always be found in Veeam Help Center
Gostev
Veeam Software
 
Posts: 21354
Liked: 2333 times
Joined: Sun Jan 01, 2006 1:01 am
Full Name: Anton Gostev


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot], Google Feedfetcher and 24 guests