Comprehensive data protection for all workloads
Post Reply
Matts N
Enthusiast
Posts: 59
Liked: 10 times
Joined: Dec 27, 2010 10:41 am
Full Name: Matts Nilsson
Contact:

After a backup job completes, it is not visible under heading "Backups"

Post by Matts N »

Hello,
Case 05915960.

We have a demo environment that was running v11a. Upgraded to v12. After upgrade, two backup jobs using tags as selection criteria doesn't show under "Backups" heading, meaning there is no way to restore any files. A backup copy job of these two backup jobs gives a warning "No restore points found".

The backup files are present on the repository, the result of the run is listed under "History", and Enterprise Manager shows the result of the jobs as well. Other jobs using VM's as selection criteria does not have this problem, with everything else the same (using same proxies, repository etc).

Any one else stumbled upon this?

// Matts
moustafa_hindawi
Veeam Legend
Posts: 7
Liked: never
Joined: Feb 25, 2023 12:43 pm
Full Name: Moustafa Hindawi
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by moustafa_hindawi »

Requirements and Recommendations for VM Tags

When you work with tags in Veeam Backup & Replication, mind the following requirements and recommendations:
  • The VirtualCenter.FQDN parameter in the Advanced Settings of vCenter Server must contain the real fully qualified domain name of the vCenter Server host.
    A certificate installed on vCenter Server must contain the real fully qualified domain name of the vCenter Server host.
    The fully qualified domain name of the vCenter Server host must be accessible and resolved to its IP (and vice versa) from machines on which Veeam Backup & Replication services are installed (at least the Veeam Backup Service and Veeam Broker Service).
    A user account used for specific data protection and disaster recovery operations must have sufficient permissions on the vCenter Server. For more information, see Full VM Restore, Replica Failback and Cumulative Permissions sections in the Permissions Reference.
    If VM tags are not displayed in the Veeam Backup & Replication console for some reason, try restarting VMware vSphere services that are responsible for the tags functionality. In VMware vSphere earlier than 6.5, you must restart the vCenter Inventory Service. Starting from VMware vSphere 6.5, vCenter Inventory Services functionality is replaced by the vCenter Content Library and other services that are part of vCenter Server 6.5.
    When you upgrade to VMware vSphere 6.5, data from vCenter Inventory Service is migrated to the new database support services in vCenter Server 6.5. The vCenter Inventory Service may remain in the list of services, however, it is no longer used.

    If you are using the vSphere Fault Tolerance feature, assign VM tags in one of the following ways in order to provide proper VM backup processing by Veeam Backup & Replication:
    Assign the required VM tag to the primary VM. In case of the failover to the secondary VM, the VM tag is copied to the secondary VM and this VM is used as a source for continuing Veeam Backup & Replication jobs.
    Assign the required VM tag to the VM container that comprises the primary VM in the virtual infrastructure inventory. The primary VM inherits this tag. In case of the failover to the secondary VM, the VM tag is copied to the secondary VM and this VM is used as a source for continuing Veeam Backup & Replication jobs.
    Thus, there is no need to assign the VM tag to the secondary VM. Moreover, if you manually assign the same tag both to the primary VM and the secondary VM and use this tag to add objects to a VM backup job, this will result in the backup failure.
Matts N
Enthusiast
Posts: 59
Liked: 10 times
Joined: Dec 27, 2010 10:41 am
Full Name: Matts Nilsson
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by Matts N »

The problem isn't getting the backup to run using tags. To try to clarify the problem...

Backup job selects VM's by tag.
Backup job runs without errors.
When looking under Home -> Backups -> Disk the backup job is missing in the list, but backup files exist on the repository.

A backup copy job connected to the backup job ends with warning "No restore points found", indicating it cannot find the latest backup.
Other backup jobs not using tags as selection criteria works as expected.
PetrM
Veeam Software
Posts: 3216
Liked: 515 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by PetrM »

Hi Matts,

The best option now is to let our support team investigate this technical issue. I doubt that you would find any relevant information on the forums, we cannot troubleshoot technical problems effectively over the forum posts because we don't have access to debug logs or to your infrastructure.

Thanks!
Matts N
Enthusiast
Posts: 59
Liked: 10 times
Joined: Dec 27, 2010 10:41 am
Full Name: Matts Nilsson
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by Matts N » 1 person likes this post

Hello Petr,
Only reason I posted here was to see if we are the only ones who experienced this or if there are others as well. I will wait for the support team to get back to me, no worries.

Cheers!
Matts N
Enthusiast
Posts: 59
Liked: 10 times
Joined: Dec 27, 2010 10:41 am
Full Name: Matts Nilsson
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by Matts N »

Hello Petr,
The case was closed automatically due to lack of support resources. I understand the reasons why it is closed, but at the same time I think it would be valuable to Veeam to see if this is a bug in a new release or if it's something else.

Cheers!
PetrM
Veeam Software
Posts: 3216
Liked: 515 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by PetrM »

Hi Matts,

I agree, we'll discuss this problem internally. The case is closed due to a lack of resources because support of FREE/NFR licensed products is provided on a best-effort so I think you have 2 options: to keep opening support tickets - every attempt increases the chances to get support or to recreate the jobs.

Thanks!
Matts N
Enthusiast
Posts: 59
Liked: 10 times
Joined: Dec 27, 2010 10:41 am
Full Name: Matts Nilsson
Contact:

Re: After a backup job completes, it is not visible under heading "Backups"

Post by Matts N » 1 person likes this post

Hello Petr,
Opened a new case, #05944261.

I tried recreating the job and mapping it to the exising job in the repository. Same result. A completely new job will work though.

Cheers!
Post Reply

Who is online

Users browsing this forum: Baidu [Spider], crbe, garypigott, magnunfs and 148 guests