After SQL restore database appears twice in Veem report

Availability for the Always-On Enterprise

After SQL restore database appears twice in Veem report

Veeam Logoby sta-bitbw » Fri Dec 09, 2016 9:39 am

Hallo all.

I have set up an application aware SQL transaction log backup with backup interval of 15 minutes. This works ok.

After a point-in-time restore Veeam shows in every backup report two instances of the restored database. Once in state Protected, the other in state Excluded. The error message states "Transaction logs from some databases were not backed up for the last <n> intervals".

I can make this go away with manually starting a VM backup (scheduled to run once a day). After this Veeam reports the database only once in state Proteced.

Is this a Veeam issue or is it something with my backup/restore setup?
I guess the VM backup does a database backup that maybe fixes some transaction log things caused by the restore. Is a database backup required after every restore as part of standard recovery procedure?

Thank you,
Thomas.
sta-bitbw
Novice
 
Posts: 4
Liked: never
Joined: Thu Aug 25, 2016 12:19 pm

Re: After SQL restore database appears twice in Veem report

Veeam Logoby foggy » Fri Dec 09, 2016 10:44 am

Hi Thomas, this is expected in case you've performed restore to original location. After the database is restored and until the moment of the next VM backup the Veeam B&R cannot backup it's logs, since there's no backup of the database itself, so the restored database is excluded from the logs processing. Once the SQL server is backed up, the database is switched to protected, instead of the database existed prior the restore.
foggy
Veeam Software
 
Posts: 15087
Liked: 1110 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: After SQL restore database appears twice in Veem report

Veeam Logoby sta-bitbw » Fri Dec 09, 2016 10:49 am

Thank you for the explanation.

Have a nice day.
Thomas
sta-bitbw
Novice
 
Posts: 4
Liked: never
Joined: Thu Aug 25, 2016 12:19 pm

Re: After SQL restore database appears twice in Veem report

Veeam Logoby R.Stuivenberg » Wed Aug 16, 2017 6:57 am

I have the same problem, I can understand that when there has been a restore that until the moment of the next backup I get this error message.

Only a few days later I still get the same error messages and one DB is excluded and one Protected.... I get the message "Transaction logs from some databases were not backed up for the last <n> intervals".
The Excluded DB gives me 23 errors....

Thanks
Richard
R.Stuivenberg
Lurker
 
Posts: 1
Liked: never
Joined: Thu Aug 03, 2017 1:31 pm
Full Name: Richard Stuivenberg

Re: After SQL restore database appears twice in Veem report

Veeam Logoby foggy » Wed Aug 23, 2017 2:25 pm

Hi Richard, in this case please contact technical support for a closer look at why this is happening. Thanks.
foggy
Veeam Software
 
Posts: 15087
Liked: 1110 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: After SQL restore database appears twice in Veem report

Veeam Logoby Irene L. » Tue Oct 03, 2017 2:52 pm

Hi foggy, it seems like expected, however it is confusing indeed, maybe there is a chance that we do somethung about it. here is the full picturel:
1) SQL backup job and every 10 mins log backup- OK
2) Restoring DB point-in-time to riginal location -> right after this DB state in SQL log report is Excluded - also OK
3)After image-level backup of the parent SQL job t in the SQL log Report here are 2 entries, listing the same DB with the same name: 1 excluded &1 protected state- that one is confusing.
For me it stayed the same until i disabled and enabled the parent job, after this everything returned back to normal, just as it was in p.1
It seems like its expected behavior, but doesn`t seem to be right one.
Irene L.
Veeam Software
 
Posts: 29
Liked: 1 time
Joined: Wed Jul 15, 2009 9:20 am
Full Name: Irina Lentsner


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot] and 22 guests