Backup Copy Job still working after Remove from Config/AF

Availability for the Always-On Enterprise

Backup Copy Job still working after Remove from Config/AF

Veeam Logoby mkretzer » Fri Jan 20, 2017 10:51 am

Hello,

right now we are switching to per-VM backup chains and the new REFS integration.
To get a fresh start we remove the backups from the config (not delete!) and then switch the REPO and do an active full. If we would need an old backup we wound rescan and use the imported backup.

What confuses me now is that our backup copy jobs still work after the active full without doing active full for the copy job as well.
Is that normal or is this a problem?

Markus
mkretzer
Expert
 
Posts: 306
Liked: 67 times
Joined: Thu Dec 17, 2015 7:17 am

Re: Backup Copy Job still working after Remove from Config/A

Veeam Logoby DGrinev » Fri Jan 20, 2017 1:48 pm

Hi Markus,

This is expected behavior as Backup copy job has its own separate backup chain of files.
It will write all changes since last BCJ session and your active full on the source job does not trigger active full on BCJ.

Thanks!
DGrinev
Veeam Software
 
Posts: 378
Liked: 48 times
Joined: Thu Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev

Re: Backup Copy Job still working after Remove from Config/A

Veeam Logoby mkretzer » Fri Jan 20, 2017 3:45 pm

But i removed the backups from the database first and then ran an active full. It still works??
mkretzer
Expert
 
Posts: 306
Liked: 67 times
Joined: Thu Dec 17, 2015 7:17 am

Re: Backup Copy Job still working after Remove from Config/A

Veeam Logoby DGrinev » Fri Jan 20, 2017 4:23 pm

It works since your VMs has been added in BCJ, and it can find VMs data in newly created Active Full.
DGrinev
Veeam Software
 
Posts: 378
Liked: 48 times
Joined: Thu Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev

Re: Backup Copy Job still working after Remove from Config/A

Veeam Logoby mkretzer » Wed Feb 01, 2017 3:06 pm

I slowly get the feeling there is some magic involved in BCJ... We were not able to ship the last restore point offsite because of our current REFS problems.

We had to remove the source backup from DB and had to do active full to our old NTFS repo... We thought the BCJ would definately fail now... Nope the job seems to just diff the data in some way from the new active full even with the missing restore point inbetween... How is this possible?
mkretzer
Expert
 
Posts: 306
Liked: 67 times
Joined: Thu Dec 17, 2015 7:17 am

Re: Backup Copy Job still working after Remove from Config/A

Veeam Logoby DGrinev » Thu Feb 02, 2017 11:02 am

Hi Markus,

When you are setting up BCJ you just choose VMs from the certain source (infrastructure, backups, jobs).
Then BCJ looking for the most recent restore points of those VMs in source repository(s).

Thanks!
DGrinev
Veeam Software
 
Posts: 378
Liked: 48 times
Joined: Thu Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot], quazer and 48 guests