Comprehensive data protection for all workloads
Post Reply
Aaron@CRi
Novice
Posts: 7
Liked: never
Joined: Apr 04, 2009 11:05 pm
Full Name: Aaron Fredricks
Contact:

E-mail Notification Error

Post by Aaron@CRi »

I am getting an error when sending a test message. The error reads.

Failure sending mail.
Unable to read data from the transport connection: net_io_connectionclosed.

In this environment Veeam is installed on an admin Windows XP Pro SP.3 workstation. Everything else is working correctly. Any help would be great.

Aaron

Vitaliy S.
Product Manager
Posts: 24256
Liked: 1863 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: E-mail Notification Error

Post by Vitaliy S. »

Hello Aaron,

Could you please send us the logs files to support@veeam.com to investigate the issue? You can find those logs by clicking Help->Support Information.

Also from the error message it seems like you have issues with the connection being closed. Could you please tell us that you've followed all the instructions at our User Guide how to configure email notification?

Cheers,
Vitaliy

Buda
Lurker
Posts: 2
Liked: never
Joined: Aug 06, 2009 12:54 pm
Full Name: Buda from Nepal
Contact:

Re: E-mail Notification Error

Post by Buda »

Hey there,

Is this error solve?
Failure sending mail.
Unable to read data from the transport connection: net_io_connectionclosed.

Windows 2003 Server R2 SP2, default install. Nothing special has been config.

B.

Aaron@CRi
Novice
Posts: 7
Liked: never
Joined: Apr 04, 2009 11:05 pm
Full Name: Aaron Fredricks
Contact:

Re: E-mail Notification Error

Post by Aaron@CRi »

I was not able to get this to work with anything that was not a standard POP3 account. I tried with a Gmail account that was POP3 enabled but it would not work as they use modified ports for POP and SMTP. I have 2 Veeam installs working with 2 standard POP3 email accounts.

Aaron

Buda
Lurker
Posts: 2
Liked: never
Joined: Aug 06, 2009 12:54 pm
Full Name: Buda from Nepal
Contact:

Re: E-mail Notification Error

Post by Buda »

Problem is solve.
Network switch was not conf. as it should be (Vlans ID)

Buda

Gostev
SVP, Product Management
Posts: 26700
Liked: 4276 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: E-mail Notification Error

Post by Gostev »

Buda, thanks for updating the topic with resolution, hopefully this information will be useful for future readers.

carguello
Lurker
Posts: 1
Liked: never
Joined: Sep 12, 2012 3:13 pm
Full Name: Chad Arguello
Contact:

[MERGED] enabling email notfication

Post by carguello »

i was enabling email notification and as i went to sent a test message i got an error message failure sending mail. Unable to read data from the transport connection:net_io_connectioclosed.
i have the same settings that i have used for APC alerts on a rackspace account with no issues.. any suggestions :roll:

m.novelli
Veeam ProPartner
Posts: 365
Liked: 43 times
Joined: Dec 29, 2009 12:48 pm
Full Name: Marco Novelli
Location: Asti - Italy
Contact:

Re: E-mail Notification Error

Post by m.novelli »

It happened today on a Windows 2008 R2 server with Veeam 6.5 patch 3
Server was running fine since one year, now it's 10 days that don't send emails with this error.
I suspect a Microsoft patch?

Marco

Vitaliy S.
Product Manager
Posts: 24256
Liked: 1863 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: E-mail Notification Error

Post by Vitaliy S. »

Marco, thanks for posting in existing topic. Do you have the same issue if you specify any other email account (domain) to send notifications to?

m.novelli
Veeam ProPartner
Posts: 365
Liked: 43 times
Joined: Dec 29, 2009 12:48 pm
Full Name: Marco Novelli
Location: Asti - Italy
Contact:

Re: E-mail Notification Error

Post by m.novelli »

Hi, after some troubleshooting I've found that the error is due to the customer public IP address blacklisted by the RBL http://cbl.abuseat.org

Unfortunately Veeam error message was misleading, I was thinking to an issue with the local backup server (network card, windows firewall, some Microsoft patch)

Marco

Vitaliy S.
Product Manager
Posts: 24256
Liked: 1863 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: E-mail Notification Error

Post by Vitaliy S. »

Glad that you've resolved it. Let me check if we can write a more descriptive error message for these kind of situations.

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

[MERGED] Automated emails failing to send

Post by AlexLeadingEdge »

I am trying to send automated emails from VEEAM One but I keep getting this error:

Failure to send test email message.
Error description: Failure sending mail.Unable to read data from the transport connection: net_io_connectionclosed.

Ticket number is 01723415.

Shestakov
Expert
Posts: 7328
Liked: 773 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: E-mail Notification Error

Post by Shestakov »

Hello,
Have you tried different SMTP server, sender settings?
Based on the users` experience the issue may be caused by some network problems.
Thanks!

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: E-mail Notification Error

Post by AlexLeadingEdge »

I am on a Windows Server 2012 that we use for backups. It is domain joined.

I have tried:

smtp.gmail.com on port 465
aspmx.l.google.com on port 25
smtp-relay.gmail.com on port 25
send.xtra.co.nz on port 465

I have turned off the antivirus, and added an exception to both the local and domain firewalls for port 25, port 465 and port 587 for both incoming and outgoing protocols. No luck.

I have changed the login details to my own personal email address, also using gmail. I have tried to use my personal account using Xtra, another ISP and SMTP server. No luck.

I have checked to see if the WAN IP address is in any email blacklists (as per the situation that m.novelli had). Still no luck!

Is there a component that is missing perhaps? Is there a way to reinstall Veeam One and make sure all the components have installed correctly?
I have run the repair command for the Veeam ONE server. I am wondering if something is missing from the Server itself, perhaps a role or feature that needs to be installed?

Shestakov
Expert
Posts: 7328
Liked: 773 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: E-mail Notification Error

Post by Shestakov »

Default installation should provide all the components.
The easiest way to solve the problem is applying to Veeam technical support.

As an independent workaround I would also try to use the another(3rd party) client on the same mail server to check if emails actually work on the network to find out if Veeam ONE works incorrectly.
Once you contact Veeam support, please post the case number here.
Thanks!

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: E-mail Notification Error

Post by AlexLeadingEdge »

In my first post I mentioned the ticket number is 01723415 :)

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: E-mail Notification Error

Post by AlexLeadingEdge »

Hi guys, got it sorted, seems to have been bad login / port number details. Really annoying! Thanks for your help :)

Shestakov
Expert
Posts: 7328
Liked: 773 times
Joined: May 21, 2014 11:03 am
Full Name: Nikita Shestakov
Location: Prague
Contact:

Re: E-mail Notification Error

Post by Shestakov »

Hi AlexLeadingEdge,
Thanks for updating the thread with the investigation results! Good to know the issue is resolved.

robin.frick
Novice
Posts: 4
Liked: 5 times
Joined: Apr 11, 2016 3:44 pm
Full Name: Robin Frick
Location: Liechtenstein
Contact:

Re: E-mail Notification Error

Post by robin.frick » 4 people like this post

Hello guys,

I fixed an issue with smtp.gmail.com 587 . It seems that if you have a password containing ":" character it does not work and you get a "net_io_connectionclosed" I changed the password containing no special characters and it worked.

AlexLeadingEdge
Expert
Posts: 350
Liked: 43 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: E-mail Notification Error

Post by AlexLeadingEdge » 1 person likes this post

Hi Robin,

That is really interesting! My original password had a colon ":" in it so you may have just solved why it wasn't working for me! I changed the password to random alphanumeric letters and an exclamation mark and changed the port number and it worked.

I found that Port 465 (with or without USE SECURE) didn't work but Port 587 with USE SECURE did, but I also changed the password at the same time so that may have fixed it.

The question remains: is this a Gmail problem or a VEEAM problem?

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], restore-helper and 36 guests