Comprehensive data protection for all workloads
Post Reply
ec-inflxx
Enthusiast
Posts: 48
Liked: never
Joined: Nov 22, 2010 7:03 pm
Contact:

Failed to Upgrade Host Components

Post by ec-inflxx »

Hi,
I am on my 2nd upgrade of Veeam (different machines) and I am getting the same thing. The upgrade goes fine. When I launch Veeam it goes to the Components update. I hit Next and it comes up with an error that states "Failed to upgrade host components. Error: "The process cannot access the file because it is being used by another process. Failed to open the file c:\program files\veeam\backup and replication\backup\upload\xxxxxxx.msi"

Anyone have any idea how to fix this and get it to work?

Thanks.

foggy
Veeam Software
Posts: 20872
Liked: 2048 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Failed to Upgrade Host Components

Post by foggy »

Have you contacted support already?

ec-inflxx
Enthusiast
Posts: 48
Liked: never
Joined: Nov 22, 2010 7:03 pm
Contact:

Re: Failed to Upgrade Host Components

Post by ec-inflxx »

No wanted to see if there was a solution on the forums first before I went that route. Is this a support issue?

foggy
Veeam Software
Posts: 20872
Liked: 2048 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Failed to Upgrade Host Components

Post by foggy »

I cannot recall similar reports here so asking support to review your setup (and logs, if required) would be more effective.

Gostev
SVP, Product Management
Posts: 30013
Liked: 5929 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Failed to Upgrade Host Components

Post by Gostev »

Sounds like an antivirus. I just cannot imagine why any other type of software would start locking up our files.

tdominici
Lurker
Posts: 1
Liked: 3 times
Joined: May 20, 2015 9:20 pm
Full Name: Teddy Jean DOMINICI
Contact:

Re: Failed to Upgrade Host Components

Post by tdominici » 3 people like this post

Hello, i had the same issue with veeam B&R 8 SP 2. I had an error when i tried to update the transport component so i gone to C:\Program Files\Veeam\Backup and Replication\Backup\Packages and i launched manually VeeamTransport.msi and after the installation my error was gone. Hope this can help you.

Regards.

Post Reply

Who is online

Users browsing this forum: No registered users and 33 guests