Comprehensive data protection for all workloads
Post Reply
flavor4real
Expert
Posts: 205
Liked: 5 times
Joined: Nov 22, 2010 7:57 pm
Full Name: DS
Contact:

FIPS error....

Post by flavor4real »

Hello,
I was wondering if anyone else had FIPS error on the Veeam Enterprise Manager? the source code solution I've found will not work.

thanks,

jsoled
Enthusiast
Posts: 48
Liked: never
Joined: Jun 16, 2009 1:01 pm
Full Name: Jason Soled
Contact:

Re: FIPS error....

Post by jsoled »

can you give more details on what you say will not work?

debug mode off combined with specifying 3DES does work. Although not listed as part of the solution it helps to use .NET 3.5 SP1 instead of .NET 2.0

flavor4real
Expert
Posts: 205
Liked: 5 times
Joined: Nov 22, 2010 7:57 pm
Full Name: DS
Contact:

Re: FIPS error....

Post by flavor4real »

Hello,

Once I open the Veeam Backup Enterprise Manager in the Browser, and log on the error below is displayed.
InvalidOperationException
This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
I've looked up several solutions and found the source code snippet below, which I have to past in two locations in the web.config file of the Enterprise manager.
<machineKey validationKey="AutoGenerate,IsolateApps" decryptionKey="AutoGenerate,IsolateApps" validation="3DES" decryption="3DES"/>
However, the instruction I have is the correct pasting of the code snippet for the REPORTER and not the Enterprise Manager. Since the Web.config file is different I don;t know where I need to past it in exactly. In addition, what else do I have to set?

Thanks

jsoled
Enthusiast
Posts: 48
Liked: never
Joined: Jun 16, 2009 1:01 pm
Full Name: Jason Soled
Contact:

Re: FIPS error....

Post by jsoled »

There's one more thing. Look for a line that says debug mode and make sure it's OFF. The devs tell me that it's ok for it to be off in production and are changing the setting to off in all future versions. When debug mode is on, regardless of how you have the encryption set it will use AES which is non compliant. This is a known IIS issue. What complicates matters is that the encryption used with .NET 2.0 is RijndaelManaged, an offshoot of AES, and on others it's a more standard AES implementation. Use .NET 3.5 SP1 if you can.

These settings apply to all Veeam products that have a website, in order to make them all FIPS compliant. I do not know that it matters exactly where the code exists within the web.config file.

This topic has been discussed before. Try this forum post for more details: http://www.veeam.com/forums/viewtopic.p ... ips#p20279

flavor4real
Expert
Posts: 205
Liked: 5 times
Joined: Nov 22, 2010 7:57 pm
Full Name: DS
Contact:

Re: FIPS error....

Post by flavor4real »

I had to contact the Veeam Support Team - closed post -

brupnick
Expert
Posts: 196
Liked: 13 times
Joined: Feb 05, 2011 5:09 pm
Full Name: Brian Rupnick
Location: New York, USA
Contact:

Re: FIPS error....

Post by brupnick »

Were you able to get this resolved with Support? I had a similar issue that I had to resolve on my own because Support said there was nothing they could do.

Vitaliy S.
Product Manager
Posts: 25019
Liked: 2127 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: FIPS error....

Post by Vitaliy S. »

Hello Brian, what is your case number?

brupnick
Expert
Posts: 196
Liked: 13 times
Joined: Feb 05, 2011 5:09 pm
Full Name: Brian Rupnick
Location: New York, USA
Contact:

Re: FIPS error....

Post by brupnick »

Vitaliy S. wrote:Hello Brian, what is your case number?
Sorry Vitality, but I didn't have email notifications enabled for this thread (they're on now). I believe that the case number was 5135777.

Vitaliy S.
Product Manager
Posts: 25019
Liked: 2127 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: FIPS error....

Post by Vitaliy S. »

Brian,

I've looked through your support case, and the workaround you've mentioned is currently the only way to fix it. Your bug/feature request has been noted and we will address this in our next major release (v6).

Thanks!

brupnick
Expert
Posts: 196
Liked: 13 times
Joined: Feb 05, 2011 5:09 pm
Full Name: Brian Rupnick
Location: New York, USA
Contact:

Re: FIPS error....

Post by brupnick »

Vitaliy S. wrote:Brian,

I've looked through your support case, and the workaround you've mentioned is currently the only way to fix it. Your bug/feature request has been noted and we will address this in our next major release (v6).

Thanks!
Thanks Vitaliy.

jsitz
Novice
Posts: 4
Liked: never
Joined: Sep 13, 2010 8:48 am
Full Name: Jérôme Sitz
Contact:

FIPS problem

Post by jsitz »

[merged]

Dear Veeam Team,

Today I've installed Veeam Backup & Replication v6. Replication + Backup works fine but if I try to restore a Linux File, I get this error:
This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
The server OS is a Windows Server 2003 Service 2 64bit. And .Net Framework 3.5 SP1 is installed.

Thanks for your help.

Kind regards

Gostev
SVP, Product Management
Posts: 28425
Liked: 5103 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: FIPS error....

Post by Gostev »

Hi Jerome, it looks like not every place was fixed. Please open a support case for investigation.

Post Reply

Who is online

Users browsing this forum: Google [Bot], nielsengelen and 28 guests