Comprehensive data protection for all workloads
Post Reply
fcmarc
Lurker
Posts: 2
Liked: never
Joined: Jan 26, 2011 3:06 pm
Full Name: MR
Contact:

Incorrect changed block tracking configuration

Post by fcmarc »

Hello,

our environment is:
VMWare vCnter Server 4.1.0
Veeam Backup and Replication 5.0.1.198 (64 bit)

The Problem: Backing up a VM with 5 RAW LUNS is running into this issue:Verifying changed block tracking...
Disk "Festplatte 3" has incorrect changed block tracking configuration.
Disk "Festplatte 4" has incorrect changed block tracking configuration.
Disk "Festplatte 5" has incorrect changed block tracking configuration.
Disk "Festplatte 6" has incorrect changed block tracking configuration.
Disk "Festplatte 7" has incorrect changed block tracking configuration.

Retrieving VM disks information...
Disk '[work1] suse1/suse1_2.vmdk' has been skipped due to unsupported type (raw device mapping in physical mode compatibility mode)
Disk '[work1] suse1/suse1_3.vmdk' has been skipped due to unsupported type (raw device mapping in physical mode compatibility mode)
Disk '[work1] suse1/suse1_4.vmdk' has been skipped due to unsupported type (raw device mapping in physical mode compatibility mode)
Disk '[work1] suse1/suse1_5.vmdk' has been skipped due to unsupported type (raw device mapping in physical mode compatibility mode)
Disk '[work1] suse1/suse1_6.vmdk' has been skipped due to unsupported type (raw device mapping in physical mode compatibility mode)

Backing up object "[work1] suse1/suse1_6.vmdk"

One or more VM disks have incorrect changed block tracking configuration. To resolve this, open VMware vSphere Client, right-click the VM, choose Edit Settings, Options tab, select General, click Configuration Parameters, and set all entries with ‘ctkEnabled’ substring to false. Veeam Backup will then automatically re-enable changed block tracking with the correct settings during the next job run.



Veeam support told me to change the RAW LUN setting in the VM from physical to virtual (compatibility mode), since physical mode isn't supported.
But how can do this?
Thanks for your help.

Greetings
Marc

Vitaliy S.
Product Manager
Posts: 24256
Liked: 1863 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Incorrect changed block tracking configuration

Post by Vitaliy S. »

Though this article states that it only applies to vCenter Server 4.0, I do believe it can be used for 4.1 as well: http://kb.vmware.com/kb/1006599

AlaskanBrewing
Influencer
Posts: 11
Liked: 1 time
Joined: Jul 08, 2009 1:00 am
Contact:

Re: Incorrect changed block tracking configuration

Post by AlaskanBrewing »

I had this same issue and resolved it yesterday on my ESXi 4.1 vSphere server.

I believe Veeam support is mistaken in this case.

The error message you're getting correctly instructs you on how to fix the problem.
One or more VM disks have incorrect changed block tracking configuration. To resolve this, open VMware vSphere Client, right-click the VM, choose Edit Settings, Options tab, select General, click Configuration Parameters, and set all entries with ‘ctkEnabled’ substring to false. Veeam Backup will then automatically re-enable changed block tracking with the correct settings during the next job run.
Shutdown the VM.

Then follow the instructions above. Look for the all the entries ending in 'ctkEnabled', changing them from "TRUE" to "false".

Start the VM back up, once it's running you can retry the Veeam Backup. Veeam will automaticly fix those ctkEnabled entries as needed and the backup will run fine.

If you change your SAN LUN's to Virtual (compatibility mode), at least in my case, Veeam won't work as it can't ignore those disks even if you select the system disk only, or exclude all the SCSI:1, :2, etc..

Gostev
SVP, Product Management
Posts: 26701
Liked: 4276 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Incorrect changed block tracking configuration

Post by Gostev »

Veeam Backup does fully supports RDM disks in virtual mode, including changed block tracking.

AlaskanBrewing
Influencer
Posts: 11
Liked: 1 time
Joined: Jul 08, 2009 1:00 am
Contact:

Re: Incorrect changed block tracking configuration

Post by AlaskanBrewing »

If fcmark is trying to backup the RDM disks in virtual mode, providing he has the space available, I realize Veeam supports that.

However if he's trying to backup only the virtual machine itself only, I was unable to exclude my RDM disk that was running in virtual compatibility mode. Regardless of setting Veeam to exclude it, Veeam kept trying to back it up and erroring out due to a lack of space (hence why I wanted it excluded). My solution was to delete the RDM virtual disk from the VM, and re-add it as a RDM physical disk along the the ctkEnabled setting changes.

If that's the case and I was mistaken at first, and you wish to backup the entire VM plus all the RDM disks, you need to shutdown the VM, Edit the VM settings, remove all your VM's existing RDM disks, then re-add them back to the VM and select virtual. Power the VM back on and the drives should be back as normal and now accessable by Veeam.

fcmarc
Lurker
Posts: 2
Liked: never
Joined: Jan 26, 2011 3:06 pm
Full Name: MR
Contact:

Re: Incorrect changed block tracking configuration

Post by fcmarc »

Hello, thank's a lot for your help - as you mentioned, i would like to backup the entire VM plus all the RDM disks.

I will do the following steps:
Shut down VM, edit Settings -> remove all RDM disks and re-add them in virtual mode.

Is it correct that there will be no data lost, which is still availabe at the RDM disks?

Thanks!
Marc

Vitaliy S.
Product Manager
Posts: 24256
Liked: 1863 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Incorrect changed block tracking configuration

Post by Vitaliy S. »

If you have pRDM disks presented then yes, all you need is to follow closely the instructions in the KB article I have provided earlier. Data on the RDM disks will remain intact.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot] and 28 guests