Availability for the Always-On Enterprise
foggy
Veeam Software
Posts: 16832
Liked: 1361 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Issues with Indexing Backups

Post by foggy » May 29, 2017 3:05 pm

I've checked a couple of cases mentioned above and they are still under investigation. Please open your own cases to confirm the issue and get notified about available solutions.

foggy
Veeam Software
Posts: 16832
Liked: 1361 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: Issues with Indexing Backups

Post by foggy » May 29, 2017 4:27 pm

Latest state from R&D: the issue is confirmed, hotfix for Veeam B&R v9.5 u2 (104602) is available through support and is planned to be included into one of the next updates. Thanks.

bucoops
Enthusiast
Posts: 39
Liked: 1 time
Joined: Aug 01, 2016 6:37 pm
Full Name: Richard
Contact:

Re: Issues with Indexing Backups

Post by bucoops » May 30, 2017 9:13 am

Hi All,

Another user with this issue. Just installed the hotfix and will see how that runs tonight. Our case ref is 02166440

davecla
Enthusiast
Posts: 25
Liked: 4 times
Joined: Feb 03, 2016 9:40 pm
Full Name: Dave Clarke
Contact:

Re: Issues with Indexing Backups

Post by davecla » May 30, 2017 8:34 pm

Hotfix applied here. One time run through the backup cycle completed without warnings or errors.

DaveWatkins
Expert
Posts: 320
Liked: 85 times
Joined: Dec 13, 2015 11:33 pm
Contact:

Re: Issues with Indexing Backups

Post by DaveWatkins » May 30, 2017 8:35 pm

Same here, fix looks good so far

bucoops
Enthusiast
Posts: 39
Liked: 1 time
Joined: Aug 01, 2016 6:37 pm
Full Name: Richard
Contact:

Re: Issues with Indexing Backups

Post by bucoops » May 30, 2017 11:52 pm

Agreed - my cycle just finished and no warnings/errors :)

Now to update the firmware on core switch 1 and then back to bed lol

adruet
Influencer
Posts: 22
Liked: 6 times
Joined: Oct 31, 2012 2:28 pm
Full Name: Alex
Contact:

Re: Issues with Indexing Backups

Post by adruet » Jun 01, 2017 6:32 am

Applied the patch too, and no more warnings !

KeiichiKun
Enthusiast
Posts: 54
Liked: 9 times
Joined: Jul 21, 2016 3:59 pm
Contact:

[MERGED] Guest file system indexing failed in network mode

Post by KeiichiKun » Sep 06, 2017 9:28 am

Hi all,
a backup job of a sql server vm ends with this warning: "Failed to index guest file system. VSSControl: Index failed"
Log has this entry:

Code: Select all

VSSControl: Index failed   at Veeam.Backup.VssProvider.CVssControl.Index(Guid jobId, String[] includeFolders, String[] excludeFolders, String outputDir)
at Veeam.Backup.Core.CViGuestDiskIndexer.Veeam.Backup.Core.IGuestDiskIndexer.Index()
at Veeam.Backup.Core.CViGuestCatIndexer.TryToIndex(Guid jobId, CCatIndex& catIndex, Boolean& isGuestGroupMembersAvailable)
vss::CVeeamIndexingProvider::NetTryCompleteIndex. Failed to complete guest file system indexing in network mode.
All our backup proxies are in automatic mode.
Why could network mode give this error? For a network problem? Should we create another proxy and force it to use another mode instead of automatic and check again?
Thanks!

DGrinev
Veeam Software
Posts: 1220
Liked: 128 times
Joined: Dec 01, 2016 3:49 pm
Full Name: Dmitry Grinev
Location: St.Petersburg
Contact:

Re: Guest file system indexing failed in network mode

Post by DGrinev » Sep 06, 2017 1:34 pm

Hi,

Please contact the support team and let them review the logs to find out the real cause of the issue.
Also, when you are posting a technical issue you should share a case id number or your message will be deleted in 24 hours by moderators according to the rules of the forum. Thanks!

KeiichiKun
Enthusiast
Posts: 54
Liked: 9 times
Joined: Jul 21, 2016 3:59 pm
Contact:

Re: Guest file system indexing failed in network mode

Post by KeiichiKun » Sep 06, 2017 2:35 pm

Sorry, #02303497

albertwt
Expert
Posts: 626
Liked: 20 times
Joined: Nov 05, 2009 12:24 pm
Location: Sydney, NSW
Contact:

Re: [MERGED] Guest file system indexing failed in network mo

Post by albertwt » Sep 22, 2017 1:12 am

KeiichiKun wrote:a backup job of a sql server vm ends with this warning: "Failed to index guest file system. VSSControl: Index failed"
Log has this entry:

Code: Select all

VSSControl: Index failed   at Veeam.Backup.VssProvider.CVssControl.Index(Guid jobId, String[] includeFolders, String[] excludeFolders, String outputDir)
at Veeam.Backup.Core.CViGuestDiskIndexer.Veeam.Backup.Core.IGuestDiskIndexer.Index()
at Veeam.Backup.Core.CViGuestCatIndexer.TryToIndex(Guid jobId, CCatIndex& catIndex, Boolean& isGuestGroupMembersAvailable)
vss::CVeeamIndexingProvider::NetTryCompleteIndex. Failed to complete guest file system indexing in network mode.
All our backup proxies are in automatic mode.
So how did you go with this issue ?
--
/* Veeam software enthusiast user & supporter ! */

KeiichiKun
Enthusiast
Posts: 54
Liked: 9 times
Joined: Jul 21, 2016 3:59 pm
Contact:

Re: Issues with Indexing Backups

Post by KeiichiKun » Sep 25, 2017 7:45 am

Hi,
apologies for late reply.
I've solved disabling indexing because file level restore is available even if file indexing is disabled.
I've tried to move shadow copies from C: to a dedicated volume Z: but I got another error "The shadow copies of volume C: were deleted because the shadow copy storage could not grow in time. Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied."
So I've choose drastic solution.

rdkennedy
Lurker
Posts: 1
Liked: never
Joined: Oct 10, 2017 6:27 pm
Contact:

Re: Issues with Indexing Backups

Post by rdkennedy » Oct 16, 2017 3:01 pm

Hello
Does hotfix 104602 only need to be applied to the Veeam server or does it need to be applied to the proxies as well?

Vitaliy S.
Veeam Software
Posts: 21536
Liked: 1281 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: Issues with Indexing Backups

Post by Vitaliy S. » Oct 16, 2017 8:02 pm 1 person likes this post

Hotifx should be installed on the Veeam backup server. Thanks!

mtaggart
Enthusiast
Posts: 25
Liked: 2 times
Joined: Dec 21, 2012 2:32 pm
Full Name: Mike Taggart
Contact:

Re: Issues with Indexing Backups

Post by mtaggart » Feb 09, 2018 10:08 pm

We have this issue as well and we are on Update 3. We've opened a support case 02596079, but there's not been any resolution to it yet.

Help, anyone!?

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 23 guests