Issues with Indexing Backups

Availability for the Always-On Enterprise

Issues with Indexing Backups

Veeam Logoby xeonjackson » Mon May 01, 2017 1:36 pm

Hi all,

I opened a ticket with Veeam support, but I thought perhaps you all may also be able to offer assistance.

Here's the situation:

I am receiving this error: Failed to Index guest file system. VSSControl: Index Failed on two jobs backing up the same VM. I have five jobs that backup the different virtual drives/vmdk's of this VM. Three complete successfully with the indexing while two fail. In the each of the five backup jobs, only the child vmdks(drives) are being backed up, not the "C" "Windows/Administrative" drive. I could understand that the job was failing if the Windows vmdk wasn't present, but three of the five jobs backup and index their virtual drive vmdk without issue. Please let me know what is going on so I can rectify it.

Case # 02135002

Please help if you can.
xeonjackson
Novice
 
Posts: 4
Liked: never
Joined: Fri Dec 02, 2016 4:47 pm

Re: Issues with Indexing Backups

Veeam Logoby foggy » Thu May 04, 2017 12:07 pm

System disk exclusion shouldn't affect guest file system indexing. Please continue working with your support engineer.
foggy
Veeam Software
 
Posts: 14560
Liked: 1060 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Issues with Indexing Backups

Veeam Logoby adruet » Fri May 19, 2017 7:22 am

@xeonjackson are you running veeam backup and replication 9.5 update 2 ?

I just upgraded from 9.5 update 1 to update 2 and I have seen 23 warnings exactly like yours last night.

I am digging in the logs right now and will open a support case if necessary.
adruet
Influencer
 
Posts: 22
Liked: 6 times
Joined: Wed Oct 31, 2012 2:28 pm
Full Name: Alex

Re: Issues with Indexing Backups

Veeam Logoby foggy » Fri May 19, 2017 12:57 pm

Hi Alex, I've checked the OP's case and it was closed after no response from the customer, so it does make sense to open your own case for investigation. Thanks.
foggy
Veeam Software
 
Posts: 14560
Liked: 1060 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Issues with Indexing Backups

Veeam Logoby adruet » Fri May 19, 2017 1:43 pm 1 person likes this post

Hi Alexander, after some investigation I did open a case: 02161438.
Thanks for your feedback.
adruet
Influencer
 
Posts: 22
Liked: 6 times
Joined: Wed Oct 31, 2012 2:28 pm
Full Name: Alex

Re: Issues with Indexing Backups

Veeam Logoby andriktr » Mon May 22, 2017 4:43 pm

Looks that we also have same issue after update 2 install. Many VM's have same warning: "Failed to index guest file system. VSSControl: Index failed"
Any news regarding this issue?
andriktr
Enthusiast
 
Posts: 35
Liked: 1 time
Joined: Mon Mar 02, 2015 11:53 am
Full Name: Andrej

Re: Issues with Indexing Backups

Veeam Logoby davecla » Mon May 22, 2017 9:53 pm

Same here after update 2 applied
Just one server out of many though.
davecla
Influencer
 
Posts: 19
Liked: 1 time
Joined: Wed Feb 03, 2016 9:40 pm
Full Name: Dave Clarke

Re: Issues with Indexing Backups

Veeam Logoby DaveWatkins » Tue May 23, 2017 1:14 am

Just another me too here.

Installed Update 2 yesterday and overnight got 8 or so failed index warnings on jobs this morning. That's still a small fraction of our total VM's but markedly more warnings than I have ever seen otherwise.

Oddly, in our case it seems to mostly affect RDP servers
DaveWatkins
Expert
 
Posts: 248
Liked: 61 times
Joined: Sun Dec 13, 2015 11:33 pm

Re: Issues with Indexing Backups

Veeam Logoby adruet » Tue May 23, 2017 6:34 am

Veeam Support told me this is a new behavior because they now have a more robust logging engine which allows them to log what they didn't see before.

From a user side, the backups with the warning are ok, and we are able to restore.

I am still working with support to give them logs to work on the issue.

We do not have Remote Desktop hosts with the issue, but many different machines.
adruet
Influencer
 
Posts: 22
Liked: 6 times
Joined: Wed Oct 31, 2012 2:28 pm
Full Name: Alex

Re: Issues with Indexing Backups

Veeam Logoby Nicodonald » Tue May 23, 2017 7:05 am

Same here after update 2
Nicodonald
Novice
 
Posts: 3
Liked: never
Joined: Thu May 12, 2016 4:12 pm

Re: Issues with Indexing Backups

Veeam Logoby foggy » Tue May 23, 2017 12:05 pm

For everybody who is seeing this behavior it is recommended to contact support, unless done already.
foggy
Veeam Software
 
Posts: 14560
Liked: 1060 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Issues with Indexing Backups

Veeam Logoby davecla » Wed May 24, 2017 10:41 pm 1 person likes this post

I've logged a support job too #02167192 - still just the one server.
Even if it's just informational, unless all my job reports are green then my day starts badly.
davecla
Influencer
 
Posts: 19
Liked: 1 time
Joined: Wed Feb 03, 2016 9:40 pm
Full Name: Dave Clarke

Re: Issues with Indexing Backups

Veeam Logoby JaySt » Fri May 26, 2017 7:57 pm

same here. However, not consistently on the same VM each job run.
Veeam Certified Engineer
JaySt
Service Provider
 
Posts: 47
Liked: 3 times
Joined: Tue Jun 09, 2015 7:08 pm
Full Name: JaySt

Re: Issues with Indexing Backups

Veeam Logoby davecla » Mon May 29, 2017 6:15 am

Anyone had a decent answer from support yet?
I've got another server now with the same error message and the one that was failing before now completes ok. No changes to the environment.

Support have indicated it's a permission problem with the account being used to run the indexer. I'm very skeptical......
davecla
Influencer
 
Posts: 19
Liked: 1 time
Joined: Wed Feb 03, 2016 9:40 pm
Full Name: Dave Clarke

Re: Issues with Indexing Backups

Veeam Logoby Nicodonald » Mon May 29, 2017 11:22 am

Same here, a server didn't had the warning since update and now it fail to index, the reverse is true too, a server had the warning since update and now it's ok.
Nicodonald
Novice
 
Posts: 3
Liked: never
Joined: Thu May 12, 2016 4:12 pm

Next

Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Google Feedfetcher, Yahoo [Bot] and 19 guests