Lost SQL database after 9.5 upgrade

Availability for the Always-On Enterprise

Lost SQL database after 9.5 upgrade

Veeam Logoby enricop » Sun Nov 27, 2016 12:54 am

I've just upgraded from Veeam B&R 9.0 upd 2 to 9.5 and I've messed up the database! :(

During upgrade I've been asked what SQL Server instance to use and confirmed the one automatically selected (named VEEAM) but I got an error because it was a SQL Server version 2005 and at least 2008 was required.

SO I clicked on the drop down list and saw an instance named VEEAMSQL2012 (I guess was installed by Veeam, surely I ddn't installed it), so I chose it.

Upgrade (apparently) went well, unfortunately after reboot Veeam is not "empty", none of my jobs, tapes, surebackups, virtual labs exists!

What is the best way to recover all Veeam "status"?
What would have been the right upgrade method?

BTW: I do have the automatic/defualt backup performed by "Backup Configuration Job" from this morning, would it be enough to restore it?

Thank you in advance for any hint.

Enrico
enricop
Lurker
 
Posts: 2
Liked: 1 time
Joined: Sat Aug 06, 2011 2:02 pm

Re: Lost SQL database after 9.5 upgrade

Veeam Logoby Vitaliy S. » Sun Nov 27, 2016 6:56 pm

HI Enrico,

Yes, you can either install a new Veeam B&R server and then import your previous configuration, or do in-place upgrade for the existing SQL Server 2005, and then point your Veeam backup server to that upgraded database. For more detailed instructions and guidance, feel free to contact our technical support team.

Thanks!
Vitaliy S.
Veeam Software
 
Posts: 19966
Liked: 1145 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Lost SQL database after 9.5 upgrade

Veeam Logoby Gostev » Sun Nov 27, 2016 7:24 pm

And the good news is that you did not actually lose anything yet.

enricop wrote:confirmed the one automatically selected (named VEEAM) but I got an error because it was a SQL Server version 2005 and at least 2008 was required.

This means all your configuration data sits in SQL 2005 database.

enricop wrote:SO I clicked on the drop down list and saw an instance named VEEAMSQL2012 (I guess was installed by Veeam, surely I ddn't installed it), so I chose it.
Upgrade (apparently) went well, unfortunately after reboot Veeam is not "empty", none of my jobs, tapes, surebackups, virtual labs exists!

You picked a database that was empty, so unsurprisingly it remained empty after upgrade ;) the only remaining step now is to import configuration backup created before the upgrade.
Gostev
Veeam Software
 
Posts: 21621
Liked: 2411 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Lost SQL database after 9.5 upgrade

Veeam Logoby enricop » Sun Nov 27, 2016 7:28 pm 1 person likes this post

Thank you Vitaliy and Gostev for the reply, I already restored the full config&database from the last config backup (was up to date from the morning) and everything is back & fine.

Enrico
enricop
Lurker
 
Posts: 2
Liked: 1 time
Joined: Sat Aug 06, 2011 2:02 pm


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: FrancWest and 1 guest