"Microsoft Exchange System Objects" Missing from AD Explorer

Availability for the Always-On Enterprise

"Microsoft Exchange System Objects" Missing from AD Explorer

Veeam Logoby mkaec » Mon Feb 15, 2016 5:37 pm

In researching some Microsoft Exchange events, the recommendation came up to delete some items out of the "Microsoft Exchange System Objects" OU in the AD.

Before moving forward, I loaded up Veeam's AD Explorer to verify I could restore the deleted items in case something were to go wrong. But, I've been unable to find the OU in Veeam Explorer for Microsoft Active Directory. I tried clicking on the "Advanced Features" option, as this is what makes the OU visible in "AD Users & Computers", but that did not reveal it. I also noticed that "NTDS Quotas" and "TPM Devices" appear to also be missing from Veeam Explorer for Microsoft Active Directory.

Now, we are not backing up the Exchange server with Veeam as it is still a physical server. So, I was unable to check in the Exchange Explorer to see if the items are visible there.

We do have a legacy backup application still running backups of the AD (it is also not backing up the Exchange server) and I do see the missing OUs available for GRT restore. So, that'll provide the comfort I'm looking for. But, I would be interested in knowing if it is possible (and how) to restore "Microsoft Exchange System Objects" AD items with Veeam.
mkaec
Expert
 
Posts: 179
Liked: 48 times
Joined: Thu Jul 16, 2015 1:31 pm
Full Name: Marc K

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby Gostev » Mon Feb 15, 2016 7:43 pm

You can make these objects appear with a simple configuration XML edit. Right now, we are purposely skipping these because we are not sure of use cases behind restoring objects from those containers. We always want to test each use case in the lab before making it available in the product. Can you share your use case please?
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby mkaec » Mon Feb 15, 2016 8:46 pm

The server is regularly logging "MSExchangeIS Mailbox Store" 7043 events [The mailbox GUID of an external system mailbox ('Mailbox - SystemMailboxXYZ') does not match the information in the Active Directory for the mailbox]. The cause appears to be excess entries in "Microsoft Exchange System Objects" and the recommendation is to delete them. However, if I am wrong or if I delete the wrong thing, I'd like to be able to restore to reverse the deletions.

https://social.technet.microsoft.com/Fo ... em-mailbox
https://social.technet.microsoft.com/Fo ... change2010
http://enterpriseit.co/microsoft-exchan ... y-mailbox/

As for "NTDS Quotas" and "TPM Devices", I don't have a specific use case. I just noticed they were missing. However, the general case of an admin having to restore because something was deleted that shouldn't have been probably applies to all 3. Some admins have a habit of getting themselves into trouble. However, I understand your caution. I'm glad that access to those items is available via an XML edit.

So, if you want to test my use case, delete some of your "SystemMailboxXYZ" entries, wait for the Exchange server to start getting upset (reboot it if you wnt to try to accelerate things) and then try to restore them back.
mkaec
Expert
 
Posts: 179
Liked: 48 times
Joined: Thu Jul 16, 2015 1:31 pm
Full Name: Marc K

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby Gostev » Mon Feb 15, 2016 9:10 pm

OK, thanks for sharing this. From my discussion with the devs I already know that restoring SystemMailbox entries specifically will not work (these will require additional code to be restored correctly). It's doable but we don't have this feature today.
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby mkaec » Mon Feb 15, 2016 9:24 pm

OK. Well, I hope that I won't be writing back here to report on how it works with the other application. :)
mkaec
Expert
 
Posts: 179
Liked: 48 times
Joined: Thu Jul 16, 2015 1:31 pm
Full Name: Marc K

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby Didi7 » Tue Feb 16, 2016 10:06 am

Should I be worried about the fact, that some parts of Exchange Items cannot be restored with the Veeam Explorer for MS Exchange?
Using Veeam Backup & Replication 9.5 Update 2 on every backup server here!
Didi7
Expert
 
Posts: 228
Liked: 15 times
Joined: Fri Oct 17, 2014 8:09 am

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby Gostev » Tue Feb 16, 2016 3:37 pm

Definitely not, because this has never been brought up in over 2 years of Veeam Explorer for Microsoft Exchange existence :D
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby mdo » Fri Nov 04, 2016 7:40 am

Hi guys,

well we've got a problem with our Exchange and I just need to compare these objects.
What can I do to show the MESO in AD explorer?

Regardings.
mdo
Lurker
 
Posts: 1
Liked: never
Joined: Fri Nov 04, 2016 7:36 am
Full Name: Moritz Dorn

Re: "Microsoft Exchange System Objects" Missing from AD Expl

Veeam Logoby foggy » Mon Nov 07, 2016 2:53 pm

Moritz, please contact technical support for instructions.
foggy
Veeam Software
 
Posts: 14742
Liked: 1079 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot] and 19 guests