Preferred Network Issue

Availability for the Always-On Enterprise

Preferred Network Issue

Veeam Logoby pterpumpkin » Fri Dec 02, 2016 2:22 am

Hi everyone!!!!!!!!

We have an issue where we have configured preferred networks between two reps, however our Veeam reps don't attempt to connect to the preferred network on the source.

Layout:
- Two reps: REP09, REP10
- Each rep is at a different geographical location connection via WAN.
- Each rep is dual homed with vNIC's.
- Each rep's vNIC is on a different subnet
- Each rep's vNIC is on a different VLAN
- Static routes have been added
- vNIC2 has direct communication between the two rep's and cannot talk to any other server e.g. cannot talk to Veeam management servers.
- The NIC2 subnets have been configured as preferred networks in Veeam.

Issue:
Code: Select all
When the  backup copy job runs, the source (REP09) does not attempt to talk to the destination (REP10) on vNIC2 IP address. It fails, then falls back to the vNIC1 IP and makes communication. Log excerpt below:
[02.12.2016 15:03:17] <14> Info     Channel encryption check: 172.23.54.10 to 10.10.129.138
[02.12.2016 15:03:17] <14> Info     Channel encryption check: 10.10.66.139 to 10.10.129.138
[02.12.2016 15:03:17] <14> Info     Number of additional connections: [5]
[02.12.2016 15:03:17] <14> Info             [AP] (3022) connecting to '10.10.129.138:2500;oncveeamrep10:2500', user '{394972cd-d0d1-460e-babd-bd7ded54817a}'
[02.12.2016 15:03:21] <28> Info                   [AP] (3022) output: >
[02.12.2016 15:03:21] <14> Info             [AP] (3022) command: 'setTrafficCompressionLevel\n-1\n'
[02.12.2016 15:03:21] <28> Info                   [AP] (3022) output: >
[02.12.2016 15:03:21] <14> Info             [AP] (f7d0) command: 'setTrafficCompressionLevel\n-1\n'
[02.12.2016 15:03:21] <19> Info                   [AP] (f7d0) output: >


Why would Veeam not attempt to communicate to the destination rep on the defined preferred network?


I hope that makes sense!

Let me know if you need any further info.


Thanks!
Pter.
pterpumpkin
Influencer
 
Posts: 11
Liked: 1 time
Joined: Tue Jun 14, 2016 9:36 am
Full Name: Pter Pumpkin

Re: Preferred Network Issue

Veeam Logoby felixcountermanche » Sun Dec 04, 2016 9:17 pm

Hi Mr Pumpkin

I would suggest trying to modify hosts file on the source veeam rep, to ensure name resolution resolves the IP address on the preferred backup network of the destination rep.

Are you able to please try and let us know?

Many thanks
Felix C. Countermanche
felixcountermanche
Lurker
 
Posts: 1
Liked: never
Joined: Sun Dec 04, 2016 9:14 pm
Full Name: Felix C Countermanche

Re: Preferred Network Issue

Veeam Logoby foggy » Mon Dec 05, 2016 2:17 pm

What type of repositories are those? Windows servers?
foggy
Veeam Software
 
Posts: 14728
Liked: 1077 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Preferred Network Issue

Veeam Logoby pterpumpkin » Mon Dec 05, 2016 8:21 pm

Hi Felix!

I did try changing the host file. No luck ;(


Hi Foggy!

They're Windows servers.
pterpumpkin
Influencer
 
Posts: 11
Liked: 1 time
Joined: Tue Jun 14, 2016 9:36 am
Full Name: Pter Pumpkin

Re: Preferred Network Issue

Veeam Logoby foggy » Tue Dec 06, 2016 11:30 am

And this is a direct backup copy, not WAN accelerated, right? I suggest contacting support to verify whether you're configuring preferred network correctly.
foggy
Veeam Software
 
Posts: 14728
Liked: 1077 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot] and 32 guests