Comprehensive data protection for all workloads
Post Reply
lewisdrummond
Enthusiast
Posts: 36
Liked: never
Joined: Apr 06, 2010 8:04 pm
Contact:

SAN Backup Difficulties

Post by lewisdrummond » Apr 07, 2010 4:02 pm

Using Veeam Backup 4.1, Server 2008 R2 x64, EqualLogic SAN, Virtual Center v4, I am having difficulties with SAN-only backups:

Code: Select all

[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.030 01296 verbose 'App'] Trying to open new LUN LVID:4aca862d-f8d95a6e-2e70-00219b929086/4aca862c-c0318f8c-8092-00219b929086/1.\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: \n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.034 01296 trivia 'App'] Attempting to open LVID:4aca862d-f8d95a6e-2e70-00219b929086/4aca862c-c0318f8c-8092-00219b929086/1.\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.034 01296 error 'App'] No path to device LVID:4aca862d-f8d95a6e-2e70-00219b929086/4aca862c-c0318f8c-8092-00219b929086/1 found.\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.035 01296 error 'App'] Failed to open new LUN LVID:4aca862d-f8d95a6e-2e70-00219b929086/4aca862c-c0318f8c-8092-00219b929086/1.\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: \n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.036 01296 verbose 'App'] Cannot access LUN LVID:4aca862d-f8d95a6e-2e70-00219b929086/4aca862c-c0318f8c-8092-00219b929086/1, cannot open disk snapshot-692[TESTVM] TESTVM/TESTVM.vmdk. Giving up.\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.037 01296 error 'BlockList'] \n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.037 01296 info 'BlockList'] Closing connection 192.168.3.30:MYDOMAIN\administrator\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: [2010-04-07 11:45:22.037 01296 trivia 'SOAP'] Sending soap request to [TCP:192.168.3.30:443]: logout\n
[07.04.2010 11:45:22] <12> Info    (Client) Service output: SAN: Cannot access a SAN/iSCSI LUN backing this virtual disk. (Hint: If you are using vcbMounter you can use the option "-m nbd" to switch to network based disk access if this is what you want.) If you were attempting file-level access, stop the vmount Service by typing "net stop vmount2" on a command prompt to force vmount to re-scan for SAN LUNs and re-try the command.\n
Using VCBMounter from the command-line, I can backup the virtual machine over the SAN. I have disabled automount in diskpart, and can see the necessary LUN in Windows Disk Management. Any advice?

Let me know if you need me to clarify anything.

Regards,

Lewis

Vitaliy S.
Product Manager
Posts: 22697
Liked: 1498 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: SAN Backup Difficulties

Post by Vitaliy S. » Apr 07, 2010 4:20 pm

Hello Lewis,

If you're able to use VCBmounter (SAN mode) without any issues, vStorage API mode should work for you also. Could you please clarify if you've been using the same account credentials to launch VCBmounter and for Veeam Backup service (logon as account). If they are the same, please open support ticket with us, so our technical team could have a look at your issue more closely.

Thank you!

lewisdrummond
Enthusiast
Posts: 36
Liked: never
Joined: Apr 06, 2010 8:04 pm
Contact:

Re: SAN Backup Difficulties

Post by lewisdrummond » Apr 07, 2010 4:40 pm

Thank you for your quick response. With the VCBmounter command, I was using administrator to connect to Virtual Center. I ran the command again as my Veeam service account user, veeam, and the command failed. I then added 'veeam' to the local Administrators account, and the command worked.

Thinking that this would then fix my problem, I ran the original job again, but it still fails with the same error:

Code: Select all

Backing up file "[TESTVM] TESTVM/TESTVM-flat.vmdk"
BackupDisk failed
Client error: Failed to open VDDK disk [[TESTVM] TESTVM/TESTVM.vmdk] ( is read-only mode - [true] )
Failed to open VMDK.
Logon attempt with parameters [VC/ESX: [192.168.3.30];Port: 443;Login: [MYDOMAIN\administrator];VMX Spec: [moref=vm-101];Snapshot mor: [snapshot-694];Transports: [san]] failed because of the following errors:

Server error: End of file
Any further advice? Perhaps reboot the VC/Veeam server since the permission changes?

Regards,

Lewis

lewisdrummond
Enthusiast
Posts: 36
Liked: never
Joined: Apr 06, 2010 8:04 pm
Contact:

Re: SAN Backup Difficulties

Post by lewisdrummond » Apr 07, 2010 5:09 pm

Rebooting the server post-permission change fixed the issue. Thank you!

Lewis

Vitaliy S.
Product Manager
Posts: 22697
Liked: 1498 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: SAN Backup Difficulties

Post by Vitaliy S. » Apr 07, 2010 6:28 pm

Lewis,

Thank you for updating the thread, glad that you're up and running now!

Post Reply

Who is online

Users browsing this forum: Majestic-12 [Bot] and 29 guests