Availability for the Always-On Enterprise
Post Reply
kyoon@casusa.com
Novice
Posts: 9
Liked: never
Joined: Dec 29, 2014 7:01 pm
Full Name: Ken Yoon
Contact:

SQL Server transaction log backup failing

Post by kyoon@casusa.com » Apr 16, 2015 4:47 pm

Hello,

We had a job consist of 8 SQL VMs also backup SQL logs.

I delete one of them VM from the job and created dedicated backup job for the VM to use it with Veeam Cloud Connector.

Since then, Regular backup job is running fine however, SQL Server transaction log backup is keep failing and I get following log stating the old backup job is still responsible for the log backup.

"Failed to prepare guest for SQL transaction log backup Details: Job Backup Job 3 - SQL VMs is responsible for SQL transaction logs backup"

I double checked the VM is not part of old backup job anymore. What am I missing here? Your input is much appreciated. Thanks.

VEEAM CASE #: 00880477

Gostev
Veeam Software
Posts: 22770
Liked: 2798 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: SQL Server transaction log backup failing

Post by Gostev » Apr 16, 2015 7:23 pm

Hi, Ken. As per Release Notes, SQL transaction log backup to a cloud repository is not supported. Thanks!

foggy
Veeam Software
Posts: 16662
Liked: 1338 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: SQL Server transaction log backup failing

Post by foggy » Apr 20, 2015 4:44 pm

However in this specific case, the message is caused by the fact that this VM was previously backed up within another job. By default, the new job will not perform logs backup during 7 days after last successful logs backup performed by another (existing) job.

Gostev
Veeam Software
Posts: 22770
Liked: 2798 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: SQL Server transaction log backup failing

Post by Gostev » Apr 20, 2015 11:32 pm

Right - I missed that part of the issue, sorry.

Clemens Bertram
Influencer
Posts: 12
Liked: never
Joined: Jun 28, 2012 1:20 pm
Contact:

Re: SQL Server transaction log backup failing

Post by Clemens Bertram » Mar 06, 2017 10:48 am

Hello Gostev,

please have a look at Case 02086028

We are facing the same Issue.

Basically that is a "No Go" for Veeam in our Environment because we are running Enterprise Applications on MS-SQL in our Environment.

Mike Resseler
Veeam Software
Posts: 4641
Liked: 497 times
Joined: Feb 08, 2013 3:08 pm
Full Name: Mike Resseler
Location: Belgium
Contact:

Re: SQL Server transaction log backup failing

Post by Mike Resseler » Mar 07, 2017 8:16 am

Hi Clemens,

My German is a bit rusty but from what I can read in the support case it is solved now?

Let me know
Mike

Clemens Bertram
Influencer
Posts: 12
Liked: never
Joined: Jun 28, 2012 1:20 pm
Contact:

Re: SQL Server transaction log backup failing

Post by Clemens Bertram » Mar 07, 2017 11:56 am

Hi Mike,

the case is closed because the Support told us that this behavior is by Design.
The only thing we can do is set the value from 7 Days to 1 Day.

Kind regards
Clemens

foggy
Veeam Software
Posts: 16662
Liked: 1338 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: SQL Server transaction log backup failing

Post by foggy » Mar 07, 2017 1:03 pm

Yes, the behavior is currently expected and designed to protect from thoughtless decisions. You can set the registry value to 0 to disable it though.

Clemens Bertram
Influencer
Posts: 12
Liked: never
Joined: Jun 28, 2012 1:20 pm
Contact:

Re: SQL Server transaction log backup failing

Post by Clemens Bertram » Mar 07, 2017 1:51 pm

Hi

sorry but the value 0 is not possible.
We discussed that with the Support.

Value "0" would fix our Problem.

foggy
Veeam Software
Posts: 16662
Liked: 1338 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: SQL Server transaction log backup failing

Post by foggy » Mar 13, 2017 11:47 am 1 person likes this post

Hi Clemens, we've checked internally, the registry value set to 0 should work. Make sure you're using the correct value and specify it in the backup server and please refer to this KB article for details.

Post Reply

Who is online

Users browsing this forum: Bing [Bot], david.tosoff, Google [Bot] and 18 guests