Comprehensive data protection for all workloads
Post Reply
goalie
Novice
Posts: 5
Liked: never
Joined: Jun 24, 2010 10:46 pm
Contact:

SSH Connection Settings

Post by goalie »

Folks,

I am using Veeam FastSCP Backup 4.1.1 to do some replication of VM's from a Vsphere 4 standard box to another Vsphere 4 standard box. The replication works fine but I get this message in the details box:

This VM has been processed using non-optimal data transfer engine. We recommend using service console agent mode for VMs replicated to regular ESX servers. To enable service console agent mode, provide SSH connection settings for target ESX server. To stop receiving this message, change target ESX server’s data transfer mode to "Force agentless".

I have the SSH coonection ticked in the ESX server along root account and password. Do i need to open up the SSH port on the ESX server I am also running VM version 7 on the servers I am replicating.

Alexey D.

Re: SSH Connection Settings

Post by Alexey D. »

Hello,

Please check whether you can successfully connect to this ESX host using ssh tool such as Putty.

Moreover, be sure that you have ssh for root enabled on your ESX.
Here's an article telling how to do this: http://www.vladan.fr/how-to-activate-ro ... -in-esx-4/

goalie
Novice
Posts: 5
Liked: never
Joined: Jun 24, 2010 10:46 pm
Contact:

Re: SSH Connection Settings

Post by goalie »

Hello Alexey

No I can't connect via the root login using putty to ssh. Access is denied. I have setup a local account on the box that I will use for the ssh but I can't set the password on it. I get paswd: authetication token minipulation error? I created the account when logged in as root. I obviously don't know a whole lot about linux by the looks of things...

goalie
Novice
Posts: 5
Liked: never
Joined: Jun 24, 2010 10:46 pm
Contact:

Re: SSH Connection Settings

Post by goalie »

Should add I do su - veeam, then passwd, it asks me for current password which I didn't set, i try to add one then the error comes up

Vitaliy S.
Product Manager
Posts: 24249
Liked: 1860 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: SSH Connection Settings

Post by Vitaliy S. »

You need to either enable root access on your ESX host by following the instructions in Alexey's post above, or you may use "Elevate account to root" to use optimal data transfer engine.

P.S. I've searched for your error message on VMware's KB...is that what you're trying to do? Please have a look:
http://kb.vmware.com/kb/1012033

goalie
Novice
Posts: 5
Liked: never
Joined: Jun 24, 2010 10:46 pm
Contact:

Re: SSH Connection Settings

Post by goalie »

Yes I am trying to setup an account which I can elevate to root to use optimal data transfer engine and I cannot set the password, error is the one in the knowledgebase you specify. I don't want to enable root access on the ESX for ssh for security reasons.

Post Reply

Who is online

Users browsing this forum: Bing [Bot], rpeterson and 63 guests