Comprehensive data protection for all workloads
Post Reply
jbdk
Lurker
Posts: 2
Liked: never
Joined: Nov 18, 2020 2:22 pm
Full Name: Jeppe Bøjlesen
Contact:

String was not recognized as valid DateTime

Post by jbdk »

Hello good people,

First i apologise in advance, I'm very new to using veeam, so I'm not completely familiar with it. I have opened a support case with number: 04502355

So i recently setup a new Veeam backup and replication 10 Community Edition on Windows Server 2019 with Hyper-V and 2 virtual machines. I have connected veeam to the Virtual Infrastructure, and setup multiple backup jobs, that works perfect.

The only problem i have is when the backup ends and should be sending an e-mail report, I get an Error saying "Sending email report Details: String was not recognized as a valid DateTime."

I have tried change time zones and time formats, but without success.

Any help is greatly appreciated

Gostev
SVP, Product Management
Posts: 29899
Liked: 5842 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: String was not recognized as valid DateTime

Post by Gostev »

Judging in your name, this might be a bug with your system locale... so, try changing the Regional Format in Windows settings to English. Thanks!

jbdk
Lurker
Posts: 2
Liked: never
Joined: Nov 18, 2020 2:22 pm
Full Name: Jeppe Bøjlesen
Contact:

Re: String was not recognized as valid DateTime

Post by jbdk »

You are correct, i'm located in Denmark.
I have tried changing the Regional Formet to: "English(Denmark)", "Danish(Denmark)", "English(World)", "English(United Kingdom)" and "Recommended [English (United States)]", all with the same result.

I can also only access the "General Options menu", if the regional format is set to "English(Denmark)" else i get the following error:
"Error while parsing node [Notifytime] in [CMailOptions] String was not recognized as a vaild datetime"

Gostev
SVP, Product Management
Posts: 29899
Liked: 5842 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: String was not recognized as valid DateTime

Post by Gostev »

Perhaps something was set into the configuration at the installation time using the system locale used then, so changing the locale now makes no difference. You will need to work with support to determine and fix the issue with the configuration edit.

Anyway, all these are just my guesses based on errors pointing to some date/time value issue. Support folks should be able to determine the real reason through debug logs review.

Thanks!

fabio75
Lurker
Posts: 2
Liked: never
Joined: Feb 08, 2021 1:51 pm
Contact:

Re: String was not recognized as valid DateTime

Post by fabio75 »

same problem here. VEEAM 10.0.1.4854.
is it possible to change consolle language from Italian to English?

foggy
Veeam Software
Posts: 20771
Liked: 2030 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: String was not recognized as valid DateTime

Post by foggy »

I believe it uses the system locale language for some system-generated messages, so changing the locale should help. As for the DateTime issue, please contact technical support for assistance, as mentioned above. Thanks!

BjornStandal
Lurker
Posts: 1
Liked: 1 time
Joined: Jan 20, 2022 10:14 am
Full Name: Bjorn Standal
Contact:

Re: String was not recognized as valid DateTime

Post by BjornStandal » 1 person likes this post

I have encountered the same error: Test e-mail goes through just fine. Notifications e-mail does not.
Logs shows: String was not recognized as a valid DateTime. (System.FormatException)

After tips from Gostev here, I started digging in the locale settings on the server (Windows Server 2016).
Found the culprit in Control Panel->Clock and Region->Region->button "Additional Settings" and tab "Time".
Ensure that the time divider (between hours, minutes and seconds) is a colon (:) and not a period (.)
I believe this is from choosing Norwegian Format directly under "Region".

Hope this can help someone else.

AlexLeadingEdge
Expert
Posts: 414
Liked: 53 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: String was not recognized as valid DateTime

Post by AlexLeadingEdge »

I'm having the same problem. We had a backup server that was Server 2012, which stopped doing Windows Updates and failed to get the new security patch (see KB5015527 for more details) which allowed non-Domain servers to communicate with Domain servers, so we decided to build a new backup server which is Windows 10 Pro. I installed VeeamB&R 10a and imported the settings configuration file, then upgraded the VeeamB&R to 11a. Everything seemed to be fine but today I'm seeing:
Error: The string was not recognized as a valid DateTime. There is an unknown word starting at index 19.
Thinking that perhaps the update of the components on the servers hadn't upgraded, I tried to go into General Options, and now I'm seeing:
Error while parsing node [NotifyTime] in [CMailOptions]
The string was not recognised as a valid DateTime. There is an unknown word starting at index 19.
I have just checked the language and time settings, but they are set to English (United States) and our local time here in New Zealand. We don't use fullstops in our time settings.

AlexLeadingEdge
Expert
Posts: 414
Liked: 53 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: String was not recognized as valid DateTime

Post by AlexLeadingEdge »

Looking in the Svc.VeeamBackup.log I can see this:
[23.06.2022 11:19:06] <199> Error [ArchiveBackupEmailNotificationManager] Error in notification loop
[23.06.2022 11:19:06] <199> Error Error while parsing node [NotifyTime] in [CMailOptions] (Veeam.Backup.Common.CRegeneratedTraceException)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Common.CExceptionUtil.RegenTraceExc(Exception originalExc, String formatString, Object[] args)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Common.CXmlHelper.GetChildNodeText[T](XmlNode parentNode, String childNodeName, T defaultValue)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Model.CMailOptions.Deserialize(XmlNode rootNode)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Core.SBackupOptions.GetMailOptions()
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Reporting.DbLayer.CPeriodicNotificationManager`1.Dispatch(DateTime now)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Reporting.DbLayer.CPeriodicNotificationManager`1.DispatchLoopProc()
[23.06.2022 11:19:06] <199> Error The string was not recognized as a valid DateTime. There is an unknown word starting at index 19. (System.FormatException)
[23.06.2022 11:19:06] <199> Error at System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Common.CXmlHelper.ConvertFromString[T](String strValue)
[23.06.2022 11:19:06] <199> Error at Veeam.Backup.Common.CXmlHelper.GetChildNodeText[T](XmlNode parentNode, String childNodeName, T defaultValue)

AlexLeadingEdge
Expert
Posts: 414
Liked: 53 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: String was not recognized as valid DateTime

Post by AlexLeadingEdge »

Case # 05499112

I can confirm that a restart of the services seems to work temporarily, but after an hour the backup copies have stopped working again.

AlexLeadingEdge
Expert
Posts: 414
Liked: 53 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: String was not recognized as valid DateTime

Post by AlexLeadingEdge »

Interestingly, the backups seem to be writing the correct sized full backup and incremental backups. Some sort of reporting error?

david.domask
Veeam Software
Posts: 393
Liked: 111 times
Joined: Jun 28, 2016 12:12 pm
Contact:

Re: String was not recognized as valid DateTime

Post by david.domask »

Hi @AlexLeadingEdge, indeed, this is just about the mail notifications, so any backups being written are just fine, it's just some invalid data got into the database it seems.

The Engineer should have a good update for you soon, so stay tuned ;)
David Domask | Director: Customer Care | Veeam Technical Support

AlexLeadingEdge
Expert
Posts: 414
Liked: 53 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: String was not recognized as valid DateTime

Post by AlexLeadingEdge »

Thanks David, I look forward to a resolution.

AlexLeadingEdge
Expert
Posts: 414
Liked: 53 times
Joined: Dec 14, 2015 9:42 pm
Contact:

Re: String was not recognized as valid DateTime

Post by AlexLeadingEdge »

Veeam Technician wrote:In order to resolve the issue, we need to edit the Veeam DB, replacing the "." with ":" in node NotifyTime of [dbo].[Options].email_notification.

Please perform the below steps:

1. Create the backup of Veeam DB (https://www.veeam.com/kb1471)
2. Run the below SQL query: (using SQL Management Studio)

update Options set value.modify('replace value of (/CMailOptions/NotifyTime/text())[1] with ("01/01/2019 22:00:00")') where name = 'email_notification'
That seems to have fixed the issue. The backup copies are now running correctly, and the General Options menu item is now able to be selected and opened.

I note that one thing the technician should have said is that in SQL Server Management Studio the query has to be run from the VeeamBackup SQL database (SERVERNAME\VEEAMSQL2016>Databases>VeeamBackup), not at the stop level as it errors with 'Options' not found.

david.domask
Veeam Software
Posts: 393
Liked: 111 times
Joined: Jun 28, 2016 12:12 pm
Contact:

Re: String was not recognized as valid DateTime

Post by david.domask » 1 person likes this post

Glad it's resolved! And fair enough, though the use of that script is a bit curious, as it's not quite what we discussed internally ;) (original script had

use [VeeamBackup];

as the first line and just replace the value entry for the relevant one...the above code is fine and does the same thing but I personally just don't like mucking about with the XML parsing in SQL as it's really ugly)

Anyways, glad it's solved. For anyone else with this issue, start with just setting the locale first and see if it helps, otherwise something like the above should be perfectly fine.
David Domask | Director: Customer Care | Veeam Technical Support

Post Reply

Who is online

Users browsing this forum: Yahoo [Bot] and 41 guests