Surebackup - SQL tests failing

Availability for the Always-On Enterprise

Surebackup - SQL tests failing

Veeam Logoby Cragdoo » Mon Jan 25, 2016 1:04 pm

SInce upgrading to v9 , my Surebackup job keeps failing on my SQL VM when running the SQL port tests

Code: Select all
SQL_Port, failed - The system cannot find the file specified
Error    Predefined script 2: name Sql Server, error code 2

Is this a known issue ?

If not, I'll raise a support ticket.
Cragdoo
Veeam Vanguard
 
Posts: 408
Liked: 134 times
Joined: Tue Sep 27, 2011 12:17 pm
Location: Scotland
Full Name: Craig Dalrymple

Re: Surebackup - SQL tests failing

Veeam Logoby Gostev » Mon Jan 25, 2016 1:11 pm

Anything that does not come up in the forum search is not a known issue :D
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Surebackup - SQL tests failing

Veeam Logoby foggy » Mon Jan 25, 2016 2:30 pm

Craig, have you checked whether the testing script is actually there?
foggy
Veeam Software
 
Posts: 14742
Liked: 1080 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson

Re: Surebackup - SQL tests failing

Veeam Logoby Cragdoo » Mon Jan 25, 2016 4:26 pm

yeah, the script is there on the VBR server.

I'll do some digging around in the logs, then raise a call with support
Cragdoo
Veeam Vanguard
 
Posts: 408
Liked: 134 times
Joined: Tue Sep 27, 2011 12:17 pm
Location: Scotland
Full Name: Craig Dalrymple

Re: Surebackup - SQL tests failing

Veeam Logoby nefes » Mon Jan 25, 2016 4:38 pm

I suppose, it is credentials problem.
Please set correct account at Credentials tab for your SQL VM.
nefes
Veeam Software
 
Posts: 534
Liked: 125 times
Joined: Mon Dec 10, 2012 8:44 am
Full Name: Nikita Efes

Re: Surebackup - SQL tests failing

Veeam Logoby Cragdoo » Mon Jan 25, 2016 5:07 pm

would incorrect credentials cause a script to crash ??

SQL_Port script, Path: D:\Program Files\Veeam\Backup\Veeam.Backup.ConnectionTester.exe, Args: 192.168.255.58 1433, Result: Crashed
Cragdoo
Veeam Vanguard
 
Posts: 408
Liked: 134 times
Joined: Tue Sep 27, 2011 12:17 pm
Location: Scotland
Full Name: Craig Dalrymple

Re: Surebackup - SQL tests failing

Veeam Logoby nefes » Mon Jan 25, 2016 5:13 pm

No, it should not. Seems that my guess was not right.
It is worth involving support in your case, since crashes cannot be effectively troubleshooted via forums.
nefes
Veeam Software
 
Posts: 534
Liked: 125 times
Joined: Mon Dec 10, 2012 8:44 am
Full Name: Nikita Efes

Re: Surebackup - SQL tests failing

Veeam Logoby Cragdoo » Mon Jan 25, 2016 5:17 pm

Done, Support Case #01677150
Cragdoo
Veeam Vanguard
 
Posts: 408
Liked: 134 times
Joined: Tue Sep 27, 2011 12:17 pm
Location: Scotland
Full Name: Craig Dalrymple

Re: Surebackup - SQL tests failing

Veeam Logoby JaxIsland7575 » Mon Jan 25, 2016 5:39 pm

Craig,
Have you started the SureBackup job then logged into the SQL server and ran the scripts manually from SQL Management? I had a permissions issue and that helped me find it.

Cheers!
VMCE v9
JaxIsland7575
Veeam Vanguard
 
Posts: 364
Liked: 98 times
Joined: Mon Apr 27, 2015 1:59 pm
Location: NY, USA
Full Name: Ryan Jacksland

Re: Surebackup - SQL tests failing

Veeam Logoby fja » Mon Nov 21, 2016 2:37 pm

Was this resolved by support? Having same issue on v.9... Seems to be intermittent. Suspect this could be due to SQL-log file backup running during surebackup job duration...
fja
Influencer
 
Posts: 21
Liked: 1 time
Joined: Tue May 26, 2015 8:58 am

Re: Surebackup - SQL tests failing

Veeam Logoby foggy » Mon Nov 21, 2016 2:42 pm

In the OP's case the issue was caused by the wrong path to the Veeam installation folder containing the script. So looks like you have a different one, I recommend contacting support for a closer look.
foggy
Veeam Software
 
Posts: 14742
Liked: 1080 times
Joined: Mon Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot] and 17 guests