Comprehensive data protection for all workloads
Post Reply
BITuBIT
Influencer
Posts: 15
Liked: never
Joined: Nov 26, 2010 2:46 pm
Full Name: Leonardo
Contact:

System freeze every time during copy at 99%

Post by BITuBIT »

Hi to all,

I have two different ESXI: hostA and hostB. We also have another macchine called VEEAM (ver. 5.0.0.179 a 64bit) that replicate a virtual machine (mail server) from hostA to hostB every hour. All machine are in the same rack connected via switch a 1 Gbps.

We have seen that when the copy up to 99% the system into hostA freeze and we cannot send or receive any mail. In order to complete the copy (from 99% to 100%) are necessary 1 minute or more. Actually the replication job is configured in Processing Mode: Network and keep just 1 restore point. The virtual machine in hostA have 400GB of storage.
Could someone help me to solve this strange issue ?
Thanks in advance,


Leonardo

Gostev
SVP, Product Management
Posts: 26289
Liked: 4100 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: System freeze every time during copy at 99%

Post by Gostev »

Hi, this is due to VMware removing snapshot, there are quite a few existing topics about this issue > http://www.veeam.com/forums/search.php? ... oval+issue

BITuBIT
Influencer
Posts: 15
Liked: never
Joined: Nov 26, 2010 2:46 pm
Full Name: Leonardo
Contact:

Re: System freeze every time during copy at 99%

Post by BITuBIT »

Hi Gostev,

thanks for your fast and useful reply, I have investigated more about this problem and I have seen that the problem happen when the hostA reach the 95% of "Removing snapshot"; I have seen that some user suggest to set ctkEnabled = "FALSE" in .vmx file of this virtual machine but I'm not pretty sure that is a right manner to solve this problem. Furthermore I cannot accesso via SSH to this ESXi host that is in a server farm so far from here.
Could you suggest the right step to solve it definitely ?
Many thanks,


Leonardo

Alexey D.

Re: System freeze every time during copy at 99%

Post by Alexey D. »

Hello Leonardo,

Have you had a chance to explore this (and ongoing) topic?
Many VM's dropping packets losing pingstate during rep/back

By the way, SSH connection to ESXi is officially unsupported by VMware.

Gostev
SVP, Product Management
Posts: 26289
Liked: 4100 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: System freeze every time during copy at 99%

Post by Gostev »

BITuBIT wrote:ctkEnabled = "FALSE" in .vmx file of this virtual machine
This would disable changed block tracking on the virtual machine, so yes this can hardly be considered as a solution.
BITuBIT wrote:Could you suggest the right step to solve it definitely ?
I can suggest contacting VMware support since the issue here is with native VMware functionality.

BITuBIT
Influencer
Posts: 15
Liked: never
Joined: Nov 26, 2010 2:46 pm
Full Name: Leonardo
Contact:

Re: System freeze every time during copy at 99%

Post by BITuBIT »

Hi Alexey, Hi Gostev,

many thanks for your reply, I don't have vmware tools installed on that virtual machine. Maybe that can help me ? Actually I'm using 2 ESXi 4.0.0 the free disk space in hostA is 504,8 GB. When the system freeze (don't respond a ping command or something else), I have this task:
Remove snapshot
hostA
Completed
root
25/01/2011 16.32.19
25/01/2011 16.32.19
25/01/2011 16.34.46

For 2minutes the hostA does not appear up! ;(

If i browse the datastore, into a folder hostA I can see some file called:
hostA-Snapshot71.vmsn
hostA-000002.vmdk
hostA-000003.vmdk
hostA-Snapshot8.vmsn
hostA-000004.vmdk
hostA-Snapshot13.vmsn
hostA-000005.vmdk
hostA-Snapshot26.vmsn

Is possible to remove all snapshot manually ?

This morning I have also submitted a System request into the difficult Vmware support system and I'm waiting for their reply.
Thanks a lots for your help...I keep you update when I receive a reply from vmware support.

Gostev
SVP, Product Management
Posts: 26289
Liked: 4100 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: System freeze every time during copy at 99%

Post by Gostev »

You should definitely upgrade to ESXi 4.1 as well, as reportedly it further removes snapshot removal handling.

And I did not realize you have existing snapshots - this is definitely what is causing long hangs on snapshot removal, I found this issue myself shortly after vSphere release. You should remove all those snapshots using Remove All in vSphere Client... if you cannot see any snapshots, create new one manually with vSphere Client, and they should appear. If you still cannot see snapshots, VMware has support KB article on how to remove those, it is even linked somewhere on this forums.

Vitaliy S.
Product Manager
Posts: 23997
Liked: 1786 times
Joined: Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov
Contact:

Re: System freeze every time during copy at 99%

Post by Vitaliy S. »

Leonardo, these VMware KB articles should help:
http://kb.vmware.com/kb/1012383
http://kb.vmware.com/kb/1007849

Thanks!

BITuBIT
Influencer
Posts: 15
Liked: never
Joined: Nov 26, 2010 2:46 pm
Full Name: Leonardo
Contact:

Re: System freeze every time during copy at 99%

Post by BITuBIT »

Finally I have solved all my problem. Just for information I have removed all snapshot into first host and then everything works fine.
Many thanks for you help.

Alexey D.

Re: System freeze every time during copy at 99%

Post by Alexey D. »

Leonardo, thanks for posting back.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 19 guests