Comprehensive data protection for all workloads
Gostev
SVP, Product Management
Posts: 24092
Liked: 3278 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by Gostev » Jan 24, 2019 11:32 pm

mkretzer wrote:
Jan 24, 2019 11:09 pm
Maybe a new bug in GA?
Highly unlikely, as the GA build itself had twice as many downloads than RTM already :) and with over 10000 downloads, I'd expect at least a few hundreds support cases by now for any real upgrade bug that is not a corner case.

BLC
Influencer
Posts: 10
Liked: 1 time
Joined: Mar 01, 2017 4:56 pm
Full Name: Bryan Chapnick
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by BLC » Jan 25, 2019 12:27 am

I am having the same problem. I upgraded Veeam ONE... No issue. I then tried to upgrade EM and the install failed. I re-tried and the installer hung and froze.

UPDATE: So I rebooted the server then tried to install Veeam B&R (EM was greyed out). The install was successful.

I then tried to install EM again and it still fails. I will be opening up a SR.

Gostev
SVP, Product Management
Posts: 24092
Liked: 3278 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by Gostev » Jan 25, 2019 12:33 am

All, please remember to include support case ID for your "+1s" to be actionable. Thanks!

chris_lalala
Novice
Posts: 7
Liked: 2 times
Joined: Jun 26, 2013 8:12 am
Full Name: Chris
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by chris_lalala » Jan 25, 2019 9:15 am

Same Problem here with GA Version.

Last Jobs were successful. Same error when try to upgrade EM.

Code: Select all

[25.01.2019 10:07:31][INFO] Exception occurred (Veeam products installation section).
Info: System.ComponentModel.Win32Exception (0x80004005): Fatal error during installation
   at Veeam.Setup.MsiLibrary.VmMsiCommon.CheckError(VmMsiDatabase db, UInt32 result)
   at Veeam.Setup.MsiLibrary.VmMsiCommon.InstallProduct(String product, String commandLine, Boolean& bReboot)
   at Veeam.Setup.Wizard.VmInstallProduct.RunInstallation(Boolean& bReboot)
   at Veeam.Setup.Wizard.VmInstallEngine.Install(ShowControlFunc showActionData, Boolean bRepair, Boolean bUpgrade, VmDialogEngineHandler m_dialogEngineHandler)
   at Veeam.Setup.Wizard.PredefinedDialogs.VmInstallDialog.m_installWorker_DoWork(Object sender, DoWorkEventArgs e)
[25.01.2019 10:07:31][INFO] Starting services...
[25.01.2019 10:07:31][INFO] Services have been started.

engedib
Service Provider
Posts: 10
Liked: 5 times
Joined: Jan 04, 2019 2:40 am
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by engedib » Jan 25, 2019 10:09 am

Gostev wrote:
Jan 25, 2019 12:33 am
All, please remember to include support case ID for your "+1s" to be actionable. Thanks!
My case ID: 03375628
Forgot to copy the detailed log, but it failed at one part of the database schema extension, then it displayed the downgrade detected error.

Gostev
SVP, Product Management
Posts: 24092
Liked: 3278 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by Gostev » Jan 25, 2019 4:34 pm 1 person likes this post

The log above is actually not relevant (which is why we ask not to post random log snippet on the forums, they are usually of no use but they do trash the forums). However, looking at the relevant log file in the debug log package from a support case - thanks for opening btw - we think this may be OS locale specific bug with date/time conversion.

Overall, we have only had 1 (one) support case open on this issue before @engedib opened the second one. So, certainly does not look like a common issue at this time with 11312 downloads and counting.

Will keep you posted.

engedib
Service Provider
Posts: 10
Liked: 5 times
Joined: Jan 04, 2019 2:40 am
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by engedib » Jan 26, 2019 12:19 am

Should I retry the upgrade after changing the locale and time / date format from en-NZ to en-US?

DaveWatkins
Expert
Posts: 336
Liked: 89 times
Joined: Dec 13, 2015 11:33 pm
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by DaveWatkins » Jan 26, 2019 6:10 pm 1 person likes this post

Hmm, I'm in NZ too.... so it's another +13GMT bug because we're in daylight savings currently. No one ever expects +13 :)

engedib
Service Provider
Posts: 10
Liked: 5 times
Joined: Jan 04, 2019 2:40 am
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by engedib » Jan 27, 2019 1:27 am

Don't want to imagine what would happen with those Veeam boxes on the Chathams :D (GMT +13:45)

mkretzer
Expert
Posts: 468
Liked: 100 times
Joined: Dec 17, 2015 7:17 am
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by mkretzer » Jan 27, 2019 8:24 am

So - are all users who have seen this in that timezone? It should be "safe" for the rest?

infused
Service Provider
Posts: 107
Liked: 4 times
Joined: Apr 20, 2013 9:25 am
Full Name: Hayden Kirk
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by infused » Jan 28, 2019 12:52 am

Happened on two of my production boxes. All jobs are disabled and no failed jobs.

Going to open support case now (case id 03383348)

Edit: I'm also in New Zealand.
http://www.infused.co.nz - My Blog.

Gostev
SVP, Product Management
Posts: 24092
Liked: 3278 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by Gostev » Jan 28, 2019 12:55 am

@mkretzer seeing yet another .nz domain in Hayden's signature, I guess this is the answer to your question!

BLC
Influencer
Posts: 10
Liked: 1 time
Joined: Mar 01, 2017 4:56 pm
Full Name: Bryan Chapnick
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by BLC » Jan 28, 2019 1:33 pm 1 person likes this post

I am having the same problem. I upgraded Veeam ONE... No issue. I then tried to upgrade EM and the install failed. I re-tried and the installer hung and froze.

UPDATE: So I rebooted the server then tried to install Veeam B&R (EM was greyed out). The install was successful.

I then tried to install EM again and it still fails. I will be opening up a SR.

I opened up support request #03381416. The technician has me do a port scan on the Veeam server. The local server was accessing port 9443, so he recommended stopping the World Wide Publishing Service. That did the trick! EM install was successful.

gambit120
Service Provider
Posts: 7
Liked: never
Joined: Feb 29, 2016 3:01 am
Full Name: Paul
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by gambit120 » Jan 29, 2019 1:30 am

Yeah I saw this as well. I ended up uninstalling VBR and just installing the new version and 2016 SQL Express from scratch. Imported the config file afterwards. Luckily it was one of our small VBR instances. We have 2 more big prod environments 500-100VM's which I think I will leave for the meantime :-)

Rick_M
Novice
Posts: 7
Liked: never
Joined: Aug 29, 2016 10:54 pm
Contact:

Re: Upgrade from 9.5U3 to 9.5U4 failed with "Database version downgrade detected"

Post by Rick_M » Jan 29, 2019 5:20 am

I had the same issue - due to some Veeam Services using a service account instead of System.

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot], restore-helper and 7 guests