vCloud 5.1 backup broken after KB3172614/KB3161606

Availability for the Always-On Enterprise

vCloud 5.1 backup broken after KB3172614/KB3161606

Veeam Logoby EvanWaite » Sat Jul 30, 2016 8:25 am 3 people like this post

I wanted to give a quick heads up about an issue we ran into today after applying July's windows patches to our Veeam B&R server (2012R2 running Veeam B&R v9 U1). The patch causing the issue is July 2016 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 (KB3172614) but it also would surface with June 2016 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 (KB3161606).

Issue:
After applying the patch listed above, our vCloud backup job failed with the following error
Code: Select all
Task failed. Error: vCloud Director server is not accessible

We also saw the following logged in the Windows event log
Code: Select all
Log Name:      System
Source:        Schannel
Date:          7/30/2016 1:07:53 AM
Event ID:      36888
Task Category: None
Level:         Error
Keywords:     
User:          SYSTEM
Computer:      <removed>
Description:
A fatal alert was generated and sent to the remote endpoint. This may result in termination of the connection. The TLS protocol defined fatal error code is 40. The Windows SChannel error state is 808.


This lead to some posts indicating TLS 1.0 is disabled by the patch (breaking many products).

Fix/Workaround:
Due to the old (and unsupported) vCloud 5.1.x version we have, the only option we had was uninstalling the patch. I can confirm removing KB3172614 and rebooting fixed our issue. I wouldn't be surprised if this issue occurs with older vCenter versions as well but haven't seen it.

Hope that helps someone along the way :D
EvanWaite
Lurker
 
Posts: 2
Liked: 3 times
Joined: Sun Aug 21, 2011 3:32 am
Full Name: Evan Waite

Re: vCloud 5.1 backup broken after KB3172614/KB3161606

Veeam Logoby Gostev » Sun Jul 31, 2016 12:07 am

Thanks for the heads up!
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: vCloud 5.1 backup broken after KB3172614/KB3161606

Veeam Logoby lukklin » Wed Sep 21, 2016 1:48 pm

Thanks, for sharing..had the same issue :-)
lukklin
Service Provider
 
Posts: 15
Liked: 1 time
Joined: Thu Sep 03, 2015 8:16 am
Full Name: Lukas Klinger

Re: vCloud 5.1 backup broken after KB3172614/KB3161606

Veeam Logoby tqmbill » Sun Jan 29, 2017 12:24 am

I have the same exact error message, but it is affecting Veeam ONE.
I just upgraded from v9.0 to v9.5 but around the same time I installed some Win2012R2 updates and even ESXi 6.0 U1 to U2. So can't pinpoint the true cause. I only noticed problems after all that. Symptom in Veeam ONE 9.5 is absence of data from hosts and VMs, i.e. CPU, memory, disk etc.
Another anomaly is that I am at the moment still running Veeam B&R at v9.0 as its upgrade crashed... awaiting tech support session in 2 days time.
So, while this doesn't fit the original post, it's maybe close enough that a googler will find it.
I'll report back results after removing the KB3172614 update, which I had installed 3 months ago with no Veeam ONE problems.
tqmbill
Novice
 
Posts: 5
Liked: never
Joined: Sun Jan 29, 2017 12:15 am
Full Name: Bill Cox

Re: vCloud 5.1 backup broken after KB3172614/KB3161606

Veeam Logoby tqmbill » Sun Jan 29, 2017 4:00 pm

So far, they report back is that it may have helped, but it is so far in conclusive. I think in my particular case it's more likely a problem with the failed Upgrade of B&R
tqmbill
Novice
 
Posts: 5
Liked: never
Joined: Sun Jan 29, 2017 12:15 am
Full Name: Bill Cox


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Exabot [Bot], Yahoo [Bot] and 18 guests