Comprehensive data protection for all workloads
Post Reply
Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Veeam (linux) disable log

Post by Acu »

Hi,
I have linux server (slackware) and virtual PC with veeam B&R. Each Veeam backup creates a log folder in the var \ log \ veeambackup \ folder. Veeam creates a log (very large) for each backup.
Is it possible not to log these events at all? Is it possible to disable the log?

HannesK
Veeam Software
Posts: 11264
Liked: 2135 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Veeam (linux) disable log

Post by HannesK »

Hello,
and welcome to the forums.

Setting the maximum log file size (logsMaxSize) in /etc/veeam/veeam.ini should reduce the amount of space used (not sure what "very large" large is though)

Best regards,
Hannes

Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Re: Veeam (linux) disable log

Post by Acu »

Hello,
the veeam folder does not exist in /etc
I just found in /opt/veeam/transport

Karel

Mildur
Veeam Software
Posts: 3576
Liked: 1186 times
Joined: May 13, 2017 4:51 pm
Full Name: Fabian K.
Location: St. Gallen, Switzerland
Contact:

Re: Veeam (linux) disable log

Post by Mildur »

It should be under /etc if this kb is correct:

https://www.veeam.com/kb1825
*6. The size of an agent log file.

Location: /etc/VeeamAgentConfig
Name: AgentMaxLogSize
Data: in BYTES
Default: 15728640

*7. Amount of the agent rollback files

Location: /etc/VeeamAgentConfig
Name: AgentMaxLogCount
Data: <numeric value>
Default: 10
Or are they only used for Veeam B&R components?
Product Management Analyst @ Veeam Software

HannesK
Veeam Software
Posts: 11264
Liked: 2135 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Veeam (linux) disable log

Post by HannesK »

Hello,
I moved the topic to the VBR forum. It looks like Veeam Agent for Linux is not used (I was about to post that /var/log/veeambackup/folder does not exist for me for Veeam Agent for Linux. As you say, that you don't have /etc/veeam and that you have /opt/veeam/... I'm pretty sure that we talk about a repository or proxy server here.

What Fabian posted should do the job, yes.

Best regards,
Hannes

Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Re: Veeam (linux) disable log

Post by Acu »

On the station with veeam, I set the value in the "AgentLogging" registers to "0"
Logging in Linux has stopped, but now when I want to back up via SMB, it writes an error Error: Dir path is not full

Logging also takes place at the station where veeam is, and in addition I get an e-mail report and that's enough for me. I don't need to log anything on the linux side.
I would like to turn off logging or redirect it to network storage.

PetrM
Veeam Software
Posts: 2263
Liked: 364 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: Veeam (linux) disable log

Post by PetrM »

Hi Karel,

I don't recommend to disable logging as our support will not be able to troubleshoot a technical issue without debug logs, if something is broken due to whichever reason. Could you please clarify which specific log files are too large and how much space do these logs consume? Also, did you try to adjust logging settings as per the KB1825 suggested by Fabian?

Thanks!

Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Re: Veeam (linux) disable log

Post by Acu »

I don't know exactly how to use it under Linux. I would have to create the files because they do not exist.
So can't it just be redirected elsewhere?

PetrM
Veeam Software
Posts: 2263
Liked: 364 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: Veeam (linux) disable log

Post by PetrM »

Hi Karel,

I'll try to find out whether it is possible to redirect log files to another location or not but could you please clarify which files do not exist and what are you going to create? If it's related to the "Dir path is not full" error, then it will be better to contact our support team and ask our engineers to troubleshoot the issue.

Thanks!

Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Re: Veeam (linux) disable log

Post by Acu »

I have a linux server (UnRaid-Slackware) running virtual (Windows) with veeam on this server.
I used to back up data and photos using SMB, but I found that when I add shared disks as a "File server", data transfer is several times faster.
The problem with some "File server" backups, however, was that when I only want to make incremental backups, it always does a full backup.
But this does not happen with SMB. The problem with SMB, however, is that the log on the Linux server "UnRaid" (running from a flash drive) creates logs of individual tasks in \ var \ log \ veeambackup for each task.
The log on the server reports in 3 days that it is full and the server seems to be slowed down. But I'm running veeam from a virtual PC, I don't need logs in a linux server.

Or the second option to solve why backups created via the "File server" are not just increments.

PetrM
Veeam Software
Posts: 2263
Liked: 364 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: Veeam (linux) disable log

Post by PetrM » 1 person likes this post

Hi Karel,

First of all, I've found a registry setting to change log location, it must be applied on the Veeam server:
LinAgentLogFolder
HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Backup and Replication
REG_SZ
Default value: "/var/log/VeeamBackup"

Well, if you're using File Share backup and it always creates full, it's definitely not normal and must be investigated by our support team. Basically, only the first run of file share backup job is performed in full mode. All subsequent runs process data changed since the previous backup session. Please review this page of our help center.

What I'd suggest to do is to contact our support team and ask our engineers to investigate both issues: unexpected file share backups in full mode and the problem with logs consuming extra space.

Thanks!

Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Re: Veeam (linux) disable log

Post by Acu » 1 person likes this post

Great Petr with this I redirected the logging elsewhere:
LinAgentLogFolder
HKEY_LOCAL_MACHINE\SOFTWARE\Veeam\Veeam Backup and Replication
REG_SZ
Default value: "/var/log/VeeamBackup"

I will return to the "File server" backup
It is special when backing up data via "File server" the file creation date has a date 01.01.1601 1:00

PetrM
Veeam Software
Posts: 2263
Liked: 364 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: Veeam (linux) disable log

Post by PetrM »

Hi Karel,

Ok, thanks for information! Could you please clarify what exact file are you talking about, whose creation date is weird? Not sure that I fully understood the question.

Thanks!

Acu
Novice
Posts: 7
Liked: 1 time
Joined: Oct 27, 2021 11:25 pm
Full Name: Karel Snitz
Contact:

Re: Veeam (linux) disable log

Post by Acu »

I'm sending a photo here https://ibb.co/yXtTc2S.

When I add a File share as a "File server" and then back up something, I will issue another backup file date in the backup, see the photo.
This only happens for backups added from the "File server", for backups added as SMB everything is fine but the backup takes longer.
The main problem with "File server" backups is that when I back up photos, for example, everything is backed up every day, not just changes. I wondered if the creation date had any effect on that.

PetrM
Veeam Software
Posts: 2263
Liked: 364 times
Joined: Aug 28, 2013 8:23 am
Full Name: Petr Makarov
Location: Prague, Czech Republic
Contact:

Re: Veeam (linux) disable log

Post by PetrM »

Karel, thanks for clarification but I think that the best way is to open a support request, the described behavior does not seem to be expected.

Thanks!

Post Reply

Who is online

Users browsing this forum: Diego.wachholz, magnunfs, Majestic-12 [Bot] and 46 guests