Comprehensive data protection for all workloads
Post Reply
kellison
Enthusiast
Posts: 25
Liked: never
Joined: Dec 22, 2009 5:56 pm
Full Name: Ken Ellison
Contact:

Veeam Ver4.1 Backup fails Virtual Appliance

Post by kellison » Dec 22, 2009 6:13 pm

I have a total of 45 VM's - using VSphere 4 that spans across 3 ESX Host - running on IBM HS22 Blades connected to an IBM XIV via Fiber. I have 6 VM's that I am not able to run a backup using the Virtual Appliace option. If I select the "San w/failover" option the backup will work but is much slower. The VM's range in size and the Windows operating system. 2 of them were P to V's, 2 I moved them from my ESX 3.2 to the 4 and one is a new VM Windows 2003 DataCtr. As I go through the setup I select the destination as a backup LUN that all 3 of my ESX hosts knows about. (example: /vmfs/volumes/VSphere_Domino_Backup) - The Domino server (which is a new VM) has 800GB of data to backup and the LUN to backup to has 1.70TB free space so I know it is not because of limited available space. When I start the backup below is the error message. Can someone help me with this? I opened a case ticket with Veeam and their first suggestion was to upgrade to Ver 4.1 which I did and the other option was: Hello Ken,

If you are using vCenter Server earlier than version 4.1, a helper VM named “VMName(VCB-HELPER)” must also be created on the same ESX server where Veeam Backup VM is running. The helper VM is a blank dummy VM without virtual disks or OS installed. This VM is only used to temporarily hot-add disks of backed up VMs to.

Thank you for contacting Veeam Support.


Here is the error log...

5 of 14 files processed

Total VM size: 800.00 GB
Processed size: 12.52 KB
Processing rate: 0 KB/s
Backup mode: HOTADD without changed block tracking
Start time: 12/22/2009 8:40:23 AM
End time: 12/22/2009 8:42:32 AM
Duration: 0:02:09

Enabling changed block tracking...
Changed block tracking cannot be enabled: virtual hardware version 7 or later required.

Backing up file "[Vshpere_Domino2] wcadomino01/wcadomino01-flat.vmdk"
BackupDisk failed
Client error: Failed to open VDDK disk [[Vshpere_Domino2] wcadomino01/wcadomino01.vmdk] ( is read-only mode - [true] )
Logon attempt with parameters [VC/ESX: [172.21.255.92];Port: 902;Login: [root];VMX Spec: [moref=96];Snapshot mor: [96-snapshot-3];Transports: [hotadd]] failed because of the following errors:

Server error: Failed to open VDDK disk [[Vshpere_Domino2] wcadomino01/wcadomino01.vmdk] ( is read-only mode - [true] )
Logon attempt with parameters [VC/ESX: [172.21.255.92];Port: 902;Login: [root];VMX Spec: [moref=96];Snapshot mor: [96-snapshot-3];Transports: [hotadd]] failed because of the following errors:
Failed to process VM disk backup. VMDK path: [vddk://<vddkConnSpec><viConn name="172.21.255.92" authdPort="902" vicPort="443" /><vmxPath vmRef="96" datacenterRef="ha-datacenter" datacenterInventoryPath="ha-datacenter" snapshotRef="96-snapshot-3" datastoreName="Vshpere_Domino2" path="wcadomino01/wcadomino01.vmx" /><vmdkPath datastoreName="Vshpere_Domino2" path="wcadomino01/wcadomino01.vmdk" /><transports seq="hotadd" /><readBuffer size="2097152" /></vddkConnSpec>].

Gostev
SVP, Product Management
Posts: 24473
Liked: 3413 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by Gostev » Dec 22, 2009 6:36 pm

Ken, we are unable to provide technical assistance on complex technical environment-specific issues via forum, because they require full logs research and/or webex. Please continue working with our support on this issue. If your issue is not resolved within reasonable timeframe, please let me know via a personal message. Thank you.

withanh
Expert
Posts: 262
Liked: never
Joined: Jul 21, 2009 3:19 pm
Full Name: Darhl
Location: Pacific Northwest
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by withanh » Dec 28, 2009 10:11 pm

Anton,

According to Ken, support told him if he was running vCenter Server lower than 4.1 he needed the VCB-Helper, but the latest version of vCenter Server on the VMware site is 4.0 Update 1. Is this what he is referring to, or did he possibly mean Veeam Backup 4.1?
Hello Ken,

If you are using vCenter Server earlier than version 4.1, a helper VM named “VMName(VCB-HELPER)” must also be created on the same ESX server where Veeam Backup VM is running. The helper VM is a blank dummy VM without virtual disks or OS installed. This VM is only used to temporarily hot-add disks of backed up VMs to.

Thank you for contacting Veeam Support.
I'm asking because I'm starting to play with Virtual Appliance mode and am so far seeing good results, but am running VCenter 4.0 (no update yet). I want to make sure I'm setting this up properly and if I need a different version of vCenter I want to get that going right away.

My results so far?
First/full backup using Virtual Appliance:
Total VM size: 356.00 GB
Processed size: 356.00 GB
Processing rate: 82 MB/s
Backup mode: HOTADD with changed block tracking
Start time: 12/28/2009 10:43:55 AM
End time: 12/28/2009 11:57:53 AM
Duration: 1:13:58

Second/incremental backup using Virtual Appliance: (granted it's only a couple of hours later, but WOW)
Total VM size: 356.00 GB
Processed size: 356.00 GB
Processing rate: 1 GB/s
Backup mode: HOTADD with changed block tracking
Start time: 12/28/2009 1:34:15 PM
End time: 12/28/2009 1:39:57 PM
Duration: 0:05:41

Thanks for clarifying!

Darhl
For every expert there is an equal and opposite expert - Arthur C Clarke's Fourth Law

Gostev
SVP, Product Management
Posts: 24473
Liked: 3413 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by Gostev » Dec 28, 2009 11:38 pm

Hi Darhl, he probably meant Veeam Backup 4.1...
VCB-HELPER appliance is not needed if you have vCenter Server 4.0 or later.

Gostev
SVP, Product Management
Posts: 24473
Liked: 3413 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by Gostev » Dec 28, 2009 11:49 pm

OK, after some research looks like the error was caused during the User Guide update to version 4.1, as I can see the same error there. Looks like search-replace from 4.0 to 4.1 affected vCenter version. :)

I will ask to fix the documentation.

withanh
Expert
Posts: 262
Liked: never
Joined: Jul 21, 2009 3:19 pm
Full Name: Darhl
Location: Pacific Northwest
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by withanh » Dec 29, 2009 12:11 am

Good, because it seemed like it was working for me.
For every expert there is an equal and opposite expert - Arthur C Clarke's Fourth Law

Gostev
SVP, Product Management
Posts: 24473
Liked: 3413 times
Joined: Jan 01, 2006 1:01 am
Location: Baar, Switzerland
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by Gostev » Dec 29, 2009 11:19 pm

User Guide is updated in Veeam.com around Virtual Appliance mode - the documentation bug discussed above is fixed, plus a couple of common questions answered/clarified.

withanh
Expert
Posts: 262
Liked: never
Joined: Jul 21, 2009 3:19 pm
Full Name: Darhl
Location: Pacific Northwest
Contact:

Re: Veeam Ver4.1 Backup fails Virtual Appliance

Post by withanh » Dec 30, 2009 3:08 am

Cool, thanks :-)
For every expert there is an equal and opposite expert - Arthur C Clarke's Fourth Law

Post Reply

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 18 guests