Virtual lab doesn't start

Availability for the Always-On Enterprise

Virtual lab doesn't start

Veeam Logoby tomhkr » Mon Jun 26, 2017 7:49 am

A "friendly coworker" rebooted our Veeam backup & replication server when a Surebackup job was running.
We're using this virtual lab for testing new release of software to a specific environment.

After reboot, the Surebackup job was of course no longer running. The temporary VM's lost their disks and snapshots and days of work is gone.
After much trouble I managed to delete the defunct VMs. I then tried to restart the Surebackup job but it didn't start.
I thought the Virtual lab was defunt so I deleted it and built a new one.

This one doesn't start either. Partial error message is below.
I have checked the Broker service and it is running, the firewall rule is active and should work.
What more can I do?

[26.06.2017 09:12:09] <01> Error Failed to Lock. VLabId: [eec6742a-ea40-4466-9b39-ed8779f45f39], JobId: [24317635-4c43-4330-aac7-75e370b96466], TTL: [4200 sec]
[26.06.2017 09:12:09] <01> Error Server stack trace:
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Common.CExceptionUtil.RegenTraceExc(Exception originalExc, String formatString, Object[] args)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Service.CVirtualLabLockServiceStub.Veeam.Backup.Interaction.Management.IVirtualLabLockService.Lock(Guid vlabId, Guid jobId, String jobName, TimeSpan ttl)
[26.06.2017 09:12:09] <01> Error at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
[26.06.2017 09:12:09] <01> Error at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
[26.06.2017 09:12:09] <01> Error Exception rethrown at [0]:
[26.06.2017 09:12:09] <01> Error at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
[26.06.2017 09:12:09] <01> Error at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Interaction.Management.IVirtualLabLockService.Lock(Guid vlabId, Guid jobId, String jobName, TimeSpan ttl)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Interaction.Management.Client.CVirtualLabLockServiceProxy.<>c__DisplayClass4.<Veeam.Backup.Interaction.Management.IVirtualLabLockService.Lock>b__3()
[26.06.2017 09:12:09] <01> Error at Veeam.Common.Remoting.CRetryableMethod.<>c__DisplayClass1.<DoInvoke>b__0()
[26.06.2017 09:12:09] <01> Error at Veeam.Common.Remoting.CRetryableMethod.DoInvoke[Ret](ActionDelegate`1 dlg)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Interaction.Management.Client.CVirtualLabLockServiceProxy.Veeam.Backup.Interaction.Management.IVirtualLabLockService.Lock(Guid vlabId, Guid jobId, String jobName, TimeSpan ttl)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.SureBackup.CViSbJobPerformer.LockVirtualLab(IViSbJobPerformerConfig config)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.SureBackup.CViSbJobPerformer.Perform()
[26.06.2017 09:12:09] <01> Error Failed to load virtual lab lock at Veeam.Backup.Service.CVirtualLabLockEx.Load(CSoapConnection conn, String vmRef)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Service.CVirtualLabLockService.CheckLock_(CSoapConnection soapConn, CViSbVirtualLab vlab, Action`1 action)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Service.CVirtualLabLockService.Veeam.Backup.Interaction.Management.IVirtualLabLockService.Lock(Guid vlabId, Guid jobId, String jobName, TimeSpan ttl)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Service.CVirtualLabLockServiceStub.Veeam.Backup.Interaction.Management.IVirtualLabLockService.Lock(Guid vlabId, Guid jobId, String jobName, TimeSpan ttl)
[26.06.2017 09:12:09] <01> Error Connection to 'Veeam Broker Service' is not available, host 'bksrv01', port '9501' at Veeam.Common.Remoting.CReconnectableMethod.AttemptFail(Exception networkExc, Boolean& isErrHandled)
[26.06.2017 09:12:09] <01> Error at Veeam.Common.Remoting.CRetryableMethod.DoInvoke[Ret](ActionDelegate`1 dlg)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Core.SVeeamBaseService`1.DoCheckBackwardCompatibility()
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Core.SVeeamBaseService`1.DoCheckCompatibility()
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Core.SVeeamBaseService`1.DoCheckConnectivity(CConnection connParams, CRemoteClient remoteClient)
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Core.SVeeamBaseService`1.get_Session()
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Core.SHierarchyLoaderFactory.GetBrokerService()
[26.06.2017 09:12:09] <01> Error at System.Lazy`1.CreateValue()
[26.06.2017 09:12:09] <01> Error --- End of stack trace from previous location where exception was thrown ---
[26.06.2017 09:12:09] <01> Error at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
[26.06.2017 09:12:09] <01> Error at System.Lazy`1.get_Value()
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Core.CServiceHostHierarchyLoader.ForceReload()
[26.06.2017 09:12:09] <01> Error at Veeam.Backup.Service.CVirtualLabLockEx.Load(CSoapConnection conn, String vmRef)
[26.06.2017 09:12:09] <01> Error No connection could be made because the target machine actively refused it
tomhkr
Enthusiast
 
Posts: 38
Liked: 7 times
Joined: Mon Feb 03, 2014 7:40 am

Re: Virtual lab doesn't start

Veeam Logoby vmniels » Mon Jun 26, 2017 8:12 am 1 person likes this post

Best would be to contact support for help here. Also please don't post any log snippets as this is usually case specific (it looks like the broker service is not running on the Veeam server in this case).
VCP-DCV
Veeam Certified Engineer
http://foonet.be
vmniels
Veeam Software
 
Posts: 1475
Liked: 322 times
Joined: Mon Jul 15, 2013 11:09 am
Full Name: Niels Engelen

Re: Virtual lab doesn't start

Veeam Logoby tomhkr » Mon Jun 26, 2017 9:13 am

Okay, I submitted a case and let's see what that gives.
tomhkr
Enthusiast
 
Posts: 38
Liked: 7 times
Joined: Mon Feb 03, 2014 7:40 am


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Bing [Bot] and 28 guests