VIX Error: One of the parameters was invalid Code: 3

Availability for the Always-On Enterprise

VIX Error: One of the parameters was invalid Code: 3

Veeam Logoby hyvokar » Thu Sep 29, 2016 11:26 am

Hi!

I'm trying to use AAIP on a VM that has no network connectivity to veeam-server.


29.9.2016 13:59:19 :: Processing VM1 Error: Cannot connect to host [vcenter.local] over VIX. Login: [domain.local\vcenter_admin]. Guest Login: [.\administrator].
Failed to login to VM: [[SAN1-VOL1] VM1.vmx]. User: [.\administrator].
VIX Error: One of the parameters was invalid Code: 3


This was working previously, before we upgraded from vcenter/esxi 5.5 to 6 patch3.

Any ideas?

Case # 01918330
Bed?! Beds for sleepy people! Lets get a kebab and go to a disco!
MS MCSA, MCITP, MCTS, MCP
VMWare VCP5-DCV
Veeam VMCE
hyvokar
Service Provider
 
Posts: 254
Liked: 15 times
Joined: Fri Nov 21, 2014 10:05 pm

Re: VIX Error: One of the parameters was invalid Code: 3

Veeam Logoby hyvokar » Thu Sep 29, 2016 12:13 pm 1 person likes this post

Ok, it seems that something has changed.

Solved this with your support.

.\administrator as an user account doesn't seem to work anymore so I have to use servername\administrator account. This is a bit of an annoynce, since now I have to make a ton of new accounts on veeam server.
Bed?! Beds for sleepy people! Lets get a kebab and go to a disco!
MS MCSA, MCITP, MCTS, MCP
VMWare VCP5-DCV
Veeam VMCE
hyvokar
Service Provider
 
Posts: 254
Liked: 15 times
Joined: Fri Nov 21, 2014 10:05 pm

Re: VIX Error: One of the parameters was invalid Code: 3

Veeam Logoby mma » Thu Dec 01, 2016 1:32 pm

Thanks for the post, have the same issue on various installations... :-/
mma
Service Provider
 
Posts: 58
Liked: 10 times
Joined: Thu Dec 22, 2011 9:12 am
Location: Lucerne, Switzerland
Full Name: Marcel

Re: VIX Error: One of the parameters was invalid Code: 3

Veeam Logoby hyvokar » Sun Dec 04, 2016 8:24 pm

Any change this could be changed on the future versions? Would make my life a lot easier.
Bed?! Beds for sleepy people! Lets get a kebab and go to a disco!
MS MCSA, MCITP, MCTS, MCP
VMWare VCP5-DCV
Veeam VMCE
hyvokar
Service Provider
 
Posts: 254
Liked: 15 times
Joined: Fri Nov 21, 2014 10:05 pm

Re: VIX Error: One of the parameters was invalid Code: 3

Veeam Logoby Gostev » Sun Dec 04, 2016 9:29 pm

hyvokar wrote:This was working previously, before we upgraded from vcenter/esxi 5.5 to 6 patch3.

Sounds like the change is in vSphere itself then, so not sure we can do anything from our side. However, VIX API has been discontinued starting vSphere 6.5, so we will be using the new API for this and later vSphere version. There's a chance that the new API does not have this limitation - something for us to test.
Gostev
Veeam Software
 
Posts: 21390
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: VIX Error: One of the parameters was invalid Code: 3

Veeam Logoby hyvokar » Sun Dec 04, 2016 9:34 pm

I'm not a coder, but a simplest way I guess would be to check if the login contains . and replace it from VMs domain name from vcenter and use that combination as a login.
Bed?! Beds for sleepy people! Lets get a kebab and go to a disco!
MS MCSA, MCITP, MCTS, MCP
VMWare VCP5-DCV
Veeam VMCE
hyvokar
Service Provider
 
Posts: 254
Liked: 15 times
Joined: Fri Nov 21, 2014 10:05 pm


Return to Veeam Backup & Replication



Who is online

Users browsing this forum: Yahoo [Bot] and 30 guests