Disaster recovery orchestration for the Enterprise (formerly Veeam Availability Orchestrator)
Post Reply
chjones
Expert
Posts: 117
Liked: 31 times
Joined: Oct 30, 2012 7:53 pm
Full Name: Chris Jones
Contact:

Only one datastore detected as NetApp

Post by chjones »

I have deployed Veeam DRO 5.0 for a customer also running Veeam B&R 11a.

Their production site has two LUNs presented from the same ONTAP SVM (using ONTAP 9.9.1). There are two Veeam Backup jobs, one for each datastore, which succeed.

The backup jobs create local ONTAP snapshots then update a Mirror-Vault relationship successfully (the jobs create both SnapMirror and SnapVault copies at the destination), then also mount the Vault destination and write to a SOBR. This all works.

I’ve add vSphwre tags and can see them in Veeam DRO and have also added both ONTAP SVMs to DRO.

The customer actually has two iSCSI LUNs presented from ONTAP storage at both datacenters.

In the DRO Console, in the Inventory, the first datastore at each site shows with a NetApp icon next to it yet the second datastore at both sites does not.

When I create a DR Location and add the target SVM and click Info I only see the first datastore as being protected. I can’t get the second one to also be recognised.

When creating a Storage DR Plan I only get the first datastore as a choice, never the second one.

The DR plan works and can failover for the first datastore.

Both SnapMirror relationships for the two datastores use the same policy and are of the same type. There are no visible differences between them and Veeam B&R has no issue backing them up and replicating the storage.

I’m not sure where to look to investigate this or have any clue as to why only one datastore is detected as ONTAP and the other isn’t.

Has anyone come across this?

Thanks,
Chris

HannesK
Veeam Software
Posts: 10715
Liked: 2031 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Only one datastore detected as NetApp

Post by HannesK »

Hello,
I’m not sure where to look to investigate this
what did support say (case number)?

Best regards,
Hannes

chjones
Expert
Posts: 117
Liked: 31 times
Joined: Oct 30, 2012 7:53 pm
Full Name: Chris Jones
Contact:

Re: Only one datastore detected as NetApp

Post by chjones »

We're waiting for a response from support. I dont have the case number, sorry, it was submitted under the customer's Veeam account which I dont have access to at the moment. I'll see if I can get it.

chjones
Expert
Posts: 117
Liked: 31 times
Joined: Oct 30, 2012 7:53 pm
Full Name: Chris Jones
Contact:

Re: Only one datastore detected as NetApp

Post by chjones »

The Case Number is 05224378. The customer is working to respond back to support's questions.

chjones
Expert
Posts: 117
Liked: 31 times
Joined: Oct 30, 2012 7:53 pm
Full Name: Chris Jones
Contact:

Re: Only one datastore detected as NetApp

Post by chjones »

So, support are still working on this and we're told it's with Engineering. From what we know so far, Veeam DRO queries vCenter for the list of datacentres and retrieves the first iSCSI IP from vCenter and discards the rest. vCenter seems to return the IPs numerically, so in an MPIO configuration the same IP is always returned first from a HA Pair of ONTAP controllers.

In ONTAP, there are iSCSI IPs on each controller in the HA Pair, and it appears Veeam DRO is querying for the LUN and Volume and then requests a list of iSCSI IPs. ONTAP appears to return the iSCSI IPs of the Controller that is hosting the LUN, which do not always match the IP returned from vCenter.

We tested this by shutting down the iSCSI LIFs on Controller A in ONTAP and rescanned our datastores. vCenter only saw two paths to the LUN, via Controller B. Veeam DRO rescanned the inventory and then detected the second datastore as an ONTAP LUN. However, this then breaks the first datastore which was working previously, as it is hosted on Controller A.

Hopefully there can be a patch or workaround to resolve this. Veeam B&R queries vCenter and ONTAP and seems to have no issues correlating the objects, however, Veeam DRO seems to be doing the process differently.

HannesK
Veeam Software
Posts: 10715
Liked: 2031 times
Joined: Sep 01, 2014 11:46 am
Full Name: Hannes Kasparick
Location: Austria
Contact:

Re: Only one datastore detected as NetApp

Post by HannesK »

Hello,
yes, I looked at the case status last week. As developers are already involved, there is nothing to add from my side.

If a hotfix is not possible, it's a good idea to ask for the bug number. Then it can easily be checked later if the bug is fixed.

Best regards,
Hannes

chjones
Expert
Posts: 117
Liked: 31 times
Joined: Oct 30, 2012 7:53 pm
Full Name: Chris Jones
Contact:

Re: Only one datastore detected as NetApp

Post by chjones » 1 person likes this post

We received some updated files from support that appear to have resolved this issue. Support also confirmed this fix will be included in the next major release.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest