Issue Opening Nworks Management Center

Unleash the power of System Center for vSphere and Hyper-V | Veeam Task Manager for Hyper-V

Issue Opening Nworks Management Center

Veeam Logoby depot210 » Wed Oct 06, 2010 6:33 pm

Hello everyone,

We are experiencing the following issue when opening the nWorks Management Center. A pop up appears after log in with the following message: "Index was outside the bounds of the array."

The pages that do not work and produce this error are the Dashboard and Monitoring Jobs tabs.

We tried opening the Management Center from various browsers and workstations but the same result. The nworks logs or windows logs are not showing any events related to this issue.

Any help in this matter is greatly appreciated.

Regards,
CA
depot210
Novice
 
Posts: 5
Liked: never
Joined: Fri Jun 18, 2010 7:53 pm
Full Name: Depot

Re: Issue Opening Nworks Management Center

Veeam Logoby Vitaliy S. » Thu Oct 07, 2010 8:09 am

Hello,

Try removing maindb.xml and re-open the nWorks Management Center, should help! Below are all the paths where you can find this file.

For Windows 2008:
Code: Select all
C:\ProgramData\nworks\Management Center\maindb.xml

For Windows 2003:
Code: Select all
C:\Documents and Settings\All Users\Application Data\nworks\Management Center\maindb.xml

Thank you!
Vitaliy S.
Veeam Software
 
Posts: 19564
Liked: 1103 times
Joined: Mon Mar 30, 2009 9:13 am
Full Name: Vitaliy Safarov

Re: Issue Opening Nworks Management Center

Veeam Logoby depot210 » Thu Oct 07, 2010 3:13 pm

Vitaliy,

Thanks for the reply. I tried your suggested fix but unfortunately the issue remains. Any other suggestions? Again thanks for your input.

Regards,
CA
depot210
Novice
 
Posts: 5
Liked: never
Joined: Fri Jun 18, 2010 7:53 pm
Full Name: Depot

Re: Issue Opening Nworks Management Center

Veeam Logoby Irina Simkina » Thu Oct 07, 2010 3:27 pm

Hello Depot,

after you removed the maindb.xml did you get the issue immidiately or after adding targets?

Irina
Irina Simkina
Enthusiast
 
Posts: 51
Liked: never
Joined: Tue Apr 20, 2010 9:00 am
Full Name: Irina Simkina

Re: Issue Opening Nworks Management Center

Veeam Logoby Alec King » Thu Oct 07, 2010 3:36 pm

Hi Depot,

When you removed maindb.xml did you first stop the nworks Enterprise Manager service?

If not, then your maindb configuration will have been stored in memory anyway. And Enterprise Manager service would simply write it back to the file.

You have to stop the service, delete the file, then restart the service, in order to clean your nworks config.

PLEASE NOTE - this will delete ALL of your targets (vCenter connection(s)), and return all settings to default.
You will have to add your Virtual Center server again.

Let us know if that solves the problem for you,

Thanks!
Alec
Alec King
Vice President, Product Management
Veeam Software
Alec King
Veeam Software
 
Posts: 700
Liked: 116 times
Joined: Sun Jan 01, 2006 1:01 am

Re: Issue Opening Nworks Management Center

Veeam Logoby depot210 » Thu Oct 07, 2010 4:41 pm

Alec,

Thanks for the clarification. We will put in the proper change control and apply the fix once approved.

Regards,
Carlos
depot210
Novice
 
Posts: 5
Liked: never
Joined: Fri Jun 18, 2010 7:53 pm
Full Name: Depot

Re: Issue Opening Nworks Management Center

Veeam Logoby depot210 » Mon Oct 11, 2010 6:47 pm

Alec,

We implemented the fix as detailed in your log post and it fixed the issue. But now when we try to add our Vcenter connection, we are receiving the following error: "Unknown API version: '4.1' & product: 'vpx'"

Any idea on how to resolve this issue?

Thanks

"
depot210
Novice
 
Posts: 5
Liked: never
Joined: Fri Jun 18, 2010 7:53 pm
Full Name: Depot

Re: Issue Opening Nworks Management Center

Veeam Logoby Gostev » Mon Oct 11, 2010 9:31 pm

AFAIK vSphere 4.1 is only supported by nworks 5.5.2 or later
Gostev
Veeam Software
 
Posts: 21396
Liked: 2349 times
Joined: Sun Jan 01, 2006 1:01 am
Location: Baar, Switzerland

Re: Issue Opening Nworks Management Center

Veeam Logoby Alec King » Mon Oct 11, 2010 11:25 pm

Hi - that's correct, we implemented support for vCenter 4.1 in our nworks 5.5.2 version. If you have vCenter 4.1 please upgrade by downloading the latest version from http://www.veeam.com/downloads/

Cheers,
Alec
Alec King
Veeam Software
 
Posts: 700
Liked: 116 times
Joined: Sun Jan 01, 2006 1:01 am

Re: Issue Opening Nworks Management Center

Veeam Logoby depot210 » Tue Oct 12, 2010 7:04 pm

Alec and everyone, thanks for your assistance.

We upgraded our nworks software to the latest version and all is well.

Regards,
Depot210
depot210
Novice
 
Posts: 5
Liked: never
Joined: Fri Jun 18, 2010 7:53 pm
Full Name: Depot


Return to Veeam Management Pack for Microsoft System Center



Who is online

Users browsing this forum: No registered users and 4 guests