nworks Collector: VC-API Performance Link Connection Status

Unleash the power of System Center for vSphere and Hyper-V | Veeam Task Manager for Hyper-V

nworks Collector: VC-API Performance Link Connection Status

Veeam Logoby Christopher Keyaert » Mon Jul 04, 2011 9:13 am

Hi Everyone,

So, I've got a little, with one located in Atlanta (our primary site is in Belgium).

When I check my collector everything seems to work fine, this collector monitor 2000 objects, but I receive a lot of alerts like the ones below, around 80 alerts per 24hours.
These alerts auto-close in less than 10 min, but that generates a lot of incidents in our Servers Team queue.

Do you have any advise ? Which threshold may I increase ?

Thank you
Bests Regards
Christopher

VP210 Datacomm connection lost to VC target atlvc001.dir.ucb-group.com. The VMware API error returned was 'The underlying connection was closed: A connection that was expected to be kept alive was closed by the server., Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. at nworksCollector.Collectors.EsxPerfCollector40.performanceDaemon()'. No performance data will be obtained from this source until connection can be restored.


This event generated by the nworks collector
For more information see http://veeam.com/support/events.aspx?EvtID=96


VP210 Datacomm connection lost to VC target atlvc001.dir.ucb-group.com. The VMware API error returned was 'The operation has timed out at nworksCollector.Collectors.EsxPerfCollector40.performanceDaemon()'. No performance data will be obtained from this source until connection can be restored.


This event generated by the nworks collector
For more information see http://veeam.com/support/events.aspx?EvtID=96
Christopher Keyaert
Enthusiast
 
Posts: 30
Liked: never
Joined: Thu Jul 15, 2010 9:33 am
Full Name: Christopher Keyaert

Re: nworks Collector: VC-API Performance Link Connection Sta

Veeam Logoby Alec King » Thu Jul 07, 2011 10:27 am

Hi Christopher,

Well, if you are monitoring over the WAN, you could have latency or delays in the network causing a timeout.

If so, then the timeout setting for all Collectors is in Enterprise Manager.

In our UI, go to Enterprise Manager tab, and select Enterprise Manager node. Click Advanced Settings button and you will find 'Net Timeout'.

Default is 210 seconds, you can try increasing to 300, or 400.

However - I'd always advise opening a support case. Increasing the timeout might not be dealing with some root cause configuration issue.

Let me know how it goes!

Thanks,
Alec
Alec King
Vice President, Product Management
Veeam Software
Alec King
Veeam Software
 
Posts: 700
Liked: 116 times
Joined: Sun Jan 01, 2006 1:01 am

Re: nworks Collector: VC-API Performance Link Connection Sta

Veeam Logoby Christopher Keyaert » Thu Jul 07, 2011 12:11 pm

Alec King wrote:Hi Christopher,

Well, if you are monitoring over the WAN, you could have latency or delays in the network causing a timeout.

If so, then the timeout setting for all Collectors is in Enterprise Manager.

In our UI, go to Enterprise Manager tab, and select Enterprise Manager node. Click Advanced Settings button and you will find 'Net Timeout'.

Default is 210 seconds, you can try increasing to 300, or 400.

However - I'd always advise opening a support case. Increasing the timeout might not be dealing with some root cause configuration issue.

Let me know how it goes!

Thanks,
Alec

Thank you Alec, I just checked and the value was set to 120, this value was may be the one by default from a previous release ? I did a upgrade from 5.5 to 5.6.
I reset it to the default value, 210, and I will see now, if i still have the alert.

Thank you
Christopher Keyaert
Enthusiast
 
Posts: 30
Liked: never
Joined: Thu Jul 15, 2010 9:33 am
Full Name: Christopher Keyaert

Re: nworks Collector: VC-API Performance Link Connection Sta

Veeam Logoby Christopher Keyaert » Mon Jul 11, 2011 9:04 am

I confirm that's working perfectly now. I really don't know why I was not using the default value ;-)

Thank you.
Christopher Keyaert
Enthusiast
 
Posts: 30
Liked: never
Joined: Thu Jul 15, 2010 9:33 am
Full Name: Christopher Keyaert

Re: nworks Collector: VC-API Performance Link Connection Sta

Veeam Logoby Alec King » Mon Jul 11, 2011 10:13 am

excellent news Christopher, thanks! :)
Alec King
Veeam Software
 
Posts: 700
Liked: 116 times
Joined: Sun Jan 01, 2006 1:01 am


Return to Veeam Management Pack for Microsoft System Center



Who is online

Users browsing this forum: No registered users and 2 guests